7.7 Изменить значение реквизита справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 21 мар 2012.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Подскажите пожалуйста как мне изменить значения реквизитов "Кор.ПервПок". необходимо заменить значение 25,00 на 25,99 Эталонные значения разносил следующей обработкой.

    Код:
    Процедура ПоНорме()
    ТрСр= СоздатьОбъект ("Справочник.Транс");
    КорЭталон= СоздатьОбъект ("Справочник.Кор");
    
    
    Кор= СоздатьОбъект ("Справочник.Кор");
    
    ТрСр.ВыбратьЭлементы();
    Пока   ТрСр.ПолучитьЭлемент()=1   Цикл
    Сообщить("!!! " +ТрСр);
    Если (ТрСр.ТекущийЭлемент()<>ТрЭтал) Тогда
    Кор.ИспользоватьВладельца(ТрСр.ТекущийЭлемент());
    КорЭталон.ИспользоватьВладельца(ТрЭтал);
    
    КорЭталон.ВыбратьЭлементы(1);
    Пока   КорЭталон.ПолучитьЭлемент()=1   Цикл
    
    Кор.Новый();
    Кор.Код= КорЭталон.Код;
    Кор.Наименование= КорЭталон.Наименование;
    Кор.ПервПок= КорЭталон.ПервПок;
    Кор.СледПок= КорЭталон.СледПок;
    Кор.ЕдИзм = КорЭталон.ЕдИзм;
    Кор.Записать();
    
    КонецЦикла;
    // Прервать ;
    КонецЕсли;
    КонецЦикла;
    
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура Изменить()
    НачатьТранзакцию();
    Кор= СоздатьОбъект ("Справочник.Кор");
    
    Кор.ВыбратьЭлементы();
    Пока   Кор.ПолучитьЭлемент()=1   Цикл
    
    Если Кор.ПервПок= 25 Тогда
    Кор.ПервПок= 25.99;
    Кор.Записать(); 
    КонецЕсли;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    КонецПроцедуры
  3. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Забыл добавить что справочник кор является подчиненным справочнику транс. обработка не работает
  4. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    задача выполнена

    Код:
    Процедура Изменить()
    Кор= СоздатьОбъект ("Справочник.Кор");
    Кор.ВыбратьЭлементы(0);
    Пока  Кор.ПолучитьЭлемент()=1   Цикл
    сообщить(" в"+Кор);
    Если Кор.ПервПок= 5 Тогда
    Кор.ПервПок= 5.99;
    Кор.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

Поделиться этой страницей