8.х Изменить регистр наименования в справочнике

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем SkyNetYar, 28 апр 2016.

  1. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Добрый день! УТ 11.1
    По требованию Яндекс Маркета необходимо причесать все наименования в справочнике номенклатура.
    А конкретнее те наименования которые содержат заглавные переделать в меньший регистр.
    К примеру:
    СОСИСКА МЯСНАЯ --> Сосиска мясная
    Подскажите идеи,есть обработка которая просто меняет регистр ,даже так СОСИСКА -->сосиска а надо бы первую букву оставлять заглавной.
    Код:
    &НаСервереБезКонтекста
    Процедура СделатьНаСервере()
        // Вставить содержимое обработчика.
      
    Выборка = Справочники.Номенклатура.Выбрать();
    н=0;
    Пока Выборка.Следующий() Цикл
        Объект = Выборка.ПолучитьОбъект();
      
        ИзменяемоеИмя = НРег(Объект.Наименование);   // делаем всё строчними(нижним регистром)
        Сообщить("1= "+ИзменяемоеИмя);
      
        Объект.Наименование = ТРег(Лев(ИзменяемоеИмя,2))+Сред(ИзменяемоеИмя,3); // берем первых два символа нименования и первый из них делаем Заглавным
        Сообщить("2= "+Объект.Наименование);
      
        Попытка
            Объект.Записать();
        Исключение
            Сообщить("ваш текст сообщения");
        КонецПопытки;
      
        н=н+1;
        Если н=110 Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
      
    КонецПроцедуры
    
    &НаКлиенте
    Процедура Сделать(Команда)
        СделатьНаСервере();
    КонецПроцедуры
    
    Помогите допилить пожалуйста.
  2. TopicStarter Overlay
    SkyNetYar
    Offline

    SkyNetYar Опытный в 1С

    Регистрация:
    11 ноя 2014
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Пока решил проблему обработкой с инфостарта http://infostart.ru/public/172585/ ,правда она под обычные формы,но это не проблема, запустился в обычном приложении свою конфигурацию и обработал.
    Но вопрос актуален, попробую подсмотреть в той обработке,она правда делает либо все строчными,потом правда можно сделать первую заглавной. в 2 операции.
  3. Petrony
    Offline

    Petrony Новичок в 1С

    Регистрация:
    29 апр 2016
    Сообщения:
    5
    Симпатии:
    1
    Баллы:
    4
    Вот здесь нужно исправить
    Объект.Наименование = ТРег(Лев(ИзменяемоеИмя,2))+Сред(ИзменяемоеИмя,3); // берем первых два символа нименования и первый из них делаем Заглавным
    на

    Объект.Наименование = ВРег(Лев(ИзменяемоеИмя,1))+Сред(ИзменяемоеИмя,2);

Поделиться этой страницей