8.х Изменить цвет текста в ячейке табилчной части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Serge, 11 сен 2008.

  1. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерия предприятия 1.6.8.3
    Необходимо поменять цвет текста в одной ячейке ТЧ. Каким образом получить доступ к свойству "Цвет" только одной этой ячейки?
    Делаю таким образом:

    Код:
    Красный = Новый Цвет(255, 0, 0);
    ЭлементыФормы.ТабличнаяЧасть.ТекущаяКолонка.ЭлементУправления.ЦветТекстаПоля = Красный;
    
    Тип данных в ячейке - СправочникССылка.Номенклатура либо Строка, во втором случае текст должен быть красным. Когда печатаешь текст, он красный, нажимаешь Enter - опять становится черный. Что я делаю не так?
  2. zaiko99@mail.ru
    Offline

    zaiko99@mail.ru

    Регистрация:
    4 сен 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Тебе надо пользоваться методом ПриВыводеСтроки - там в ОформленииСтроки - задашь нужной ячейке нужный парметр.
  3. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    Теперь программа вылетает при входе в эту функцию! (ТабличнаяЧастьПриВыводеСтроки). Режим предприятия закрывает к чертям, никаких сообщений. Мелькает на экране какое-то окошко, не успеваю разглядеть. В логах ничего нет, антивирус выгружал и все прочее.
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код-то покажи...
  5. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ТабличнаяЧастьПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Вот собственно и все. Ни один оператор процедуры не выполняется, вылетает сразу же при входе в процедуру.
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    А что внутри процедуры?
  7. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ТабличнаяЧастьПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ТипЗнч(ЭлементыФормы.ТабличнаяЧасть.ТекущаяСтрока.Номенклатура) = Тип("Строка") Тогда
    Красный = Новый Цвет(255, 0, 0);
    ЭлементыФормы.ТабличнаяЧасть.ОформлениеСтроки(ЭлементыФормы.ТабличнаяЧасть.ТекущаяСтрока).Ячейки.Номенклатура.ЦветТекста = Красный;
    Иначе
    Авто = Новый Цвет (0, 0, 0);
    ЭлементыФормы.ТабличнаяЧасть.ОформлениеСтроки(ЭлементыФормы.ТабличнаяЧасть.ТекущаяСтрока).Ячейки.Номенклатура.ЦветТекста = Авто;
    КонецЕсли;
    КонецПроцедуры
    
  8. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Вот это:
    ЭлементыФормы.ТабличнаяЧасть.ОформлениеСтроки
    в топку - перепишите нормально
  9. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    А сразу параметр ОформлениеСтроки нельзя использовать???

    Код:
    Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ОформлениеСтроки.Ячейки.Наименование.ЦветТекста = Новый Цвет(255,0,0);
    КонецПроцедуры
    

Поделиться этой страницей