8.х Изменить цвет фона строк табличной части Не ПриПолученииДанных и Не ПриВыводеСтроки

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем russlix, 6 апр 2012.

  1. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Добрый день.

    Существует две таблицы в документе для осуществеления взаимозачетов между контрагентами по документам расчета.
    В одной таблице Дебетовые документы, а в другой Кредитовые.

    Необходимо, чтобы ПриАктивизацияСтороки() одной таблицы в другой таблице в определенный цвет закрашивались строки по документам которых был осуществлен взаимозачет.

    Это не работает:
    Код:
    Для Каждого ТекСтр Из Дебет Цикл
    ЭлементыФормы.Дебет.ОформлениеСтроки(ТекСтр).ЦветФона = WebЦвета.БледноЗеленый;
    
    КонецЦикла
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    пример раскраски:

    Код:
    Процедура ТабличнаяЧасть1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ДанныеСтроки.Номенклатура.ЭтоГруппа Тогда
    ОформлениеСтроки.ЦветФона   = Новый Цвет(204,255,255);
    ОформлениеСтроки.Шрифт   = Новый Шрифт(ОформлениеСтроки.Шрифт,,,истина)
    КонецЕсли;
    
    КонецПроцедуры
  3. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Тогда как мне приАктивизацииСтроки одной таблицы вызвать У другой Вывод всех строк?
  4. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    нуу.. например, ПриАктивацииСтроки() элемента формы ТабличноеПоле1 вызвать обновление всей формы. а в событие ПриПолученииДанных() элемента формы ТабличноеПоле2 добавить раскраску..
  5. TopicStarter Overlay
    russlix
    Offline

    russlix

    Регистрация:
    15 авг 2008
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Разобрался - ПриАктивизацииСтроки одной таблицы происходит событие ПриВыводеСтроки у всех таблиц.
    Короче все работает.

Поделиться этой страницей