7.7 Изменения периодических реквизитов - документом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем phcode, 17 июл 2011.

  1. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Добрый день, подскажите пожалуйста как реализовать изменения периодических реквизитов - документом.
    Есть например, специальный документ, в табличной части которого указывается «наименование материала»и «влажность» этого материала.

    При проведение этого документа, везде в где встречаются это «наименование материала» в справочнике НормыРасходов, изменялся бы периодический реквизит влажность. (В НормахРасходов).

    конфа Произвoдствo и Уcлуги.

    хотя бы саму идею, как это можно реализовать.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Смотрите метод УстановитьРеквизитСправочника
  3. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Вот, что у меня получилось:
    Код:
    Процедура ОбработкаПроведения()
    
    // Здесь следует написать алгоритм проведения документа
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    УстановитьРеквизитСправочника(Материал, "ФактВлаж", ФактВлажность, ДатаДок); //Материал - реквизит, тип значение, которого = Справочник.НормыРасходов
    КонецЦикла;
    
    
    КонецПроцедуры
    
    
    при проведение, периодический реквизит меняются тока в одной Норме Расходов, принадлежащей одной номенклатуре.

    Не подскажите, как сделать так, чтобы по всех Нормах Расхода, где встречается этот Материал, менялся периодический реквизит?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
  5. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерский угодник, она самая.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вообще-то НормыРасходов - подчиненный справочник Номенклатуры.
    Вы его как в табличной части заполняете - с учетом владельца?
  7. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Наверно да, при выборе материала, программа сначала спрашивает владельца (номенклатуру), затем элемент нормы расходов.
    Т.е. если подбирать материалы без учета владельца, все будет нормально работать? как это сделать?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Наоборот - это не нормально будет.

    По примеру в посте №3 - все должно работать.
  9. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерский угодник, да все и работает я не жалуюсь.
    Вопрос в другом, как во всех справочниках НормыРасходов, не взирая на владельцев, там где встречается это норма (Материал совпадает), изменить периодический реквизит.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    По справочнику НормаыРасходов применит метод ВыбратьЭлементы(0). В этом режиме родитель не учитывается
  11. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    если не трудно подскажите, где и как применить этот метод?
    в табличной части, где выбирается Материал (НормаРасхода), или в модули проведения документа?
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Разумеется в модуле проведения....
    Перебираем нормы расходов всей БД и сравниваем материал из ТЧ документа.
  13. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Вроде, все так сделал, а вылазит ошибка:

    Код:
    // ********************
    //
    Процедура ОбработкаПроведения()
    
    // Здесь следует написать алгоритм проведения документа
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    //ВыбратьЭлементы(0);
    СпрНормы = СоздатьОбъект("Справочник.НормыРасходов");
    //СпрНормы.ИспользоватьВладельца();
    СпрНормы.ВыбратьЭлементы(0);
    
    Пока СпрНормы.ПолучитьЭлемент()=1 Цикл
    Если СпрНормы.Наименование=Материал.Наименование Тогда
    Предупреждение("Нашел!");
    Материал0 = СпрНормы.ТекущийЭлемент();
    УстановитьРеквизитСправочника(Материал0, "ФактВл", ФактическаяВлажность, ДатаДок); //Материал - реквизит, тип значение, которого = Справочник.НормыРасходов
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;	
    КонецПроцедуры
    
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Отстутствует реквизит в справочнике, или он не периодический, или не может меняться документом
  15. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерский угодник, спасибо большое за поддержку и помощь!
Похожие темы
  1. Steel Rain
    Ответов:
    1
    Просмотров:
    3.727
  2. registration
    Ответов:
    1
    Просмотров:
    657
  3. Olga_programmer
    Ответов:
    6
    Просмотров:
    1.516
  4. Mirvel
    Ответов:
    9
    Просмотров:
    1.387
  5. sergey484
    Ответов:
    2
    Просмотров:
    1.604
Загрузка...

Поделиться этой страницей