8.х УПП Изменение шапки отчета

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем invistik, 20 авг 2013.

  1. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    Помогите разобраться 1С УПП 1.3.38.4 не могу понять есть отчет Расчетные листки организации нужно дописать в шапке информацию, но в макете самой шапки нет, есть только табличная часть где взять шапку?
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    в отчете есть СКД, а в СКД - макет, а в макете - Шапка
  3. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    извините туплю как найти СКД что бы посмотреть у него отчет?
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Отчет открываете у него там где Наименование, Полное наименование ниже есть поле Основная схема компановки данных и кнопка Открыть схему
  5. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    да я понял но там нет шапки она вызывается

    // Вывод заголовка отчета
    //
    Процедура ВыводЗаголовкаОтчета(Результат, ВыводВФормуОтчета = Истина) Экспорт

    Если РасширеннаяНастройка Тогда
    Возврат;
    КонецЕсли;

    ЗначениеПараметра = КомпоновщикНастроек.Настройки.ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("TitleOutput"));
    ВыводитьЗаголовок = (ЗначениеПараметра.Значение = ТипВыводаТекстаКомпоновкиДанных.Выводить И ЗначениеПараметра.Использование);

    Если Не ВыводВФормуОтчета И Не ВыводитьЗаголовок Тогда
    Возврат;
    КонецЕсли;


    МакетЗаголовок = ПолучитьОбщийМакет("ЗаголовокТиповогоОтчета");
    ОбластьЗаголовок = МакетЗаголовок.ПолучитьОбласть("Заголовок");
    ЗаголовокОтчета = КомпоновщикНастроек.Настройки.ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Title")).Значение;
    ОбластьЗаголовок.Параметры.ЗаголовокОтчета = ЗаголовокОтчета;
    Результат.Вывести(ОбластьЗаголовок);

    КонецПроцедуры
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Почему нет. у СКД есть вкладка макет, там есть Область ШапкаРасчетногоЛистка: Заголовок

    Просто смотря какя шапка Вам нужна
  7. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    для наглядности приведу примеры макет и сам отчет красным отмечено то что нужно отредактировать

    Вложения:

  8. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Тогда это да в том коде. а что надо изменить?

    если тупо напишите


    МакетЗаголовок = ПолучитьОбщийМакет("ЗаголовокТиповогоОтчета");
    ОбластьЗаголовок = МакетЗаголовок.ПолучитьОбласть("Заголовок");
    ЗаголовокОтчета = "Вот что я написал"
    ОбластьЗаголовок.Параметры.ЗаголовокОтчета = ЗаголовокОтчета;
    Результат.Вывести(ОбластьЗаголовок);

    То выйдет "Вот что я написал"
  9. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    нужно дописать в отчет с права в верху маленькими буквами

    Приказ №20 от 29.12.2012г. «Об учетной политике на 2013г»
  10. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    У Вас расчетные лиски - внешний отчет? если нет, то советую сохранить как внешний

    В него скопировать макет ЗаголовокТиповогоОтчета и уже там добавить в него вверху вправо
    и уже вместо


    МакетЗаголовок = ПолучитьОбщийМакет("ЗаголовокТиповогоОтчета");
    ОбластьЗаголовок = МакетЗаголовок.ПолучитьОбласть("Заголовок");


    МакетЗаголовок = ЭтотОбъект.ПолучитьМакет("ЗаголовокТиповогоОтчета");
    ОбластьЗаголовок = МакетЗаголовок.ПолучитьОбласть("Заголовок");


    Это что бы вам меньше конфу ломать. Либо заводите еще один общий макет в конфе или прямо в отчете и подтяигайте его. В общем макете ЗаголовокТиповогоОтчета ничего не меняйте т.к он во многих отчетах учавствует.
  11. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    это всё я сделал только вот не понял как добавлять в верху с лева.
  12. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    в самом макете зайдите и там вверху слева пропишите - у вас же эта надпись будет постоянна и меняться не будет
  13. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    я сделав внешний отчет расчетные листки но не могу найти макет ЗаголовокТиповогоОтчета

  14. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    В конфигурации в Общих макетах
  15. TopicStarter Overlay
    invistik
    Offline

    invistik Опытный в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    114
    Симпатии:
    0
    Баллы:
    26
    Всё разобрался!!! Draco спасибо, респект и уважуха!!!
  16. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Всегда пожалуйста. Спасибо.
Похожие темы
  1. UltrasSlim
    Ответов:
    25
    Просмотров:
    3.767
  2. saha25
    Ответов:
    7
    Просмотров:
    924
Загрузка...

Поделиться этой страницей