7.7 Изменение "Обработка.ЗакрытиеКассовойСмены" 1С 7.7 ТиС

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Link, 20 апр 2009.

  1. TopicStarter Overlay
    Link
    Offline

    Link

    Регистрация:
    3 авг 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток. как можно сделать чтобы обработка не загружала дубли из выгруженного отчета о продажах? допустим в файле о продажах записано следующее

    725;15.04.09;12:03:38;11;1;2321;4;680;1;999;1;999; !!
    726;15.04.09;12:04:03;30;1;2321;4;680;1;2498;0;999; !!
    727;15.04.09;12:04:31;40;1;2321;4;0;741;0;1;999;
    728;15.04.09;12:04:31;55;1;2321;4;0;0;0;0;999;
    729;15.04.09;12:37:40;11;1;2322;4;2540;1;366;1;366;
    775;16.04.09;19:32:11;55;1;2336;2;0;0;0;0;2998;
    776;16.04.09;19:48:54;60;1;2337;2;304;0;4992;0;9988;
    777;16.04.09;19:49:27;51;1;2338;2;0;0;0;0;4992;
    778;16.04.09;19:49:47;61;1;2339;2;742;0;0;0;9988;
    725;15.04.09;12:03:38;11;1;2321;4;680;1;999;1;999; !!
    726;15.04.09;12:04:03;30;1;2321;4;680;1;2498;0;999; !!

    те строки которые я пометил знаком "!!" обработка загрузит дважды, надо чтобы он как то определил что последние две строки (именно в этом случае две последние строки) загружать не надо.думаю можно чтоб он проверял по номеру транзакции, но как это сделать не знаю... обработку прикрепил...

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Думаю нужно применить фильтр
    Код:
    Функция ДатьИндекс(Стр)
    Поз=Найти(Стр,";");
    Если Поз=0 Тогда
    Возврат "";
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе		</span>
    Возврат Лев(Стр,Поз-1);
    КонецЕсли;
    КонецФункции
    
    .......
    Исключения=СоздатьОбъект("СписокЗначений");
    .......
    стр=//ты получил строку из файла
    Индекс=ДатьИндекс(Стр);
    Если ПустоеЗначение(Индекс)=0 Тогда //не форматная строка
    Продолжить;
    КонецЕсли;
    Если Исключения.НайтиЗначение(Индекс)<>0 Тогда //уже было
    Продолжить;	
    КонецЕсли;
    Исключения.ДобавитьЗначение(Индекс);      
    //твори....
    
    
  3. TopicStarter Overlay
    Link
    Offline

    Link

    Регистрация:
    3 авг 2007
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    не могу разобраться куда вставить данный код......=(
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В твоей обработке вообще нет обращения к какому-либо внешнему файлу. Поэтому не знаю.
    Я выложил тебе пример написания фильтра - дальше думай сам.....
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    или рассказывай дальше, как происходит процесс импорта данных из-в, причем, желательно, по шагам.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Добрый я смотрю ты человек, душевный)))))))))
  7. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29

Поделиться этой страницей