8.х Изменение документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем OIT, 26 фев 2008.

  1. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Можно ли программным путем создавать документ "Прием на работу в организацию" или
    хотя бы редактировать У меня выдает сообщение Ошибка при вызове метода контекста(Добавить)
    Объект недоступен для изменения
    Благодарю Вас
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Конфигурация? Платформа? Конфа типовая/измененная?
    телепатов тут нет...
  3. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    НовыйДокумент = Документы.ПриемНаРаботуВОрганизацию.СоздатьДокумент();
    // заполняем реквизиты
    // например
    НовыйДокумент.Дата = ТекущаяДата();
    //......
    // записываем документ
    НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);
    
    
    
  4. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    1C Предприятие 8.1 ЗУП Конфиг 2.5.7
    Документ создается пустой
    но работник не загружается выдает сообщение объект недоступен для изменеия
    Благодарю Вас
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Понятнее не стало :) Но хоть знаем с чем работаем :)
    Давайте теперь посмотрим код, который вызывает такую ошибку, код в студию!
  6. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Вот программа в которой пытаюсь добавить в документ работников и выходит
    сообщение объект не доступен для изменения
    Код:
    Процедура СформироватьОперации() Экспорт 
    Если тзДанных.Количество()=0 Тогда
    ПрочитатьИзФайла(ИмяФайла);        
    КонецЕсли;
    Для каждого СтрокаДанных Из тзДанных Цикл
    ФИО=СтрокаДанных.Фамилия;
    НайденныйСотрудник = Справочники.СотрудникиОрганизаций.НайтиПоНаименованию(ФИО,Истина);
    ОбъектДок=Документы.ПриемНаРаботуВОрганизацию.НайтиПоНомеру("КАФ00000001", Дата(2008, 2, 22));
    ОбъектДок.ПолучитьОбъект();
    НоваяЗапись=ОбъектДок.РаботникиОрганизации.Добавить();
    НоваяЗапись.Сотрудник=НайденныйСотрудник;
    ОбъектДок.Записать();
    КонецЦикла;
    КонецПроцедуры
    
    
    Благодарю Вас
  7. vlashi
    Offline

    vlashi Опытный в 1С

    Регистрация:
    18 янв 2008
    Сообщения:
    143
    Симпатии:
    0
    Баллы:
    26
    Попробуй так:
    Код:
     
    Процедура СформироватьОперации() Экспорт
    Если тзДанных.Количество()=0 Тогда
    ПрочитатьИзФайла(ИмяФайла);
    КонецЕсли;
    Для каждого СтрокаДанных Из тзДанных Цикл
    ФИО=СтрокаДанных.Фамилия;
    НайденныйСотрудник = Справочники.СотрудникиОрганизаций.НайтиПоНаименованию(ФИО,Истина);
    ОбъектДок=Документы.ПриемНаРаботуВОрганизацию.НайтиПоНомеру("КАФ00000001", Дата(2008, 2, 22));
    ИзмДок = ОбъектДок.ПолучитьОбъект();  // изменил
    НоваяЗапись=ИзмДок.РаботникиОрганизации.Добавить(); // Кстати что такое новая запись?
    НоваяЗапись.Сотрудник=НайденныйСотрудник;
    ИзмДок.Записать(); // изменил
    КонецЦикла;
    КонецПроцедуры
    
    
    
    
    И еще, пользуйся тэгом CODE

Поделиться этой страницей