7.7 Изменение даты констант

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AD1986, 30 июл 2012.

  1. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Добрый день подскажите пожалуйста есть справочник валюты есть значение валют я хочу внести валюту но тремя днями назад тоесть нужно что бы можно было выбрать да ту константы. Проблема в том что когда устанавливаешь валюту то она берет дату сегодняшнею и изменить нельзя подскажите как изменить.
    Код:
    Процедура глРедактироватьИсториюЗначений(Конт, Реквизиты = "", Заголовок = " ", Просмотр = 0, ДляГрупп=0) Экспорт
    Перем Спр;
    Если Конт.Выбран() = 0 Тогда
    Предупреждение("Просмотр истории значений возможен только для записанного элемента.");
    Возврат;
    ИначеЕсли (ДляГрупп=0) И (Конт.ЭтоГруппа() = 1) Тогда
    Возврат;
    КонецЕсли;
    СЗ = СоздатьОбъект("СписокЗначений");
    СЗ.ДобавитьЗначение(Конт, "Контекст");
    СЗ.ДобавитьЗначение(Реквизиты, "Реквизиты");
    СЗ.ДобавитьЗначение(Заголовок, "Заголовок");
    Если Конт.Форма.ТолькоПросмотр() = 1 Тогда
    Просмотр = 1;
    КонецЕсли;
    СЗ.ДобавитьЗначение(Просмотр, "Просмотр");
    ОткрытьФорму("Отчет.СписокПериодическихРеквизитов#"+ЗначениеВСтрокуВнутр(Конт.ТекущийЭлемент()), СЗ);
    КонецПроцедуры //глРедактироватьИсториюЗначений

    и сам модуль



    Код:
    //_____________________________________________________________________________
    Процедура ПриВыбореФайла()
    ИмяФайла = ИмяФайлаПрописи;
    Каталог = КаталогИБ();
    ВыборФайла = 0;
    Пока ВыборФайла = 0 Цикл
    ФС.ВыбратьФайл(0,ИмяФайла,Каталог,"Выберите файл прописи для валюты """+Наименование+"""","Файлы прописи(*.spl)|*.spl");
    Если СокрП(Нрег(Каталог)) <> СокрП(Нрег(КаталогИБ())) Тогда
    Предупреждение("Выберите файл только из каталога "+КаталогИБ()+" !");
    Каталог = КаталогИБ();
    Иначе
    ВыборФайла = 1;
    ИмяФайлаПрописи = ИмяФайла;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    //_____________________________________________________________________________
    Процедура ПоказатьИсторию()
    глРедактироватьИсториюЗначений(Контекст,
    "Курс,
    |Кратность",
    "История периодических реквизитов ("+ТекущийЭлемент()+")",1);
    КонецПроцедуры //ПоказатьИсторию
    //_____________________________________________________________________________
    
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Что-то я вообще не вижу кода установки значения реквизита справочника...

    Необходимо создать ссылку на элемент справочника, спозиционировать его. Использовать метод "Установить" (устанавливает новое значение на нужную дату) и записать.

Поделиться этой страницей