8.х Изменение цвета статуса заказа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем malcevm, 28 янв 2015.

  1. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    вы свой код видели? вы понимаете что он делает? вы понимаете где присваивается цвет ячейки? представляете как проверяются условия?

    З.Ы. не хочу обидеть, но странно видеть в завершении темы этот код.. такое впечатление что вы без разбору шлепаете куски кода
  2. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Ошибок не обнаружено и отладчик не ругается но ячейки не красит
    Код:
    //Начало СостояниеЗаказа
        Для каждого Оформление Из ОформленияСтрок Цикл
    
            лкЦвет  = WebЦвета.Белый;       
    
            Если Оформление.Ячейки.СостояниеЗаказа.ЦветФона = Перечисления.СостояниеЗаказа.Заказать Тогда
                лкЦвет = WebЦвета.Зеленый;
            ИначеЕсли Оформление.Ячейки.СостояниеЗаказа.ЦветФона = Перечисления.СостояниеЗаказа.Подтвержден Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.Ячейки.СостояниеЗаказа.ЦветФона = лкЦвет;       
          
        КонецЦикла;
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    мдя, будьте внимательны при кодинге... от одной маленькой ошибки, неприметной такой, результат может быть сильно ощутимым
    Код:
    //Начало СостояниеЗаказа
        Для каждого Оформление Из ОформленияСтрок Цикл
    
            лкЦвет  = WebЦвета.Белый;      
    
            //Если Оформление.Ячейки.СостояниеЗаказа.ЦветФона = Перечисления.СостояниеЗаказа.Заказать Тогда
            Если Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Заказать Тогда
                лкЦвет = WebЦвета.Зеленый;
            //ИначеЕсли Оформление.Ячейки.СостояниеЗаказа.ЦветФона = Перечисления.СостояниеЗаказа.Подтвержден Тогда
            ИначеЕсли Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Подтвержден Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.Ячейки.СостояниеЗаказа.ЦветФона = лкЦвет;      
         
        КонецЦикла;
  4. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Я прошу прощения за свою не грамотность, но в конечном итоге все получилось, все огромное спасибо!

    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
       
        //Начало СостояниеЗаказа
        Для каждого Оформление Из ОформленияСтрок Цикл
    
            лкЦвет  = WebЦвета.Белый;       
    
            Если Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Заказать Тогда
                лкЦвет = WebЦвета.Зеленый;
            ИначеЕсли Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Подтвержден Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.Ячейки.СостояниеЗаказа.ЦветФона = лкЦвет;       
          
        КонецЦикла;
    КонецПроцедуры
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    и разберитесь базовыми знаниями по 1С, чуствуется у вас их немного, иначе дальше куда сложнее покажется

Поделиться этой страницей