8.х Изменение цвета статуса заказа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем malcevm, 28 янв 2015.

  1. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Приветствую Вас боги 1С. Вообщем без вашей помощи ни как. Прикрутили мне значит к 1С:Предприятие 8.2 (8.2.19.90) статусы заказов их целых 10 штук. Вот сижу теперь и думаю как бы к этим статусам красок добавить. Скажем Оплачен=>Зеленый ну и, так и далее... Сам то я, в синтаксисе не силен могу только методом тыка понять, что за что отвечает, собственно по этому вам и кланяюсь.
    Последнее редактирование модератором: 28 янв 2015
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Настройка динамического списка курите.
    А ссылочку я затер :))
  3. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    За ссылку сори писал на два форума для ускорения процесса, скопировал оттуда. Можно как то подробней?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Начнем с того, конфа на управляемых формах ?
  5. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    наверное тогда уж надо начинать с того, какая конфа :)
  6. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    10.3.29.1
    --- Объединение сообщений, 28 янв 2015 ---
    Ну подход мне уже нравится :)
  7. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Для визуального восприятия

    Вложения:

  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Это называется условное форматирование.
    У вас же в списке (на втором скрине) уже это реализовано. Или вам нужно это сделать на первом скрине ?
  9. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Это не реализовано, я сам подкрасил =) Так нужно сделать
  10. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Я уже написал - условное форматирование формы списка.
  11. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Вот что удалось накидать, но что то не работает не перекрашивает
    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
      
        //Начало СостояниеЗаказа
        Для каждого Оформление Из ОформленияСтрок Цикл
    
            лкЦвет  = WebЦвета.Белый;       
    
            Если Оформление.ДанныеСтроки.СостояниеЗаказа = "Заказать" Тогда
                лкЦвет = WebЦвета.Зеленый;
            ИначеЕсли Оформление.ДанныеСтроки.СостояниеЗаказа = "Подтвержден" Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.ЦветФона = лкЦвет;       
          
        КонецЦикла;
    КонецПроцедуры
    --- Объединение сообщений, 28 янв 2015 ---
    А где искать его?
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Состояние заказа какой тип имеет? явно не строка
  13. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    ПеречислениеСсылка.СостояниеЗаказа
  14. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    В свойсвах списка
  15. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну так и сравнивайте с перечислением
    --- Объединение сообщений, 28 янв 2015 ---
    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
     
        //Начало СостояниеЗаказа
        Для каждого Оформление Из ОформленияСтрок Цикл
    
            лкЦвет  = WebЦвета.Белый;      
    
            Если Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Заказать Тогда
                лкЦвет = WebЦвета.Зеленый;
            ИначеЕсли Оформление.ДанныеСтроки.СостояниеЗаказа = Перечисления.СостояниеЗаказа.Подтвержден Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.ЦветФона = лкЦвет;      
         
        КонецЦикла;
    КонецПроцедуры
  16. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    спасибо вам большое работает, только вот мне нужно что бы ячейка была цветная а не строка
  17. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну тогда и укажите что Ячейке цвет присваиваете
    --- Объединение сообщений, 28 янв 2015 ---
    Офоормление.Ячейки.СостояниеЗаказа.Цвет..... думаю как то так... пробуйте
  18. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    не так не работает (
  19. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    если не поленитесь полистать синтаксис-помошник, то увидите, что не Цвет, а ЦветФона - есть у каждой ячейки... я же вам по логике цепочку написала, ну а доработать - это уже ваше дело...
  20. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Ну я так и делал
    Код:
    //Начало СостояниеЗаказа
         Для каждого Оформление Из ОформленияЯчейки Цикл
    
            лкЦвет  = WebЦвета.Белый;       
    
            Если Оформление.Ячейки.<СостояниеЗаказа>.ЦветФона = Перечисление.СостояниеЗаказа.Заказать Тогда 
                лкЦвет = WebЦвета.Зеленый;
            ИначеЕсли Оформление.Ячейки.<СостояниеЗаказа>.ЦветФона = Перечисление.СостояниеЗаказа.Подтвержден Тогда
                лкЦвет = WebЦвета.Желтый;
            КонецЕсли;
    
            Оформление.ЦветФона = лкЦвет;       
           
        КонецЦикла;
    

Поделиться этой страницей