8.х УТ Изъятие и внесение денежных средст

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем BlackLeon, 22 авг 2008.

  1. TopicStarter Overlay
    BlackLeon
    Offline

    BlackLeon

    Регистрация:
    22 авг 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Как модно произвести изъятие и внесение денежных средств в 1с v 8.1 в "Управление торговлей", редакция 10.3. Фискальный регистратор Штрих-М точнее не известно. Может у кого то есть какая либо внешняя обработка?
  2. Senya
    Offline

    Senya Опытный в 1С

    Регистрация:
    6 июн 2006
    Сообщения:
    594
    Симпатии:
    0
    Баллы:
    26
    Штатной обработки нет. Необходимо:
    1. В документации к ФР найти описание соответствующих команд.
    2. Взять штатную обработку в каталоге шаблонов и дописать соответствующие процедуры.
    3. Написать соответствующую обработку для внесения/изъятия либо внести вызов этих процедур из документов, например ПКО/РКО.
  3. ACID
    Offline

    ACID

    Регистрация:
    29 май 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    В УТ есть в доументе ЧекККМ Обработка события

    Код:
    Процедура ДействияФормыВнесениеВДенежныйЯщик(Кнопка)
    
    Сумма = Неопределено;
    Если ВвестиЧисло(Сумма, "Необходимо ввести сумму", 15, 3) Тогда
    Пароль    = ПолучитьСерверТО().ПолучитьПарольКассираККМ();
    Результат = ПолучитьСерверТО().ВнестиСумму(мФР, Пароль, Сумма);
    Если ЗначениеЗаполнено(Результат) Тогда
    ТекстОшибки = ПолучитьСерверТО().ПолучитьТекстОшибкиФРТО(Результат);
    Предупреждение(ТекстОшибки);
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    
    

Поделиться этой страницей