7.7 из ТЗ в ТЧ документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Inkeeper, 6 окт 2010.

  1. TopicStarter Overlay
    Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    Доброго дня, делаю обработку загрузки данных из ТСД в ТиС документ ЧекККМ. Из ТСД в ТЗ я заполняю колонки ТЗ(ШК;Наименование;Количество;Цена;Сумма), далее пытаюсь загрузить эти данные в ТЧ ЧекККМ, в итоге в сформированном документе в ТЧ заполнены поля Штрихкод, Количество, Цена, Сумма. Поля Ед., К., Номенклатура не заполнены. Подскажите пожалуйста как сделать чтобы не заполненные поля заполнить?

    Код:
    Процедура ВДокумент() 
    
    СпрНом=СоздатьОбъект("Справочник.Номенклатура");
    СпрСклады=СоздатьОбъект("Справочник.Склады"); 
    СпрЕд=СоздатьОбъект("Справочник.Единицы");
    
    СпрНом.ВыбратьЭлементы();
    СпрСклады.ВыбратьЭлементы();
    СпрЕд.ВыбратьЭлементы();
    
    Док=СоздатьОбъект("Документ.ЧекККМ"); 
    Док.Новый(); 
    Док.ДатаДок=РабочаяДата();
    
    
    ТаблЗнач.ВыбратьСтроки();
    
    Пока ТаблЗнач.ПолучитьСтроку()=1 Цикл 
    
    Док.НоваяСтрока();
    
    Док.ШтрихКод = ТаблЗнач.ШК;
    Док.Номенклатура=ТаблЗнач.Наименование;
    Док.Количество=ТаблЗнач.Количество;
    Док.Цена=ТаблЗнач.Цена; 
    Док.Сумма=ТаблЗнач.Сумма;
    
    КонецЦикла;
    
    
    
    Док.Записать();
    ОткрытьФорму(Док.ТекущийДокумент());
    
    КонецПроцедуры
    
    
    
  2. TopicStarter Overlay
    Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    или может быть правильней через Штрихкод заполнять ТЧ, т.е. обращаться к Штрихкоду как реквизиту подчинённого справочника Единицы справочника Номенклатура? Тока не знаю как:angry:
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ШК это реквизит справочника Единицы измерения. Который в свою очередь является подчиненным справочником Номенклатура. Вот функция которая вернет номенклатуру по ШК

    Код:
    Функция ВернутьТоварПоШК(ШК)
    Спр=СоздатьОбъект("Справочник.Единицы");
    Если Спр.НайтиПоРеквизиту("ШтрихКод", СокрЛП(ШК), 1) = 1 Тогда
    Спр.Владелец;
    Иначе
    Возврат "";
    КонецЕсли;
    КонецФункции
    
    
    Не забудьте при загрузке определить склад/кассу и прочие реквизиты шапки

Поделиться этой страницей