8.х из ТЗ (Табл. Знач.) в Эксель , что то не получается(

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Forsminor, 12 дек 2012.

  1. TopicStarter Overlay
    Forsminor
    Offline

    Forsminor

    Регистрация:
    12 дек 2012
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Доброго времени форумчане! может и бональный вопрос "Где ошибка?" но сам не знаю ответа (строго не судите - начинающий)
    НомерСтроки = 0;

    Для Каждого Стр Из ТЗ Цикл
    Для б = НомерСтроки по ТЗ.Количество()- 1 Цикл
    Для в = 0 по 11 Цикл //ТЗ.Колонки.Количество()-1
    Excel.Cells(б+1, в+1).Value = Стр[в]; //
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;

    может подскажете какая у меня ошибка тут, заранее Спасибо!

    и еще выдает ошибку
    еще выдает ошибку 0х800а03ес

    стопорится на этой строчке Excel.Cells(б+1, в+1).Value = Стр[в];

    Excel.Cells(б+1, в+1).Value - как заменить?
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    я бы тоже застопорилась в таких циклах )))


    1. Оформляйте код в тегах Код1С
    2. Опишите задачу, что должен делать ваш код

    вам надо тз вывести в Эксель?

    а вот так не работает?
    Код:
    Для б = 0 по ТЗ.Количество()- 1 Цикл
    Для в = 0 по ТЗ.Колонки.Количество()-1 Цикл
    Excel.Cells(б+1, в+1).Value = тз[б][в]; //
    КонецЦикла;
    КонецЦикла;
  3. TopicStarter Overlay
    Forsminor
    Offline

    Forsminor

    Регистрация:
    12 дек 2012
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1

    спасибо за правильно подмеченный момент, сейчас попробую
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    для спасибо есть кнопочка, воспользуйтесь поиском по форуму и найдете много тем, где обсуждалась выгрузка/загрузка данных из Excel в 1С
  5. TopicStarter Overlay
    Forsminor
    Offline

    Forsminor

    Регистрация:
    12 дек 2012
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    заработало, спасибо огромное!
    а еще маленьки вопрос, как узнать какое время в данный момент формат дата + часы минуты секунды
  6. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Код:
    ТекущаяДата();
  7. TopicStarter Overlay
    Forsminor
    Offline

    Forsminor

    Регистрация:
    12 дек 2012
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Спасибо!

Поделиться этой страницей