8.х Из справочника - в ТЗ - в ТЧ нового дока

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем dim3740, 13 мар 2017.

  1. TopicStarter Overlay
    dim3740
    Offline

    dim3740 Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Код:
    Перем ТЗ;
    
    &НаСервере
    Процедура СоздатьТЗизСправочника()
      
        ТЗ=Новый ТаблицаЗначений;
        ТЗ.Колонки.Добавить("Номенклатура");  // для примера одна колонка
          
        Спр=Справочники.Номенклатура.Выбрать();
        Пока Спр.Следующий() Цикл
            Стр=ТЗ.Добавить();
            Стр.Номенклатура=Спр.ПолучитьОбъект().Наименование;  // .Ссылка? Тип данных?
        КонецЦикла;
    
    СоздатьДок();    // на след процедуру
    КонецПроцедуры
    
    &НаСервере
    Процедура СоздатьДок()
    ….
    // заполняем табличную часть Товары создаваемого документа Док
    Для Каждого СтрТЗ из ТЗ Цикл
         СтрТЧ=Док.Товары.Добавить();
         СтрТЧ.Номенклатура=СтрТЗ.Номенклатура;
    КонецЦикла;
    Поля Номенклатура документа не заполняются.
    Последнее редактирование модератором: 13 мар 2017
  2. 1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    162
    Баллы:
    104
    Стр.Номенклатура=Спр.Ссылка;
    dim3740 нравится это.
  3. TopicStarter Overlay
    dim3740
    Offline

    dim3740 Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Спасибо за быстрый и корректный ответ.

Поделиться этой страницей