8.х Из регистра сведений в документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ПоискОтветов, 27 окт 2006.

  1. TopicStarter Overlay
    ПоискОтветов
    Offline

    ПоискОтветов

    Регистрация:
    27 окт 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Есть регистр сведений "ШтатноеРасписаниеОрганизаций" и есть документ "Трудовой договор". Как можно сделать так чтобы при заполнении поля ввода в трудовом договоре открывалось штатное расписание и оттуда можно было выбрать например должность? Открыть штатное расписание из трудового договора получилось. Должность выбирается. А вот как все это передать трудовому договору не знаю.
  2. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    Ну можно например в открытой форме, на обработчике выбора, вызвать функцию ОповеститьОВыборе,
    которая, в форму-источник передаст то, что нужно.
  3. TopicStarter Overlay
    ПоискОтветов
    Offline

    ПоискОтветов

    Регистрация:
    27 окт 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    На форме документа "Трудовой договор"
    Процедура ПолеВвода1НачалоВыбора(Элемент, СтандартнаяОбработка)
    РегистрыСведений.ШтатноеРасписаниеОрганизаций.ПолучитьФормуСписка("ФормаСписка").РежимВыбора=Истина;
    РегистрыСведений.ШтатноеРасписаниеОрганизаций.ПолучитьФормуСписка("ФормаСписка").Открыть();
    КонецПроцедуры

    Процедура ПолеВвода1ОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    ЭтаФорма.ПолеВвода1.Значение=ВыбранноеЗначение;
    КонецПроцедуры

    На форме регистра сведений "Штатное расписание"

    Процедура ШтатныеЕдиницыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    ДолжностьЭ = Элемент.ТекущаяСтрока.Должность;
    ОповеститьОВыборе(ДолжностьЭ);
    КонецПроцедуры

    Что не правильно?
  4. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    В форме-родителе вызываешь на элементе который выбираешь на событие НачалоВыбора:
    Процедура ДолжностьНачалоВыбора(Элеменет,СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ФормаРегистра = РегистрыСвдений.МойРегистр.ПолучитьФорму("ОсновнаяФорма",Элемент);
    ФормаРегистра.Открыть();
    КонецПроцедуры

    В форме, которую вызываешь:
    Процедура ТаблицаЗначенийВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    ОповеститьОВыборе(ВыбраннаяСтрока.Должность);
    КонецПроцедуры

    Вот так вроде должно получиться.
  5. TopicStarter Overlay
    ПоискОтветов
    Offline

    ПоискОтветов

    Регистрация:
    27 окт 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Ура! Получилось! Спасибо большое! :unsure:

Поделиться этой страницей