7.7 Из 1С 7.7 в XML по схемам.

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем Lilit, 3 окт 2011.

  1. TopicStarter Overlay
    Lilit
    Offline

    Lilit

    Регистрация:
    11 сен 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Всем добрый день, в связи с переходом (попытки только) с 1с на другую программу, "внедренцы" дали xml-схемы, хотят, чтобы я выгрузила в их формате. Что посоветуете?
    схема выглядит вот так
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не понятен вопрос. Все делается штатными методами. Смотрите описание V7plus.dll
  3. TopicStarter Overlay
    Lilit
    Offline

    Lilit

    Регистрация:
    11 сен 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    За подсказку библиотечки, спасибо. Как бы еще сделать так, чтобы выгружалось в UTF8
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Написать функцию перекодировки. Воспользуйтесь поиском по сайту - проскакивало.
  5. makfromkz
    Offline

    makfromkz

    Регистрация:
    12 июн 2009
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Код:
    Функция ВыгрузитьВКодировкеUTF8(Текст, Каталог)
    
    ТекстВыгрузки = СоздатьОбъект("Текст");
    
    XmlcUtf = СоздатьОбъект("Текст");
    
    XmlcWin = СоздатьОбъект("Текст");
    
    // ** - Представление списка - символ в кодировке win1251, значение элемента списка - 
    //		представление символа в кодировке utf-8
    СписокСимволов = СоздатьОбъект("СписокЗначений");
    
    XmlcWin.Открыть(КаталогИБ()+"ExtForms\"+Каталог+".grp\xmlc.win");
    XmlcUtf.Открыть(КаталогИБ()+"ExtForms\"+Каталог+".grp\xmlc.utf");
    
    Если ПустоеЗначение(XmlcWin) + ПустоеЗначение(XmlcUtf) > 0 Тогда
    Предупреждение("Невозможно загрузить файлы кодировки. Выгрузка прекращена!");
    Возврат "";
    КонецЕсли;
    
    Если (XmlcWin.КоличествоСтрок() > 0) и (XmlcUtf.КоличествоСтрок() > 0) Тогда
    СтрокаWin = XmlcWin.ПолучитьСтроку(1); СтрокаUtf = XmlcUtf.ПолучитьСтроку(1);
    Для i = 0 по СтрДлина(СтрокаWin) - 1 Цикл
    СписокСимволов.ДобавитьЗначение(Сред(СтрокаUtf,(i*2)+1,2), Сред(СтрокаWin,i+1,1));
    КонецЦикла;
    КонецЕсли;
    
    Для i = 1 по Текст.КоличествоСтрок() Цикл
    СтрокаТекстВыгрузки = "";
    СтрокаТекст = Текст.ПолучитьСтроку(i);
    Для j = 1 по СтрДлина(СтрокаТекст) Цикл
    СимволСтроки = Сред(СтрокаТекст, j, 1);			
    СимволСпискаКодировки = СписокСимволов.Получить(СимволСтроки);
    Если ПустоеЗначение(СимволСпискаКодировки) = 0 Тогда
    СтрокаТекстВыгрузки = СтрокаТекстВыгрузки + СимволСпискаКодировки;
    Иначе
    СтрокаТекстВыгрузки = СтрокаТекстВыгрузки + СимволСтроки;
    КонецЕсли;
    КонецЦикла;
    ТекстВыгрузки.ДобавитьСтроку(СтрокаТекстВыгрузки);
    КонецЦикла;
    
    Возврат ТекстВыгрузки;
    
    КонецФункции
    
    
    Посмотреть вложение 8831

    Вложения:

    • XMLC.rar
      Размер файла:
      276 байт
      Просмотров:
      90
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А чем вас не устраивает?
Похожие темы
  1. Elvisnya
    Ответов:
    2
    Просмотров:
    889
Загрузка...

Поделиться этой страницей