8.х Итоги в группировках простого отчета

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Татьяна_В, 23 фев 2014.

  1. TopicStarter Overlay
    Татьяна_В
    Offline

    Татьяна_В

    Регистрация:
    5 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Проблема в том, что в отчете выводятся итоги сверху у детальных записей, а нужны только снизу. Как от них избавиться?
    В запросе 2-е группировки: по ВидЗадолженности и СчетРасчетов

    Код:
    ВыборкаПоВидуЗадолженности = РезультатКонтрагенты.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ВидЗадолженности");
    Если ВыборкаПоВидуЗадолженности.НайтиСледующий(Перечисления.ВидыЗадолженности.Дебиторская, "ВидЗадолженности") Тогда
    ПодвалТаблицыДт.Параметры.Заполнить(ВыборкаПоВидуЗадолженности);
    ВыборкаПоСчету = РезультатКонтрагенты.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "СчетРасчетов");
    Пока ВыборкаПоСчету.Следующий() Цикл
    ПодвалТаблицыДтПоСчету.Параметры.Заполнить(ВыборкаПоСчету);
    ВыборкаПоКонтрагенту = ВыборкаПоСчету.Выбрать();
    Пока ВыборкаПоКонтрагенту.Следующий() Цикл
    СтрокаТаблицыДт.Параметры.Заполнить(ВыборкаПоКонтрагенту);
    СтрокаТаблицыДт.ВерхнийКолонтитул.Выводить = Ложь;
    СтрокаТаблицыДт.Параметры.КонтрагентПредставление = ?(ПустаяСтрока(ВыборкаПоКонтрагенту.КонтрагентНаименованиеПолное),
    ВыборкаПоКонтрагенту.КонтрагентНаименование, ВыборкаПоКонтрагенту.КонтрагентНаименованиеПолное);
    ТабДокумент.Вывести(СтрокаТаблицыДт);
    КонецЦикла;
    ТабДокумент.Вывести(ПодвалТаблицыДтПоСчету);
    КонецЦикла;
    КонецЕсли;

    Вложения:

    Последнее редактирование модератором: 24 фев 2014
  2. TopicStarter Overlay
    Татьяна_В
    Offline

    Татьяна_В

    Регистрация:
    5 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Малость промахнулась при выборе раздела. Прошу прощенья
  3. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Это у вас итоговая колонка или пустая группировка ?, Кстати, тему перенес.

Поделиться этой страницей