8.х Итоги по несколько табличные части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 21 ноя 2014.

  1. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD");

    Скопируйте это и вставьте.
  2. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Эмиль ну как успехи? а то через 20 минут рабочее время заканчивается
  3. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    /vanga mode on/
    будет очередной фэйл.....
    /vangа mode off/
  4. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Работает спасибо!
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    //ПромежуточнаяСумма=0;
    //Для Каждого ТекСтрока Из Затраты Цикл
    //    ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    //КонецЦикла;   
    
    //СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD");
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
    так правильно или не надо закомментировать
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    ПромежуточнаяСумма=0;
    Для Каждого ТекСтрока Из Затраты Цикл
        ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    КонецЦикла;   
    
    СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD");
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
  5. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    -Woot-ну не уж то ли... значит со спокойной совестью на выходные))
    vanga bag mode on
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Ребята, давайте без подколов. Судя по всему Эмиль только учится. Все делали ошибки, пусть и глупые. Эмиль, на будущее, просто будьте внимательнее и все получится

Поделиться этой страницей