8.х Итоги по несколько табличные части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 21 ноя 2014.

  1. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    Подскажите пожалуйста как можно получить ИТОГИ из несколько табличных частей
    Мой Пример итог от одного табличного части
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    ПромежуточнаяСумма=0;
    Для Каждого ТекСтрока Из Затраты Цикл
        ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    КонецЦикла;   
    
    СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=ПромежуточнаяСумма + НачислениеПеревозчику;
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
    Спасибо!
  2. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    1) Запрос
    2) Табличнаячасть1.Итог(Ваша колонка)+Табличнаячасть2.Итог(Вашаколонка)
  3. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    так?
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    //ПромежуточнаяСумма=0;
    //Для Каждого ТекСтрока Из Затраты Цикл
    //    ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    //КонецЦикла;   
    Табличныйчастьзатраты.итог.ТекСтрока.USD+Табличныйчастьзатратыпункт2.итог.ТекСтрока.USD
    
    СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=ПромежуточнаяСумма + НачислениеПеревозчику+Табличныйчастьзатраты.итог.ТекСтрока.USD+Табличныйчастьзатратыпункт2.итог.ТекСтрока.USD
    ;
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Текущую строку уберите. Итог по колонке вцелом.
  5. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD")

    Синтаксис помощник в помощь посмотрите метод Итог у таблицы значений
  6. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    //ПромежуточнаяСумма=0;
    //Для Каждого ТекСтрока Из Затраты Цикл
    //    ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    //КонецЦикла;   
    //Табличныйчастьзатраты.итог.USD+Табличныйчастьзатратыпункт2.итог.USD
    
    СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=ПромежуточнаяСумма + НачислениеПеревозчику+Табличныйчастьзатраты.итог.USD+Табличныйчастьзатратыпункт2.итог.USD
    ;
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
    ошибка
    Код:
    {Документ.Выезды1.МодульОбъекта(94,20)}: Переменная не определена (ПромежуточнаяСумма)
    СуммаДокумента    =<<?>>ПромежуточнаяСумма; (Проверка: Сервер)
    {Документ.Выезды1.МодульОбъекта(95,13)}: Переменная не определена (ПромежуточнаяСумма)
    ОбщийРасход=<<?>>ПромежуточнаяСумма + НачислениеПеревозчику+Табличныйчастьзатраты.итог.USD+Табличныйчастьзатратыпункт2.итог.USD (Проверка: Сервер)
    {Документ.Выезды1.МодульОбъекта(95,56)}: Переменная не определена (Табличныйчастьзатраты)
    ОбщийРасход=ПромежуточнаяСумма + НачислениеПеревозчику+<<?>>Табличныйчастьзатраты.итог.USD+Табличныйчастьзатратыпункт2.итог.USD (Проверка: Сервер)
    {Документ.Выезды1.МодульОбъекта(95,87)}: Переменная не определена (Табличныйчастьзатратыпункт2)
    ОбщийРасход=ПромежуточнаяСумма + НачислениеПеревозчику+Табличныйчастьзатраты.итог.USD+<<?>>Табличныйчастьзатратыпункт2.итог.USD (Проверка: Сервер)
    
  7. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    У Вас переменная закоменнтирована
    //ПромежуточнаяСумма=0;
    так как у вас называются табличные части? как называются колонки которые хотите просуммировать?
  8. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    нужны итоги по колонкам "USD" в каждом ТЧ
  9. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    так вот и пишите

    НазваниеВашейТабличнойЧасти.Итог("USD")+НазваниеВашейВторойТабличнойЧасти.Итог("USD")
  10. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    все равно ошибка дает не могли уточнить где именно нужно написать "НазваниеВашейТабличнойЧасти.Итог("USD")+НазваниеВашейВторойТабличнойЧасти.Итог("USD")"
  11. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Покажите код который у вас последний получился
  12. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    //// Общий расход
    //ПромежуточнаяСумма=0;
    //Для Каждого ТекСтрока Из Затраты Цикл
    //    ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    //КонецЦикла;   
    
    //СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход= НачислениеПеревозчику+ЗатратыТабличнойЧасти.Итог("USD")+ЗатратыПункт2ТабличнойЧасти.Итог("USD");
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
  13. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Так вопрос в лоб.
    1) какую ошибку выдает в этом случае?
    2) Как называются те две табличные части в которых необходимо суммировать?
  14. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    ошибка
    Код:
    {Документ.Выезды1.МодульОбъекта(94,36)}: Переменная не определена (ЗатратыТабличнойЧасти)
    ОбщийРасход= НачислениеПеревозчику+<<?>>ЗатратыТабличнойЧасти.Итог("USD")+ЗатратыПункт2ТабличнойЧасти.Итог("USD"); (Проверка: Сервер)
    {Документ.Выезды1.МодульОбъекта(94,70)}: Переменная не определена (ЗатратыПункт2ТабличнойЧасти)
    ОбщийРасход= НачислениеПеревозчику+ЗатратыТабличнойЧасти.Итог("USD")+<<?>>ЗатратыПункт2ТабличнойЧасти.Итог("USD"); (Проверка: Сервер)
    
    табличка называется "ОбщийРасход" т.е из всех табличных частей нужно собрать все итоги в ОбщийРасход
  15. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Прошу прощения за мой сарказм да даст господь мне сил получить от вас то что я хочу.

    У вас есть документ Выезды1. у него есть две табличные части? так? или это у вас программные таблицы значений?

    Мне надо название этих табличных частей в документе
  16. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Да у меня есть док с названием Выезд1 и у него есть три табличных частей в коде есть название этих таблиц. В каждом ТЧ есть расходы который мне нужно получить итоги.
    первый "Таможня"
    второй "Затраты"
    третий "ЗатратыПункт2"
  17. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Соответствено если в двух вторых таблицах будет есть колонка "USD"

    ОбщийРасход=НачислениеПеревозчику+Затраты.Итог("USD")+<<?>>ЗатратыПункт2.Итог("USD");

    пробуйте вот так
  18. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    так и так пробовал все равно ошибки

    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    //ПромежуточнаяСумма=0;
    //Для Каждого ТекСтрока Из Затраты Цикл
    //    ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    //КонецЦикла;   
    
    //СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD")+ЗатратыПункт2ТабличнойЧасти.Итог("USD");
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
    ошибка
    Код:
    {Документ.Выезды1.МодульОбъекта(94,101)}: Переменная не определена (ЗатратыПункт2ТабличнойЧасти)
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD")+<<?>>ЗатратыПункт2ТабличнойЧасти.Итог("USD"); (Проверка: Сервер)
    
    и так
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    // Общий расход
    ПромежуточнаяСумма=0;
    Для Каждого ТекСтрока Из Затраты Цикл
        ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.USD;   
    КонецЦикла;   
    
    СуммаДокумента    =ПромежуточнаяСумма;
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD")+ЗатратыПункт2ТабличнойЧасти.Итог("USD");
    Прибыль = СтоимостьПеревозки - ОбщийРасход;
    КонецПроцедуры
    
    ошибка
    Код:
    {Документ.Выезды1.МодульОбъекта(94,101)}: Переменная не определена (ЗатратыПункт2ТабличнойЧасти)
    ОбщийРасход=НачислениеПеревозчику+Таможня.Итог("USD")+Затраты.Итог("USD")+ЗатратыПункт2.Итог("USD")+<<?>>ЗатратыПункт2ТабличнойЧасти.Итог("USD"); (Проверка: Сервер)
    
  19. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Эмиль, вы читаете то что вам пишут? возьмите код прямо из текста, у вас было 3 слагаемых, теперь 4, откуда четвертое??? что это вообще такое? вы понимаете что вы творите в данный момент?
  20. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    да читаю просто четвертое не написал
    хорошо если даже три как их решить?

Поделиться этой страницей