8.х Итератор

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем romanMS, 13 фев 2012.

  1. TopicStarter Overlay
    romanMS
    Offline

    romanMS Опытный в 1С

    Регистрация:
    13 фев 2012
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    здравствуйте!

    При проведении документа в конфигурации "Бухгалтерия предприятия 2.0" система выдает ошибку: Итератор для значения не определен!


    Ошибка при выполнении обработчика - 'ОбработкаПроведения'
    по причине:
    {ОбщийМодуль.ОбщегоНазначения(2363)}: Итератор для значения не определен


    Это из Конфигуратора скопировано:

    Код:
    Процедура ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник) Экспорт
    Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл  СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить();
    ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника, СтрокаТаблицыИсточника);
    КонецЦикла;КонецПроцедуры // ЗагрузитьВТаблицуЗначений()
    
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Проверяйте тип значения ТаблицаИсточник. Какие данные в процедуру ЗагрузитьВТаблицуЗначений передаются?
  3. TopicStarter Overlay
    romanMS
    Offline

    romanMS Опытный в 1С

    Регистрация:
    13 фев 2012
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Причем если провести документ датой ранее, до НГ, например 31.12.2011 то документ проводится.

    вот текст из модуля по значению, могу ошибатся:

    Код:
    Процедура ТоварыИУслугиНоменклатураПриИзменении(Элемент)
    СтрокаТабличнойЧасти = ЭлементыФормы.ТоварыИУслуги.ТекущиеДанные;
    Если ТипЗнч(СтрокаТабличнойЧасти.Номенклатура) = Тип("СправочникСсылка.Номенклатура") Тогда
    
    ОбработкаТабличныхЧастей.ЗаполнитьНомерГТДИСтрануПроисхождения(СтрокаТабличнойЧасти, Ложь, Организация, Дата);
    ПриИзмененииНоменклатурыТоваров(СтрокаТабличнойЧасти);
    КонецЕсли;
    
    // Рассчитываем реквизиты табличной части.
    ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
    
    КонецПроцедуры // ТоварыИУслугиНоменклатураПриИзменении()
    
  4. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Переменная "ТаблицаИсточник" имеет некорректный тип, смотрите отладчиком какой тип получаете.
    Не вижу связи между первым и вторым куском кода
  5. TopicStarter Overlay
    romanMS
    Offline

    romanMS Опытный в 1С

    Регистрация:
    13 фев 2012
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Ну я возможно и не правильно определил связь между двумя таблицами. я просто посмотрел на что ссылается именно ячейка в таблице и посмотрел "ПриИзминении"... (я не силен в конфигурировании, а приходится выкручиваться) как правильно посмотреть? документ "отражение начисления НДС" в бухгалтерии предприятия 2.0.34.6
  6. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Отладчик (отладка), глаза, F11, F10, Shift+F9 - как то так.
    У вас в разных случаях на вход ф-ии
    ЗагрузитьВТаблицуЗначений
    Приходят разные аргументы. В частности
    ТаблицаИсточник
    Которая то таблица значений (скорее всего), то ХЗ (ХЗ определяется отладкой).

Поделиться этой страницей