8.х ОБМЕН Итератор для значения не определен

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Odin, 14 фев 2014.

  1. TopicStarter Overlay
    Odin
    Offline

    Odin

    Регистрация:
    13 фев 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Процедура ОбработкаПроведения(Отказ, Режим)
    Для Каждого ТекСтрока ИЗ Документы.ОтменаЗаписи
    Цикл
    Запрос =Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаписьИОтмена.Период,
    | ЗаписьИОтмена.Врач,
    | ЗаписьИОтмена.пациент
    |ИЗ
    | РегистрСведений.ЗаписьИОтмена КАК ЗаписьИОтмена
    |ГДЕ
    | ЗаписьИОтмена.Врач = &Врач
    | И ЗаписьИОтмена.пациент = &пациент
    | И ЗаписьИОтмена.Период = &Период";

    Результат =Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Если Выборка.Следующий() Тогда
    Если
    ТекСтрока = Выборка.Врач Тогда
    Сообщить("12312123");

    КонецЕсли;

    КонецЕсли;
    КонецЦикла;

    Ошибка такая: Ошибка при выполнении обработчика - 'ОбработкаПроведения'
    по причине:
    {Документ.ОтменаЗаписи.МодульОбъекта(3)}: Итератор для значения не определен
    Для Каждого ТекСтрока ИЗ Документы.ОтменаЗаписи
    Заранее благодарен за помощь!
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    и ведь правду говорит - нет у менеджера документа итератора :)

    что сделать то хотели?

Поделиться этой страницей