7.7 Исправить печатную форму

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем roman795, 2 фев 2010.

  1. TopicStarter Overlay
    roman795
    Offline

    roman795

    Регистрация:
    25 янв 2009
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Проблемма собсно в том что документ отгрузка товаров и продукции я печатную форму нашёл и отредактировал нужные пункты чтоб при печати постоянно не редактировать, а вот когда счёт фактуру делаешь к этому документу то всё в той печатной форме осталось по прежнему, делал так: действие\ввести на основании\счёт-фактура выданный и там всё как по старому ни чего не исправлено в подвале, подскажите плиз? и ещё одна маленькая проблема лажёвая но не судите строго, как сделать чтоб когда на печать выводилось какой нить документ он выводился в книжной форме по умолчанию, а не в альбомной?
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Так, давай еще раз и по-русски. Что за конфигурация, что за документ, что за печатная форма и что ты хочешь увидеть?
  3. TopicStarter Overlay
    roman795
    Offline

    roman795

    Регистрация:
    25 янв 2009
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    извиняюсь если не понятно пишу! в общем конфигурация 1с-бухгалтерия, документ-"отгрузка товаров, продукции" его заполняю и вывожу на печать, и как раз в печатной форме некоторые данные устарели например доверенность №2 и тд, я эту форму нашёл и изменил данные, но вот счёт фактуру к этому документу когда делаю там печатная форма опять же с устаревшими данными, но найти её не могу! В конфигураторе я нашёл стандартную счёт фактуру смотрел печатную форму не та!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    По умолчанию 1с пытается найти ШАБЛОН сф. Он внешний. Находится в КаталогИБ\ExtForms\PrnForms. Это в том сручае если вы не используете дополнительные печатные формы. (смотрите в сервесе "регистрация внешних печатных форм)
  5. TopicStarter Overlay
    roman795
    Offline

    roman795

    Регистрация:
    25 янв 2009
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    пасиб большое нашёл ту форму он был в обработке почему то, а вот чтоб печатать по умолчанию как книжные страницы а не альбомные не подскажете?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ПараметрыСтраницы(<Ориентация>,<Масштаб>,<РежимПечатиКопий>,<ПолеСлева>,<ПолеСправа>,<ПолеСверху>,<ПолеСнизу>,<КолонтитулСверху>,<КолонтитулСнизу>,<Автомасштаб>,<ФлагЧБПечати>,<ИмяПринтера>)
    Назначение:
    Установить параметры страницы.
  7. Annushka
    Offline

    Annushka

    Регистрация:
    6 авг 2010
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день. та же история нужно измненить номер доверенности руководителя и бухгалтера в счет-фактуре, а как это сделать в версии 7.7 редакция 4.5 1:С бухгалтерия! в журнале "Регистрация внешних печатных форм" - реквизитов предыдущих там нет, а ШАБЛОНа сф. Он внешний. Находится в каталогИБ\ExtForms\PrnForms. я не нашла в программе.
    Подскажите Где мне изменить реквизиты доверенности в счет-фактуре? изменять в ручную это не возможно. Заранее спасибо.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Все зависит от того КАКУЮ форму вы используете
    1) Внутренюю :
    • 1С определяет дату документа и в зависимости от нее
      открывает форму из папки PrnForms\1cbsf*.mxl где * - номер редакции постановления формы (189,84,283,451)
    • если фала нет, 1с пытается открыть фнутренний шаблон (находится внутри конфигурации в форме документа СФ, закладки таблицы)
    2) Внешнюю.
    1с позволяет подключать к документам внешние перчатные формы. Как они называются смотрите тут: Меню-Сервис-Регистрация внешних печатных форм - Вид документа СФ - колонка таблицы Файл. Обработки печати также находятся в папке PrnForms. Шаблоны печати в обработках могут вызываться обоими из вышеописанных способов. Тут нужно смотреть...
  9. Zernokompany
    Offline

    Zernokompany

    Регистрация:
    24 авг 2011
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Это то хорошо а как внести изменение в шаблон SF_zam.ert в папке ExtForms\PRNFORMS, мне надо добавить место для подписи и фамилию руководителя.
  10. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Ну, так заходи в режиме Конфигуратор, открывай свою SF_zam.ert и резвись.
  11. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Добрый день! 1С Предприятие 7.7 редакция 4.5 535. При печати счет-фактуры (внешняя печатная форма) КПП ставит плательщика, а мне надо чтобы КПП попадал грузополучателя (Плательщик Главный офис, а грузополучатель: филиал) как это можно сделать?
  12. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Исправить в модуле этой ВПФ.
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  14. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    а как ее можно скинуть?

    Код:
    //*******************************************
    Процедура Печать(Докум, Устройство=0, КолвоКопий=1)
    
    СтатусВозврата(0);
    
    НомерДокПечатнойФормы = глПреобразоватьНомерДок(Докум.НомерДок, 0, 0);
    Если Докум.ДатаДок >= '01.10.2011' Тогда
    
    Если Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница Тогда
    
    ТекстСообщения = "Счета-фактуры на суммовые разницы не выписываются, начиная с 01.10.2011 г.";
    Сообщить(ТекстСообщения, "!" );
    Возврат;   
    
    КонецЕсли;
    
    КонецЕсли;
    
    НомерПлатРасчДок = Докум.НомерПлатРасчДок;
    ДатаПлатРасчДок = Докум.ДатаПлатРасчДок;
    Контрагент = Докум.Контрагент;
    
    ПустойПоказатель = "----";
    
    // В зависимости от даты документа используются разные шаблоны печатной формы.
    // При наличии в каталоге информационной базы файла с именем
    // "ExtForms\PrnForms\1csf*.mxl", будет использоваться шаблон печатной формы
    // размещенный в данном файле.
    Таб = СоздатьОбъект("Таблица");
    ИмяФайлаПечатнойФормы = КаталогИБ() + "ExtForms\PrnForms\1csf2012.mxl";
    ИмяТаблицы = "Таблица";
    
    
    Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
    Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);
    Иначе
    Таб.ИсходнаяТаблица(ИмяТаблицы);
    КонецЕсли;
    
    Таб.ВывестиСекцию("ШапкаИнформация");
    
    НомерДокумента   = СокрЛ(Докум.НомерДок);
    ДатаДокумента    = Формат(Докум.ДатаДок ,"Д (0)ДДММММГГГГ");
    ПечНомерИсправления = ПустойПоказатель;
    ПечДатаИсправления  = ПустойПоказатель;
    
    Продавец = СокрЛП(Константа.ОфициальноеНазваниеОрганизации);
    
    Если Докум.ВариантОтправки=1 Тогда
    ПечГрузоотправитель = ПустойПоказатель;
    ПечГрузополучатель = ПустойПоказатель;
    
    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку()=1 Цикл
    Если ТипЗначенияСтр(Докум.Товар) = "Справочник" Тогда
    Если Докум.Товар.Вид() = "Номенклатура" Тогда
    Если (Докум.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Услуга) или
    (Докум.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Работа) или
    (Докум.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.ПосредническаяУслуга) или
    (Докум.Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.УслугаЕНВД) Тогда
    Продолжить;
    КонецЕсли;
    КонецЕсли;
    Если Докум.ВидОперации <> Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс Тогда
    ПечГрузоотправитель = "Он же";
    ПечГрузополучатель = СокрП(Докум.Грузополучатель.ПолнНаименование)+", "+СокрП(Докум.Грузополучатель.ПочтовыйАдрес);
    КонецЕсли;	
    Прервать;
    КонецЕсли;
    КонецЦикла; 
    Иначе
    ПечГрузополучатель = СокрП(Докум.Грузополучатель.ПолнНаименование)+", "+СокрП(Докум.Грузополучатель.ПочтовыйАдрес);
    ПечГрузоотправитель = СокрП(Докум.Грузоотправитель.ПолнНаименование)+", "+СокрП(Докум.Грузоотправитель.ПочтовыйАдрес);
    КонецЕсли;
    
    // Определим валюту оплаты.
    ВалютаПечати = "Российский рубль, 643";
    Если Докум.ВидОперации <> Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница Тогда
    Если Докум.Договор.ВалютаДоговора.Выбран() = 1 Тогда
    
    Если (Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс)
    И (Докум.Договор.ОплатаДоговора = 1) Тогда
    // оплата в рублях
    Иначе
    
    ВалютаПечати = "" + Докум.Договор.ВалютаДоговора.ПолнНаименование + ", " + Докум.Договор.ВалютаДоговора.Код;
    
    КонецЕсли;
    
    КонецЕсли;
    КонецЕсли;
    
    // Выгрузим табличную часть документа в таблицу значений.
    ТабДок = СоздатьОбъект("ТаблицаЗначений");
    Докум.ВыгрузитьТабличнуюЧасть(ТабДок);
    
    //**************************************************
    //Печатаем сч-ф по договору у.е. в рублях
    ТекстПредупреждения = "";
    ЦеныВДоговоре = 1; // в рублях
    ОплатаДоговора = 1; // в рублях
    СчетФактураВУЕ = 0;
    Если Докум.Договор.Выбран() = 1 Тогда
    Если ПустоеЗначение(Докум.Договор.ВалютаДоговора) = 0 Тогда
    ЦеныВДоговоре = 2; // в валюте
    ОплатаДоговора = Докум.Договор.ОплатаДоговора; // 1 - врублях, 2 - в валюте
    Если ОплатаДоговора = 1 Тогда
    СчетФактураВУЕ = 1;
    ВестиУчетРасчетовУЕ = Докум.Договор.ВестиУчетРасчетовУЕ;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    Если СчетФактураВУЕ = 1 Тогда
    ВалютаПечати = "Российский рубль, 643";
    Опер = СоздатьОбъект("Операция");
    //Предварительно получим сумму НДС, если документ проведен
    Сч68_2 = СчетПоКоду("68.2");
    СуммаНДСДокументаРуб = 0;
    Если Докум.Проведен() = 1 Тогда
    Если Опер.НайтиОперацию(Докум.ТекущийДокумент()) = 1 Тогда
    Опер.ВыбратьПроводки();
    Пока Опер.ПолучитьПроводку() = 1 Цикл
    Если Опер.Кредит.Счет = Сч68_2 Тогда
    СуммаНДСДокументаРуб = СуммаНДСДокументаРуб + Опер.Сумма;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    Сч62_6 = СчетПоКоду("62.6");
    Сч62_7 = СчетПоКоду("62.7");
    СчВР_6 = СчетПоКоду("ВР.6");
    
    СуммаЗачетаВал = 0;
    СуммаЗачетаРуб = 0;
    ЗадолженностьВал = 0;
    ЗадолженностьРуб = 0;
    
    ДокументОснование = Докум.ДокументОснование;
    
    Если ДокументОснование.Выбран() = 1 Тогда // поиск зачтенного аванса	 
    Если Опер.НайтиОперацию(ДокументОснование) = 1 Тогда
    Опер.ВыбратьПроводки();
    Пока Опер.ПолучитьПроводку() = 1 Цикл
    Если Опер.Дебет.Счет = СчВР_6 Тогда
    СуммаЗачетаВал = СуммаЗачетаВал + Опер.ВалСумма;
    СуммаЗачетаРуб = СуммаЗачетаРуб + Опер.Сумма;
    ЗадолженностьВал = ЗадолженностьВал + Опер.ВалСумма;
    ЗадолженностьРуб = ЗадолженностьРуб + Опер.Сумма;
    
    Иначе
    Если (Опер.Дебет.Счет = Сч62_7) и (Опер.Кредит.Счет = Сч62_6) Тогда
    СуммаЗачетаВал = СуммаЗачетаВал + Опер.ВалСумма;
    СуммаЗачетаРуб = СуммаЗачетаРуб + Опер.Сумма;
    КонецЕсли;
    
    Если Опер.Дебет.Счет = Сч62_6 Тогда
    ЗадолженностьВал = ЗадолженностьВал + Опер.ВалСумма;
    ЗадолженностьРуб = ЗадолженностьРуб + Опер.Сумма;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    
    Если Докум.ВерсияОбъекта < "7.70.421" Тогда
    Если Докум.Валюта.Выбран() = 1 Тогда
    ЦеныВДоговоре = 2;
    КурсДок = Докум.Валюта.Курс.Получить(Докум.ДатаДок);
    КонецЕсли;
    Иначе
    ВалютаДок = Докум.Договор.ВалютаДоговора;
    КонецЕсли;
    
    Если ЦеныВДоговоре = 2 Тогда
    Кратность = ВалютаДок.Кратность.Получить(Докум.ДатаДок);
    Кратность = ?(Кратность=0, 1, Кратность);
    Если Докум.Договор.ВестиУчетРасчетовУЕ = 1 Тогда
    Кратность = Кратность * 100 / (100 + Докум.Договор.ПроцентКорректировкиКурсаУЕ);
    КонецЕсли;
    КонецЕсли;
    
    ДоляОплаченнойОтгрузки = ?(ЗадолженностьВал = 0, 0, СуммаЗачетаВал / ЗадолженностьВал);
    КурсОплаты = ?(СуммаЗачетаВал = 0, 0, Окр(СуммаЗачетаРуб / СуммаЗачетаВал, 4, 1));
    КурсСФ = ?(((ЦеныВДоговоре = 2) и (Докум.Аванс = 0)) или (ОплатаДоговора = 2), Докум.Курс / Кратность, 1);
    
    Если Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница Тогда
    КурсСФ = 1;
    КонецЕсли;
    
    Если (Докум.ВидОперации <> Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница) и (Докум.ВидОперации <> Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс) Тогда
    ТабДок.ВыбратьСтроки();
    Пока ТабДок.ПолучитьСтроку()= 1 Цикл
    
    ОплСумма = ТабДок.Сумма * ДоляОплаченнойОтгрузки;
    ТабДок.Сумма = Окр(ОплСумма * КурсОплаты + (ТабДок.Сумма - ОплСумма) * КурсСФ, 2, 1);
    
    ОплНДС = ТабДок.НДС * ДоляОплаченнойОтгрузки;
    ТабДок.НДС = Окр(ОплНДС * КурсОплаты + (ТабДок.НДС - ОплНДС) * КурсСФ, 2, 1);
    
    ОплНП = ТабДок.НП * ДоляОплаченнойОтгрузки;
    ТабДок.НП = Окр(ОплНП * КурсОплаты + (ТабДок.НП - ОплНП) * КурсСФ, 2, 1);
    
    ОплАкцизСумма = ТабДок.АкцизСумма * ДоляОплаченнойОтгрузки;
    ТабДок.АкцизСумма = Окр(ОплАкцизСумма * КурсОплаты + (ТабДок.АкцизСумма - ОплАкцизСумма) * КурсСФ, 2, 1);
    
    ОплЦена = ТабДок.Цена * ДоляОплаченнойОтгрузки;
    ТабДок.Цена = Окр(ОплЦена * КурсОплаты + (ТабДок.Цена - ОплЦена) * КурсСФ, 2, 1);
    
    ОплВсего = ТабДок.Всего * ДоляОплаченнойОтгрузки;
    ТабДок.Всего  = Окр(ОплВсего * КурсОплаты + (ТабДок.Всего  - ОплВсего) * КурсСФ, 2, 1);
    
    КонецЦикла;
    
    Если Докум.Проведен() = 1 Тогда
    Если (СуммаНДСДокументаРуб <> ТабДок.Итог("НДС")) и (ДоляОплаченнойОтгрузки <> 0) Тогда
    ТекстПредупреждения = "Внимание! Сумма НДС в счете-фактуре отличается от суммы НДС отраженной в бухгалтерском учете. Возможно следует перепровести документ.";
    Таб.ВывестиСекцию("ТекстПредупреждения");
    Иначе
    ТекстПредупреждения = "";
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
    Таб.ВывестиСекцию("Шапка");
    
    // Печать строк документа.
    ТабДок.ВыбратьСтроки();
    Ном=0;
    Пока ТабДок.ПолучитьСтроку()=1 Цикл
    Ном=Ном+1;
    Если ТипЗначения(ТабДок.Товар) = 2 Тогда
    Наименование = ТабДок.Товар;
    ЕдиницаИзмерения = "----";
    ЕдиницаИзмеренияКод = "----";
    
    ИначеЕсли ТабДок.Товар.Вид() = "Номенклатура" Тогда
    Наименование = ?(ПустаяСтрока(ТабДок.Товар.ПолнНаименование)=1, ТабДок.Товар.Наименование, ТабДок.Товар.ПолнНаименование);
    ЕдиницаИзмерения = ТабДок.Товар.ЕдиницаИзмерения;
    ЕдиницаИзмеренияКод = ТабДок.Товар.ЕдиницаИзмерения.Код;
    
    ИначеЕсли ТабДок.Товар.Вид() = "ОсновныеСредства" Тогда
    Наименование = ТабДок.Товар.Наименование;
    ЕдиницаИзмерения = "----";
    ЕдиницаИзмеренияКод = "----";
    
    ИначеЕсли ТабДок.Товар.Вид() = "НематериальныеАктивы" Тогда
    Наименование = ТабДок.Товар.Наименование;
    ЕдиницаИзмерения = "----";
    ЕдиницаИзмеренияКод = "----";
    
    ИначеЕсли ТабДок.Товар.Вид() = "Материалы" Тогда
    Наименование = ТабДок.Товар.Наименование;
    ЕдиницаИзмерения = ТабДок.Товар.ЕдиницаИзмерения;
    ЕдиницаИзмеренияКод = ТабДок.Товар.ЕдиницаИзмерения.Код;
    КонецЕсли;
    Если Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс Тогда
    ЕдиницаИзмерения = "----";
    ЕдиницаИзмеренияКод = "----";
    КонецЕсли;
    Если ПустоеЗначение(ЕдиницаИзмерения) = 1 Тогда
    ЕдиницаИзмерения = "----";
    ЕдиницаИзмеренияКод = "----";
    КонецЕсли; 
    Если ПустоеЗначение(ТабДок.ГТД) = 1 Тогда
    НомерГТД_Н = "";
    СтранаН = "";
    СтранаКод = "";
    Иначе
    НомерГТД_Н = ТабДок.ГТД;
    Если ПустаяСтрока(ТабДок.ГТД.СтранаПроисхождения) = 1 Тогда
    СтранаН = "";
    СтранаКод = "";
    Иначе
    СтранаН = ТабДок.ГТД.СтранаПроисхождения;
    СтранаКод = "";
    КонецЕсли;
    КонецЕсли;
    Если Докум.НДСпоСтавкеНольПроцентов = 1 Тогда
    ПредставлениеСтавкиНДС = "0%";
    Иначе
    Если (ТабДок.СтавкаНДС.Выбран() = 1) и (ТабДок.СтавкаНДС.Ставка > 0) Тогда
    ПредставлениеСтавкиНДС = "" + ТабДок.СтавкаНДС.Ставка + "%";
    
    Если Докум.СуммаНДСопределяетсяРасчетнымМетодом = 1 Тогда
    ПредставлениеСтавкиНДС = ПредставлениеСтавкиНДС + " / 1" + ТабДок.СтавкаНДС.Ставка + "%";
    КонецЕсли;
    
    Иначе
    ПредставлениеСтавкиНДС = "без НДС";
    КонецЕсли;
    КонецЕсли;
    Если ТабДок.Количество = 0 Тогда
    ПечКоличество = "----";
    ПечЦена    = "----";
    ИначеЕсли (Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс)
    ИЛИ (Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница)
    ИЛИ (Докум.Аванс = 1) Тогда
    ПечКоличество = "----";
    ПечЦена    = "----";
    Иначе				
    ПечКоличество = Формат(ТабДок.Количество, "Ч-15.3,");
    Если ТабДок.Цена = 0 Тогда
    ПечЦена    = "----";
    Иначе   
    ПечЦена = Формат(ТабДок.Цена, "Ч-15.2,");
    КонецЕсли;
    КонецЕсли;
    Если (Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс)
    ИЛИ (Докум.ВидОперации = Перечисление.ВидыОперацийСчетаФактурыВыданного.СуммоваяРазница)
    ИЛИ (Докум.Аванс = 1) Тогда
    ПечСумма = "----";
    ИначеЕсли ТабДок.Сумма = 0 Тогда
    ПечСумма = "----";
    Иначе				 
    ПечСумма = Формат(ТабДок.Сумма, "Ч-15.2,");
    КонецЕсли;
    ПечАкциз = ?(ТабДок.АкцизСумма=0, "без акциза", Формат(ТабДок.АкцизСумма,"Ч-15.2,"));
    
    Если Докум.НДСпоСтавкеНольПроцентов = 1 Тогда
    ПечНДС = ?(ТабДок.НДС=0,"0,00", Формат(ТабДок.НДС,"Ч-15.2,"));
    Иначе
    ПечНДС = ?(ТабДок.НДС=0,"без НДС", Формат(ТабДок.НДС,"Ч-15.2,"));
    КонецЕсли;
    ПечВсего = ?(ТабДок.Всего=0,"----", Формат(ТабДок.Всего,"Ч-15.2,")); 
    
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    
    Если Докум.НДСпоСтавкеНольПроцентов = 1 Тогда 
    ПечИтогНДС = ?(ТабДок.Итог("НДС")=0,"0,00", Формат(ТабДок.Итог("НДС"),"Ч-15.2,"));
    Иначе
    ПечИтогНДС = ?(ТабДок.Итог("НДС")=0,"без НДС", Формат(ТабДок.Итог("НДС"),"Ч-15.2,"));
    КонецЕсли;
    
    
    ПечИтогВсего = ?(ТабДок.Итог("Всего")=0,"----", Формат(ТабДок.Итог("Всего"),"Ч-15.2,"));
    Если (Докум.ВидОперации <> Перечисление.ВидыОперацийСчетаФактурыВыданного.Аванс) Тогда
    СуммаБезНДС = ТабДок.Итог("Всего") - ТабДок.Итог("НДС");
    ПечИтогБезНДС = ?(СуммаБезНДС=0,"----", Формат(СуммаБезНДС,"Ч-15.2,"));
    Иначе
    ПечИтогБезНДС = "----";
    КонецЕсли;
    Таб.ВывестиСекцию("Подвал");
    Таб.Опции(0, 0, 0, 0, "ОпцииПечатиСчетаФактуры", "ОкноСчетаФактуры");
    
    Если ПустоеЗначение(ТекстПредупреждения) = 1 Тогда
    Таб.ОбластьПечати(1,,,);
    Иначе
    Таб.ОбластьПечати(2,,,);
    КонецЕсли;
    
    Таб.ПовторятьПриПечатиСтроки( 15, 15 );
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(2,,,,,,,,,1,,);
    Таб.Показать("Печать счета-фактуры","");
    КонецПроцедуры
    //******************************************************************************
    // ПоКнопкеПечать()
    //
    // Параметры:
    //  Нет
    //
    // Возвращаемое значение:
    //  Нет
    //
    // Описание:
    //
    Процедура ПоКнопкеПечать()
    
    Если Док.Выбран() = 0 Тогда
    Предупреждение("Не выбран документ!", 60);
    Возврат;
    КонецЕсли;
    
    Печать(Док);
    
    КонецПроцедуры // ПоКнопкеПечать()
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()
    
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    
    Докум	  = Форма.Параметр.Получить("Контекст");
    Устройство = Форма.Параметр.Получить("Устройство");
    КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
    
    Печать(Докум, Устройство, КолвоКопий);
    Статусвозврата(0);
    Возврат;
    КонецЕсли;
    
    
    КонецПроцедуры // ПриОткрытии()
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) В расширенной форме редактирования прикрепить к сообщению
    2) Выложить в файлообменник, а сюда ссылку
  16. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    http://www.fayloobmennik.net/3319827
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Заменить в макете печати (таблица) строка 15
    ИНН/КПП покупателя [Контрагент.ИНН] на ИНН/КПП покупателя [Докум.Грузополучатель.ИНН]
  18. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Все получилось! :yahoo:
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь.
    СОВЕТ: сделайте с текущей ВПФки копию (сохраните с другим именем) и используйте ее только для этого покупателя...
  20. Elena_
    Offline

    Elena_

    Регистрация:
    28 окт 2013
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Хорошо)

Поделиться этой страницей