7.7 ИспользоватьРодителя

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем drew, 12 дек 2006.

  1. TopicStarter Overlay
    drew
    Offline

    drew

    Регистрация:
    12 дек 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Помогите пожалуйста. Есть справочник, в нем две группы. Нужно сделать так: Если вводишь в группу элемент с уже существующим Наименованием тогда отмена записи. Но в другую группу можно было бы вводить элементы с таким же Наименованием. При представленном ниже коде, нельзя ввести элемент с уже существующим Наименованием даже если он в другой группе.
    Код:
     
    Процедура ПриЗаписи()
    
    Тов = СоздатьОбъект("Справочник.Товар");
    Тов.ИспользоватьРодителя();
    Тов.ВыбратьЭлементы();
    Пока Тов.ПолучитьЭлемент() = 1 Цикл
    Если Тов.Наименование = Наименование Тогда
    Предупреждение("Уже есть такой элемент!");
    Активизировать("Наименование");
    СтатусВозврата(0);
    КонецЕсли;
    КонецЦикла;
    
    КонецПроцедуры
    
    
  2. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    А если так?
    Код:
    Тов = СоздатьОбъект("Справочник.Товар");
    Тов.НайтиПоКоду("Код группы с запрещенными повторами");
    Если Родитель=Тов.ТекущийЭлемент() Тогда
    Тов.ИспользоватьРодителя(Тов.ТекущийЭлемент());
    Если Тов.НайтиПоНаименованию(Наименование,1,1)=1 Тогда
    Предупреждение("Уже есть такой элемент!");
    Активизировать("Наименование");
    СтатусВозврата(0);
    КонецЕсли;
    КонецЕсли;
    

Поделиться этой страницей