8.х ОБМЕН Использование параметров объекта в правилах конвертации

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем LxS, 12 июл 2011.

  1. TopicStarter Overlay
    LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Все уже наверняка обращали внимание на "не незаметный" батон Передавать данные в параметр в ПКС. Хотелось бы услышать от спецов, кто в реальности использовал этот механизм, каким образом его задействовать.

    К слову, у меня возникла ситуация, когда, во-первых, объект А в приемнике ищется по реквизиту с выполнением массы условий, и во-вторых, помимо этого объекта должны создаваться объекты других типов на основании данных, переданных из источника, но не имеющих непосредственного отношения к объекту А. Они содержатся в регистре сведений Значения свойств объекта.

    Отсюда выросла проблема: куда их поместить при обмене и каким образом?

    Если я верно уловил суть использования параметров объекта, то мне должно помочь использование этой примочки. Но до конца так и не разобрался в том, как их использовать.
  2. TopicStarter Overlay
    LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Разобрался в итоге.

    1. В ПКС включаем батон Передавать данные в параметр.
    2. В обработчике Перед выгрузкой определяем значение:

    Код:
    Значение = <Значение, передаваемое в параметр>
    
    3. В ПКО в обработчике После загрузки пишем следующее:

    Код:
    Если ПараметрыОбъекта <> Неопределено Тогда
    НашПараметр = ПараметрыОбъекта["ИмяПараметраОбъекта"];
    КонецЕсли;
    
    Если ЗначениеЗаполнено(НашПараметр) Тогда...
    
    Как всегда, все оказалось до безумия просто. Но информации об использовании этого механизма я не нашел нигде. Пришлось перековырять несколько типовых правил.
  3. Andy13
    Offline

    Andy13 Опытный в 1С

    Регистрация:
    1 мар 2010
    Сообщения:
    244
    Симпатии:
    2
    Баллы:
    29
    Хм, так вроде как в хелпе всё это описано...
  4. Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    239
    Симпатии:
    6
    Баллы:
    29
    Коллеги, а если мы передаем запись регистра сведений, а в приемнике необходимо изменить в этой записи значение измерения в зависимости от одного из значения ресурса? попытался сделать через параметр, он его читает, но при записи в приемник ошибки:


    {Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(4315)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
    ИмяПКО = ТекущиеКадровыеДанныеСотрудников
    ТипОбъекта = Регистр сведений набор записей: Текущие кадровые данные сотрудников
    Объект = РегистрСведенийНаборЗаписей.ТекущиеКадровыеДанныеСотрудников
    Обработчик = ПослеЗагрузкиОбъекта
    ОписаниеОшибки = Поле объекта не обнаружено (ТекущаяОрганизация)
    ПозицияМодуля = (29)
    КСообщенияОбОшибках = 21
    ВызватьИсключение СтрокаСообщенияОбОшибке;
    \

    ПКО: регистр сведений.

    Вот обработчик события в ПКО "После загрузки":


    Код:
    Организация = Справочники.Организации.ПустаяСсылка();
    
    Запрос = Новый Запрос;
    
    Запрос.Текст =
            "ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    Организации.Ссылка КАК Организация
            |ИЗ
            |    Справочник.Организации КАК Организации
            |ГДЕ
            |    Организации.ИНН = &ИНН";
       
    Запрос.УстановитьПараметр("ИНН", "8603000799");
       
    РезультатЗапроса = Запрос.Выполнить();
       
    Выборка = РезультатЗапроса.Выбрать();
       
    Пока Выборка.Следующий() Цикл
        Организация =  Выборка.Организация;
    КонецЦикла;
    
    НашПараметр = ПараметрыОбъекта["ОформленПоТрудовомуДоговору"];
    
    Сообщить(НашПараметр);
    
    Если Не НашПараметр  Тогда
        Объект.ТекущаяОрганизация = Организация;
        Объект.ДатаПриема         = Дата("19000101000000");
    КонецЕсли
    

    Кто сталкивался???
Похожие темы
  1. She
    Ответов:
    3
    Просмотров:
    3.098
  2. shurikvz
    Ответов:
    9
    Просмотров:
    2.351
  3. chehonte
    Ответов:
    8
    Просмотров:
    2.563
  4. Elenachka
    Ответов:
    0
    Просмотров:
    1.100
  5. eViLL
    Ответов:
    19
    Просмотров:
    1.638
Загрузка...

Поделиться этой страницей