8.х Использование открытого метода формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ЧКДзержинский, 22 сен 2009.

  1. TopicStarter Overlay
    ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Доброе время суток!
    Есть документ, создаваемый программно и есть другой документ тоже создаваемый программно и вводимый на основании первого. В модуле формы этого второго документа есть процедура с параметром "Экспорт" для заполнения таб. части на основании первого документа. В общем нужно после программного создания первого документа и создания на его основании второго документа, вызвать процедуру формы, предназначенную для ввода на основании. Можно ли как-то это сделать?
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну по идее ты можешь обращаться к это процедуре как к методу. В типовой есть например такое. В реализации товаров и услуг в форме есть экспортная процедура ЗаполнитьТекстПроСчетФактуру. А в счет фактуре соответственно:
    Код:
    Процедура ПослеЗаписи()
    
    МеханизмНумерацииОбъектов.ОбновитьПодсказкуКодНомерОбъекта(ЭтотОбъект.Метаданные(), ЭлементыФормы.ДействияФормы.Кнопки.Подменю, ЭлементыФормы.Номер);
    
    // Вывести в заголовке формы вид операции и статус документа (новый, не проведен, проведен).
    РаботаСДиалогами.УстановитьЗаголовокФормыДокумента(, ЭтотОбъект, ЭтаФорма);
    
    // Если открыли данную форму из формы документа, то там надо поменять текст
    Если  ВладелецФормы<>Неопределено Тогда
    
    Если ТипЗнч(ВладелецФормы) = Тип("Форма") тогда
    
    // Надо поменять текст про счет-фактуру в форме-владельце
    ВладелецФормы.ЗаполнитьТекстПроСчетФактуру();
    КонецЕсли;
    
    КонецЕсли; 
    
    КонецПроцедуры // ПослеЗаписи()
    
  3. TopicStarter Overlay
    ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Прежде чем вызвать метод формы, мне нужно эту форму получить из ссылки на документ. Это возможно?
  4. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну так метод ПолучитьФорму() вам в руки =)

Поделиться этой страницей