7.7 Использование компоненты ROM-Mail

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Maria_Ach, 18 авг 2009.

  1. TopicStarter Overlay
    Maria_Ach
    Offline

    Maria_Ach

    Регистрация:
    14 июл 2006
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте все. Помогите,пожалуйста. Из документов в 1С необходимо формировать и отправлять электронные сообщения. Использование V7Plus.dll и AddIn.V7Mail при большом количестве формирования писем работает со сбоем, не все письма доходят до адресата. При использовании компоненты ROM-Mail я подключаюсь к серверу( с которого нужна отправка), соединение есть. Программа не ругается. Однако сообщение не отправляется. Подскажите, пожалуйста, что я не так делаю.
    Код:
    [color=red]	Если[/color] ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll")=1 [color=red]Тогда[/color]		глВнешняяПочта = СоздатьОбъект("AddIn.AddInMail");[color=red]	Иначе[/color][color=red]		Сообщить[/color]("Не удалось загрузить почтовую компоненту ROM-Mail !!!","!!!");[color=red]	КонецЕсли[/color];	глВнешняяПочта.СерверОтправки= "SMTP.mail.ru";	//  "94.100.177.1";	глВнешняяПочта.ПортОтправки="25";[color=red]		Если[/color] глВнешняяПочта.Соединение=0 [color=red]Тогда[/color][color=red]		Если[/color] глВнешняяПочта.Подключиться("Отправка")=0 [color=red]Тогда[/color][color=red]				Сообщить[/color]("Не удалось подключиться к почтовому серверу","!");[color=red]				Возврат[/color];[color=red]			иначе[/color][color=red]				Сообщить[/color]("Подключились к почтовому серверу","!");[color=red]			КонецЕсли[/color];[color=red]		КонецЕсли[/color];[color=red]		Сообщить[/color]( "Соединение - " +Строка(глВнешняяПочта.Соединение));			 глВнешняяПочта.АдресОтправителя=Адрес_отправителя;;		глВнешняяПочта.ИмяОтправителя="Имя отправителя";		глВнешняяПочта.Логин=МойЛогин;		глВнешняяПочта.Пароль="********"; 		глВнешняяПочта.АутентификацияПриОтправке=1;		Пинг=глВнешняяПочта.PingText;		[color=red]Сообщить[/color](Пинг); 				глВнешняяПочта.Кодировка="windows-1251";		глВнешняяПочта.ТипПисьма=2;		глВнешняяПочта.АдресПолучателя=Адрес; 				Заголовок="Заказ поставщику";		глВнешняяПочта.Заголовок=Заголовок;		глВнешняяПочта.Тема="ТемаПисьма";					глВнешняяПочта.Тело="ТекстПисьма";[color=red]		Если[/color] глВнешняяПочта.Соединение=0 [color=red]Тогда[/color][color=red]			Сообщить[/color]("Соединение потеряно","!");[color=red]		ИначеЕсли[/color] глВнешняяПочта.Отправить()=1 [color=red]тогда[/color][color=red]			Сообщить[/color]("Почтовое сообщение отправлено","i");[color=red]		иначе[/color][color=red]			Сообщить[/color]("Не удалось отправить сообщение","!");[color=red]		КонецЕсли[/color];		глВнешняяПочта.Отключиться();		ТекстЗамечания = "";//*****************
    

    Заранее спасибо.
  2. ech
    Offline

    ech

    Регистрация:
    3 авг 2009
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Как вы определили, что письмо не отправляеться?
    Возможно вам лучше перейти на 8ку ,т.к. там движек уже встроен в платформу.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не отправляется со свех мест или с некоторых? Через программы типа TheBat или IExploere письма уходят нормально? Пробовали?
  4. makfromkz
    Offline

    makfromkz

    Регистрация:
    12 июн 2009
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Код:
    //******************************************************************************Процедура _SMTP(прм_КаталогБазы, прм_АдресПолучателя, прм_ЗаголовокПисьма, прм_ИмяФайлаВыгрузки)		Почта = СоздатьОбъект("AddIn.AddInMail");		Сообщить("---SMTP");		Почта.СерверОтправки="ВашПочтовыйСерверSMTP";		Почта.ПортОтправки="25";		Почта.Логин="ВашЛогин";		Почта.Пароль="ВашПароль";		Почта.АутентификацияПриОтправке=1;		//Почта.Отключиться();		Если Почта.Подключиться("Отправка")=0 Тогда			Почта.Отключиться();			Сообщить("Не удалось подключиться к серверу SMTP "+Почта.СерверОтправки+"!!!"); а=1/0;		Иначе			Сообщить("Подключение к серверу отправки почты (SMTP) прошло успешно");		КонецЕсли;		Почта.АдресОтправителя="ВашАдрес";		Почта.ИмяОтправителя="Автообмен";				Сообщить("Адрес получателя: "+прм_АдресПолучателя);				Почта.АдресПолучателя=СокрЛП(прм_АдресПолучателя);		Почта.Тема=СокрЛП(прм_ЗаголовокПисьма)+" "+ТекущаяДата()+" - "+ТекущееВремя();		Почта.Тело="вот оно - начало )))))";				стр=прм_КаталогБазы+СокрЛП(прм_ИмяФайлаВыгрузки);		Сообщить("Имя файла выгрузки="+стр);				Если ФС.СуществуетФайл(стр)=1 Тогда			Почта.Вложения=стр;		Иначе 			Сообщить("Не найден файл выгрузки: "+стр);		КонецЕсли;				Почта.Кодировка="windows-1251";		Почта.Важность=2;		Сообщить("Идет отправка сообщения ...");		Если Почта.Отправить()=1 Тогда			Сообщить(""+ТекущаяДата()+" - "+ТекущееВремя()+": Сообщение отправлено");		Иначе															Сообщить(""+ТекущаяДата()+" - "+ТекущееВремя()+": Не удалось отправить сообщение"); а=1/0;		КонецЕсли;		Почта.Отключиться();КонецПроцедуры
    
    // этот код работает у меня, образец также взял на просторах рунета
  5. TopicStarter Overlay
    Maria_Ach
    Offline

    Maria_Ach

    Регистрация:
    14 июл 2006
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Во первых, выдается сообщение, что сообщение не отправлено( Метод "Отправить()" равен 0).Во-вторых,я смотрела на своем почтовом ящике.
    Переход на восьмерку руководством у нас в ближайшее времяне планируется, к сожалению.
  6. TopicStarter Overlay
    Maria_Ach
    Offline

    Maria_Ach

    Регистрация:
    14 июл 2006
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Пока пробовала только со своего компьютера. С моего внешнего ящика на Mail.ru(IExploere) письма отправляются нормально.
    Пока разбиралась, выяснилось, что эта отправка сообщение таким образом им не нужна. Просто сейчас для себя интересно, почему не получается.

Поделиться этой страницей