8.х УПП Исчисление НДФЛ при начислении отпускных переходящих в новый отчетный период

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем Klondayk, 27 дек 2011.

  1. TopicStarter Overlay
    Klondayk
    Offline

    Klondayk

    Регистрация:
    27 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Тема избитая, много чего перерыл, но ни тут, ни где-то еще законченных решений не нашел.
    Имеется 1С:Предприятие 8.2 (8.2.13.219), Управление производственным предприятием, редакция 1.3 (1.3.17.1).
    Бухи начислили 01.12.2011 отпускные одному сотруднику с 19.12.2011 по 17.02.2012 за 55 дней. НДФЛ соответственно был удержан и перечислен в бюждет РФ.
    УПП все начисления и удержания соответственно разбила по месяцам. И в справку 2-НДФЛ вошли только отпускные за декабрь. Бухи хотят чтобы все начисления и удержания попадали в месяц выплаты и в справке и в БУ тоже. А еще чтобы сумма исчисленного, удерженного и перечисленого была закрыта декабрем и долга за налоговым агентом не оставалось (сейчас исчисленный совпадает с удеражанным, а перечисленный естественно больше на НДФЛ за январь и февраль).
    В регистр накопления НДФЛСведенияОДоходах процедура при записи добавлено:
    Код:
        Набор = РегистрыНакопления.НДФЛСведенияОДоходах.СоздатьНаборЗаписей();
    Набор.Отбор.Регистратор.Значение = Отбор.Регистратор.Значение;
    Набор.Прочитать();
    НадоЗаписать = Ложь; 
    Для Каждого Движение Из Набор Цикл
    Если НЕ (Движение.Период = Движение.ПериодРегистрации) ТОгда
    Движение.Период = Движение.ПериодРегистрации;
    НадоЗаписать= Истина; 
    КонецЕсли;
    //Сообщить(Движение.Период);
    
    КонецЦикла; 
    Если НадоЗаписать Тогда
    Набор.Записать();
    КонецЕсли;
    
    Теперь в весь доход попадает в декабрь, но в расчетах с бюджетом по сотрудником все по старому - сумма удержания распределена по месецам.
    Где это поправить? Или может кто предложит решение лучше?
    Ситуация вроде стандартная кто, как с этим борется?
    P.S. Судя по изученной информации в ЗиКе все аналогично.
  2. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    А почему у вас получилось, что перечисленный естественно больше, чем исчисленный? При заполнении документа "Начисление зарплаты" НДФЛ раскидывается на декабрь и январь и записывается в регистр Расчеты налоговых агентов с бюджетом по НДФЛ с "период = декабрь" и "месяц налогового периода = декабрь и январь". Если при разнесении перечисления НДФЛ правильно указать месяц ЗА который начислен НДФЛ, то по регистру исчисленный и перечисленный будут закрываться.

    Дальше, по БУ суммы и без переделки программы вроде как должны пройти в декабре: в начислении они рассчитываются в декабре и в корешке появляются декабрем, и в своде по начислениям проходят декабрем, и по регистрам проходят с периодом начисления = декабрь, и в док отражение зарплаты берутся декабрем.

    А вот в справке доходы - да, распределяются по месяцам, это, боюсь, исправлять будет довольно проблематично, потому что программа работает по месяцам налоговых периодов. Я бы не стала туда сильно лазить - много неприятностей можно себе в будущем огрести.

    И еще вопрос: а как вы собираетесь учитывать налоговую льготу, если у вас все начисление запишется в декабрь? Ведь если отпуск переходит на январь, то январская часть НДФЛ и рассчитываться должна с учетом январских льгот.

Поделиться этой страницей