Инвентаризация товаров на складе, Комплексная автоматизация

Тема в разделе "Общие вопросы по бухгалтерии", создана пользователем Юлия., 3 июл 2014.

  1. TopicStarter Overlay
    Юлия.
    Offline

    Юлия.

    Регистрация:
    7 май 2014
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Комплексная автоматизация, редакция 1.1 (1.1.48.1)

    В одной базе несколько организаций, у них общий склад.
    В настройках программы включен партионный учет, в регистре сведений "Настройка способа ведения управленческого партионного учета" у каждой фирмы стоит "По текущей организации".
    При проведении инвентаризации остатки формируются целиком по складу, в не зависимости от выбранной организации.

    Пример:
    Организация А купила "Товар1" 2шт. склад "Основной", организация Б купила такой-же товар 3шт. и отправила на "Основной" склад. Делаем "Инвентаризацию товаров" Организация А, склад "Основной", на остатках "Товар1" 5шт.!!!

    Как сделать инвентаризацию по одной организации? Может какие-о настройки не заполнены?
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Отладчиком пользуетесь
    посмотрите в процедуре
    ЗаполнитьПоОстаткамНаСкладе() в модуле документа.

    какие параметры ВремОрганизация тут
    Код:
    Запрос = ПостроительОтчета.ПолучитьЗапрос();
    
        Запрос.УстановитьПараметр("Склад",           Склад);
        Запрос.УстановитьПараметр("ПартионныйСклад", ВремСклад);
        Запрос.УстановитьПараметр("ПартионнаяОрганизация", ВремОрганизация);
        Запрос.УстановитьПараметр("ДатаОстатков",    ОбщегоНазначения.ПолучитьДатуОстатков(ЭтотОбъект));
    Там просто выше есть строчка

    ВремОрганизация = УправлениеЗапасами.ПолучитьОрганизациюВСоответствииСоСпособомВеденияПартионногоУчетаПоОрганизациям(Организация, СпособВеденияПартионногоУчетаПоОрганизацииДляУУ);

    вот ее код

    Код:
    Функция ПолучитьОрганизациюВСоответствииСоСпособомВеденияПартионногоУчетаПоОрганизациям(Организация, СпособВеденияПартионногоУчетаПоОрганизации) Экспорт
        Если СпособВеденияПартионногоУчетаПоОрганизации = Перечисления.СпособыВеденияПартионногоУчетаПоОрганизациям.ПоТекущейОрганизации Тогда
            Возврат Организация;
        ИначеЕсли СпособВеденияПартионногоУчетаПоОрганизации = Перечисления.СпособыВеденияПартионногоУчетаПоОрганизациям.ПоГоловнойОрганизации Тогда   
            Если НЕ Организация.Пустая() Тогда
                Возврат Организация.ГоловнаяОрганизация;
            Иначе
                Возврат Справочники.Организации.ПустаяСсылка();
            КонецЕсли;
        Иначе
            Возврат Справочники.Организации.ПустаяСсылка();
        КонецЕсли;
    КонецФункции
    и как Вы написали должно выполняться первое условие

Поделиться этой страницей