7.7 Инвентаризация по рознице

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем sapres, 9 июл 2009.

  1. TopicStarter Overlay
    sapres
    Offline

    sapres

    Регистрация:
    9 июл 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Задача стоит в том что бы в актах и описях инвентаризации стояла розничная цена, а ещё лучше можно было выбирать цену. Помогите пожалуйста! :smile: :unsure:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В российской конфе инвентаризацию можно делать ч/з очет ОстаткиТМЦ (есть кнопка), а в самом отчете можно выбрать по каким ценам формировать
  3. TopicStarter Overlay
    sapres
    Offline

    sapres

    Регистрация:
    9 июл 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Речь идёт именно о украинской версии. вот модуль документа инвентаризации. Надеюсь тут ещё не перевелись чародеи-рукотворцы которым это по плечу, не оставляйте людей несмыслящих с бедой один на один, знаю что это бывает и по плечу и по пояс....
    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier"> [color=green]//*****************************************************************************[/color]
    [color=green]// Описание переменных [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Дат[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> КодыСтатусов[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СписокПечати[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СписокДействий[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СтараяДата[color=red];[/color]           
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачальнаяДатаДокумента[color=red];[/color] [color=green]// Для контроля даты документа[/color]
    
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// "служебные" функции и процедуры [/color]
    
    [color=green]//*****************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ЗаголовокФормы[color=red]([/color][color=red])[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Заголовок[color=red],[/color] Название[color=red];[/color]
    Заголовок [color=red]=[/color] [color=black]"Инвентаризация"[/color][color=red];[/color]
    Название  [color=red]=[/color] [color=black]"Инвентаризация №"[/color][color=red];[/color]
    Заголовок [color=red]=[/color] Заголовок [color=red]+[/color] глЗаголовок[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]Заголовок[color=red]([/color]Заголовок[color=red])[/color][color=red];[/color]     
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> Название[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]//ЗаголовокФормы[/color]
    
    [color=green]//******************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбновитьНадписи[color=red]([/color][color=red])[/color]
    [color=green]// Формируем информационные строки[/color]
    Форма[color=red].[/color]ТекстВалюты[color=red].[/color]Заголовок[color=red]([/color]глСтрокаВалюты[color=red]([/color]Контекст[color=red])[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ТекстОснования[color=red].[/color]Заголовок[color=red]([/color]СокрП[color=red]([/color]Основание[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    [color=green]//******************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> НаборСпецификацииПоСкладу[color=red]([/color][color=red])[/color]
    
    УдалитьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    ВремРегистры[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Регистры"[/color][color=red])[/color][color=red];[/color]
    Рег[color=red]=[/color]ВремРегистры[color=red].[/color]ПартииТоваров[color=red];[/color]
    Запрос[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Запрос"[/color][color=red])[/color][color=red];[/color]
    
    ДатаКон [color=red]=[/color] ДатаДок [color=red]-[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ДатаКон[color=red]>[/color][color=red]=[/color]ПолучитьДатуТА[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color][color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ТекстЗапроса[color=red]=[/color][color=black]"[/color]
    [color=black]		|ПЕРИОД С ДатаКон По ДатаКон;"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]	|ИзмФирма=Регистр.ОстаткиТоваров.Фирма;[/color]
    [color=black]	|ИзмТовар=Регистр.ОстаткиТоваров.Товар;[/color]
    [color=black]	|ИзмСклад=Регистр.ОстаткиТоваров.Склад;[/color]
    [color=black]	|Кол=Регистр.ОстаткиТоваров.ОстатокТовара;"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ТипУчета[color=red]>[/color]Упр[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]Фирма[color=red].[/color]МетодРасчетаСебестоимостиФинансовогоУчета[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие (ИзмФирма=Фирма);"[/color][color=red];[/color]
    
    Рег[color=red].[/color]УстановитьЗначениеФильтра[color=red]([/color][color=black]"Фирма"[/color][color=red],[/color]Фирма[color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие (ИзмФирма=глПустаяФирма);"[/color][color=red];[/color]
    
    Рег[color=red].[/color]УстановитьЗначениеФильтра[color=red]([/color][color=black]"Фирма"[/color][color=red],[/color]глПустаяФирма[color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]	|Группировка ИзмТовар Без групп;// Упорядочить по ИзмТовар.Код;[/color]
    [color=black]	|Функция КонКол=КонОст(Кол);[/color]
    [color=black]	|"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТипИнвентаризации[color=red]=[/color][color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]//  <по складу>[/color]
    спСтатусы [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Склад[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]			|Условие (ИзмСклад=Склад);"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> Склад[color=red].[/color]ВидСклада [color=red]=[/color] Перечисление[color=red].[/color]ВидыСкладов[color=red].[/color]Оптовый <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]Купленный[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]Принятый[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">			ИначеЕсли</span> Склад[color=red].[/color]ВидСклада [color=red]=[/color] Перечисление[color=red].[/color]ВидыСкладов[color=red].[/color]Розничный <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаКупленный[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятый[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]				
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]			
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]Купленный[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]Принятый[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаКупленный[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятый[color=red])[/color][color=red];[/color]
    спСтатусы[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]				
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    Рег[color=red].[/color]УстановитьЗначениеФильтра[color=red]([/color][color=black]"Статус"[/color][color=red],[/color]спСтатусы[color=red],[/color][color=black]2[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Флаг[color=red]=[/color]Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color]ТекстЗапроса[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Флаг[color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">		Предупреждение</span>[color=red]([/color][color=black]"запрос по регистру ОстаткиТоваров не выполнился!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ДатаДок[color=red]<[/color]ПолучитьДатуТА[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Рег[color=red].[/color]ВременныйРасчет[color=red]([/color][color=red])[/color][color=red];[/color]
    ВремРегистры[color=red].[/color]РассчитатьРегистрыНа[color=red]([/color]ДатаДок[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Запрос[color=red].[/color]Группировка[color=red]([/color][color=black]"ИзмТовар"[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Запрос[color=red].[/color]ИзмТовар[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">			Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    НоваяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    Товар[color=red]=[/color]Запрос[color=red].[/color]ИзмТовар[color=red];[/color]
    Единица [color=red]=[/color] глВернутьБазовуюЕдиницуТовара[color=red]([/color]Товар[color=red])[/color][color=red];[/color]
    Коэффициент [color=red]=[/color] Единица[color=red].[/color]Коэффициент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипУчета[color=red]>[/color]Упр <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВП[color=red]=[/color]Гривня[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    ВП[color=red]=[/color]Товар[color=red].[/color]ВалютаУчета[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    Количество[color=red]=[/color]Запрос[color=red].[/color]КонКол[color=red];[/color] 
    ИнвКоличество[color=red]=[/color]Запрос[color=red].[/color]КонКол[color=red];[/color]
    
    Рег[color=red].[/color]УстановитьЗначениеФильтра[color=red]([/color][color=black]"Товар"[/color][color=red],[/color]Запрос[color=red].[/color]ИзмТовар[color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    тбИтоги [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ОбщаяСтоимость [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ОбщееКоличество [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Рег[color=red].[/color]ВыгрузитьИтоги[color=red]([/color]тбИтоги[color=red],[/color][color=black]1[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    тбИтоги[color=red].[/color]Свернуть[color=red]([/color][color=black]"Товар"[/color][color=red],[/color][color=black]"ОстатокТовара,Стоимость"[/color][color=red])[/color][color=red];[/color]
    
    тбИтоги[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> тбИтоги[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОбщаяСтоимость [color=red]=[/color] глПересчет[color=red]([/color]тбИтоги[color=red].[/color]Стоимость[color=red],[/color]ВП[color=red],[/color]Дата_Курса[color=red],[/color]Валюта[color=red],[/color]Дата_Курса[color=red])[/color][color=red];[/color]
    ОбщееКоличество [color=red]=[/color] тбИтоги[color=red].[/color]ОстатокТовара[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    Стоимость[color=red]=[/color][color=red]?[/color][color=red]([/color]ОбщееКоличество[color=red]=[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color]ОбщаяСтоимость[color=red]*[/color]Количество[color=red]/[/color]ОбщееКоличество[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    КонецПроцедуры	[color=green]// НаборСпецификацииПоСкладу[/color]
    
    [color=green]//******************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> НаборСпецификацииПоФирме[color=red]([/color][color=red])[/color]
    
    УдалитьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    Запрос[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Запрос"[/color][color=red])[/color][color=red];[/color]
    
    ДатаКон [color=red]=[/color] ДатаДок [color=red]-[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ДатаКон[color=red]>[/color][color=red]=[/color]ПолучитьДатуТА[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color][color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ТекстЗапроса[color=red]=[/color][color=black]"[/color]
    [color=black]		|ПЕРИОД С ДатаКон По ДатаКон;"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]	|ИзмТовар=Регистр.ПартииТоваров.Товар;[/color]
    [color=black]	|ИзмФирма=Регистр.ПартииТоваров.Фирма;[/color]
    [color=black]	|Статус=Регистр.ПартииТоваров.Статус;[/color]
    [color=black]	|Поставщик=Регистр.ПартииТоваров.Поставщик;[/color]
    [color=black]	|ИзмКонтрагент=Регистр.ПартииТоваров.Контрагент;[/color]
    [color=black]	|ИзмСтоимость=Регистр.ПартииТоваров.Стоимость;[/color]
    [color=black]	|Кол=Регистр.ПартииТоваров.ОстатокТовара;"[/color][color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]	|Группировка ИзмТовар Без групп;// Упорядочить по ИзмТовар.Код;[/color]
    [color=black]	|Функция КонКол=КонОст(Кол);[/color]
    [color=black]	|Функция КонСтоим=КонОст(ИзмСтоимость);[/color]
    [color=black]	|"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ТипУчета[color=red]>[/color]Упр[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">И</span> [color=red]([/color]Фирма[color=red].[/color]МетодРасчетаСебестоимостиФинансовогоУчета[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие (ИзмФирма=Фирма);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие (ИзмФирма=глПустаяФирма);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТипИнвентаризации[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]//  <по фирме в целом>[/color]
    [color=green]// без условий[/color]
    КодыСтатусов[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]Купленный[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]Принятый[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаКупленный[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятый[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]РозницаПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие(Статус в КодыСтатусов);"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> ТипИнвентаризации[color=red]=[/color][color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]//  <по реализатору>[/color]
    КодыСтатусов[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]ОтданныйКупленный[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]ОтданныйПринятый[color=red])[/color][color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие(Статус в КодыСтатусов);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Контрагент[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]			|Условие (ИзмКонтрагент=Контрагент);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> ТипИнвентаризации[color=red]=[/color][color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]//  <по комитенту>[/color]
    КодыСтатусов[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]Принятый[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПринятыйБезПраваПередачи[color=red])[/color][color=red];[/color]
    КодыСтатусов[color=red].[/color]ДобавитьЗначение[color=red]([/color]ОтданныйПринятый[color=red])[/color][color=red];[/color]
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]		|Условие(Статус в КодыСтатусов);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Контрагент[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса[color=red]=[/color]ТекстЗапроса[color=red]+[/color][color=black]"[/color]
    [color=black]			|Условие (Поставщик=Контрагент);"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Флаг[color=red]=[/color]Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color]ТекстЗапроса[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Флаг[color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">		Предупреждение</span>[color=red]([/color][color=black]"запрос по регистру ПартииТоваров не выполнился!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Запрос[color=red].[/color]Группировка[color=red]([/color][color=black]"ИзмТовар"[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Запрос[color=red].[/color]ИзмТовар[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">			Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    НоваяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    Товар[color=red]=[/color]Запрос[color=red].[/color]ИзмТовар[color=red];[/color]
    Единица [color=red]=[/color] глВернутьБазовуюЕдиницуТовара[color=red]([/color]Товар[color=red])[/color][color=red];[/color]
    Коэффициент [color=red]=[/color] Единица[color=red].[/color]Коэффициент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипУчета[color=red]>[/color]Упр <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВП[color=red]=[/color]Гривня[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    ВП[color=red]=[/color]Товар[color=red].[/color]ВалютаУчета[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    Количество[color=red]=[/color]Запрос[color=red].[/color]КонКол[color=red];[/color]
    ИнвКоличество[color=red]=[/color]Запрос[color=red].[/color]КонКол[color=red];[/color]
    Стоимость[color=red]=[/color]глПересчет[color=red]([/color]Запрос[color=red].[/color]КонСтоим[color=red],[/color]ВП[color=red],[/color]Дата_Курса[color=red],[/color]Валюта[color=red],[/color]Дата_Курса[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    КонецПроцедуры	[color=green]// НаборСпецификацииПоФирме()[/color]
    
    [color=green]//*************************************************************************[/color]
    [color=green]//------------------------------  П Р О Ц Е Д У Р Ы    П Е Ч А Т И  -------[/color]
    [color=green]//*************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПечатьСверки[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> СтрТип[color=red];[/color]
    
    Таб[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    
    ПечФорма [color=red]=[/color] [color=black]"СверкаНаличия"[/color][color=red];[/color]
    
    Язык [color=red]=[/color] глЯзык[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color] 	
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color]
    глУстПропись[color=red]([/color]Гривня[color=red],[/color]Язык[color=red])[/color][color=red];[/color]
    
    Заг[color=red]=[/color][color=black]""[/color][color=red];[/color]
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По фірмі "[/color][color=red],[/color][color=black]"По фирме "[/color][color=red])[/color][color=red]+[/color]Фирма[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Язык [color=red]=[/color] [color=black]"у"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТипИнвентаризации [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрТип [color=red]=[/color] [color=black]"по фірмі"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> ТипИнвентаризации [color=red]=[/color] [color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрТип [color=red]=[/color] [color=black]"по складу"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> ТипИнвентаризации [color=red]=[/color] [color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрТип [color=red]=[/color] [color=black]"по реалізатору"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> ТипИнвентаризации [color=red]=[/color] [color=black]4[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрТип [color=red]=[/color] [color=black]"по комітенту"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    А[color=red]=[/color]ТипыИнвентаризации[color=red].[/color]ПолучитьЗначение[color=red]([/color]ТипИнвентаризации[color=red],[/color]СтрТип[color=red])[/color][color=red];[/color]
    СтрТип [color=red]=[/color] СокрЛП[color=red]([/color]Сред[color=red]([/color]СтрТип[color=red],[/color][color=black]2[/color][color=red],[/color]СтрДлина[color=red]([/color]СтрТип[color=red])[/color][color=red]-[/color][color=black]2[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"Заповнено "[/color][color=red],[/color][color=black]"Заполнено "[/color][color=red])[/color][color=red]+[/color]СтрТип[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТипИнвентаризации[color=red]=[/color][color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Склад[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По складу "[/color][color=red],[/color][color=black]"По складу "[/color][color=red])[/color][color=red]+[/color]Склад[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По всіх складах"[/color][color=red],[/color][color=black]"По всем складам"[/color][color=red])[/color][color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> ТипИнвентаризации[color=red]>[/color][color=black]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Контрагент[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По контрагенту "[/color][color=red],[/color][color=black]"По контрагенту "[/color][color=red])[/color][color=red]+[/color]Контрагент[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По всіх контрагентах. "[/color][color=red],[/color][color=black]"По всем контрагентам. "[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color]
    
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    Ном[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Ном[color=red]=[/color]Ном[color=red]+[/color][color=black]1[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color]ПарСтрДок[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Защита[color=red]([/color]Константа[color=red].[/color]ФлагЗащитыТаблиц[color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]"Сверка наличия товаров"[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    [color=green]//*****************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПечатьАкта[color=red]([/color][color=red])[/color]
    
    Таб [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ПечФорма [color=red]=[/color] [color=black]"Таблица"[/color][color=red];[/color]
    
    Язык [color=red]=[/color] глЯзык[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color] 	
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color]
    глУстПропись[color=red]([/color]Гривня[color=red],[/color]Язык[color=red])[/color][color=red];[/color]
    
    КоличествоНаименований [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    КоличествоНаименований [color=red]=[/color] КоличествоНаименований [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    Таб[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    ИтСуммаПоФакту [color=red]=[/color] [color=black]0[/color][color=red];[/color]	
    ИтСуммаРазницы [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Заг[color=red]=[/color][color=black]""[/color][color=red];[/color]
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По фірмі "[/color][color=red],[/color][color=black]"По фирме "[/color][color=red])[/color][color=red]+[/color]Фирма[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"ПерваяСтраница"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Раздел2"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    ПечСтоимость [color=red]=[/color] [color=red]?[/color][color=red]([/color]Количество [color=red]=[/color] [color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color]Стоимость[color=red])[/color][color=red];[/color]
    ЦенаБезНДС 	 [color=red]=[/color] [color=red]?[/color][color=red]([/color]Количество [color=red]=[/color] [color=black]0[/color][color=red],[/color][color=red]?[/color][color=red]([/color]ИнвКоличество [color=red]=[/color] [color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color]Стоимость[color=red]/[/color]ИнвКоличество[color=red])[/color][color=red],[/color]Стоимость[color=red]/[/color]Количество[color=red])[/color][color=red];[/color]
    СуммаПоФакту [color=red]=[/color] [color=red]?[/color][color=red]([/color]Количество [color=red]=[/color] [color=black]0[/color][color=red],[/color]Стоимость[color=red],[/color]ИнвКоличество [color=red]*[/color] [color=red]([/color]Стоимость[color=red]/[/color]Количество[color=red])[/color][color=red])[/color][color=red];[/color]
    СуммаРазницы [color=red]=[/color] [color=red]?[/color][color=red]([/color]Количество [color=red]=[/color] [color=black]0[/color][color=red],[/color]Стоимость[color=red],[/color][color=red]([/color]ИнвКоличество [color=red]-[/color] Количество[color=red])[/color] [color=red]*[/color] [color=red]([/color]Стоимость[color=red]/[/color]Количество[color=red])[/color][color=red])[/color][color=red];[/color]
    ИтСуммаПоФакту [color=red]=[/color] ИтСуммаПоФакту [color=red]+[/color] СуммаПоФакту[color=red];[/color]
    ИтСуммаРазницы [color=red]=[/color] ИтСуммаРазницы [color=red]+[/color] СуммаРазницы[color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Подписи"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]"Акт инвентаризации №"[/color][color=red]+[/color]Строка[color=red]([/color]НомерДок[color=red])[/color][color=red]+[/color][color=black]" от "[/color][color=red]+[/color]Строка[color=red]([/color]ДатаДок[color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    [color=green]//*****************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПечатьИнвентаризационнаяОпись[color=red]([/color][color=red])[/color]
    
    Таб [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ПечФорма [color=red]=[/color] [color=black]"Опись"[/color][color=red];[/color]
    
    Язык [color=red]=[/color] [color=black]"у"[/color][color=red];[/color] 	
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color]ПечФорма[color=red])[/color][color=red];[/color]
    глУстПропись[color=red]([/color]Гривня[color=red],[/color]Язык[color=red])[/color][color=red];[/color]
    
    КоличествоНаименований [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Таб[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    Заг[color=red]=[/color][color=black]""[/color][color=red];[/color]
    Заг[color=red]=[/color]Заг[color=red]+[/color][color=red]?[/color][color=red]([/color]Язык[color=red]=[/color][color=black]"у"[/color][color=red],[/color][color=black]"По фірмі "[/color][color=red],[/color][color=black]"По фирме "[/color][color=red])[/color][color=red]+[/color]Фирма[color=red]+[/color][color=black]". "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]Фирма[color=red].[/color]ИспользоватьДату[color=red]([/color][color=red])[/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    текПолнНаименование [color=red]=[/color] Фирма[color=red].[/color]ПолнНаименование[color=red].[/color]Получить[color=red]([/color]ДатаДок[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>                                       
    Фирма[color=red].[/color]ИспользоватьДату[color=red]([/color]ДатаДок[color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color] [color=green]// для ситуации, когда после изменения фирмы изменяли дату[/color]
    текПолнНаименование [color=red]=[/color] Фирма[color=red].[/color]ПолнНаименование[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="wi
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Полагаю такие вопросы решают через личку, а для убеждения говорят сумму гонорара... Выложенный код мало кому поможет, не имея на руках исходной конфигурации.

Поделиться этой страницей