8.х УТ Инвентаризация и розничные цены

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем 1C8, 10 мар 2009.

  1. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    Люди добрые подскажите. Первый раз делаю инвентаризацию в УТ. При формировании документа почему-то цены на товар показываются закупочные. :unsure: А как сделать так чтобы выводились розничные?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ээээ.... Инвентаризация ведется по себестоимости.
  3. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    я так полагаю что никак? :-( А начальство требует. Говорить что типа как мы будем цену при инвентаризации сверять на ценниках....Может все таки можно это как-нить обойтить?
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Создайте ВФП для этого документа с нужной ценой и не парьтесь.
  5. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    Легко сказать. Если учесть что я 1С в глаза увидел первый раз пол года назад....
  6. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    Решил проблему по другому. Добрые люди помогли...надо было дописать немного в документе ИнвентаризацияТоваровНаСкладе, в модуле Процедуру ЗаполнитьПоОстаткамНаСкладе()
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Проблема в отсутствии понятий учета у руководства, а не в этом :)
    При попытке взыскать с людей по продажной стоимости - люди могут смело посылать накатать жалобу в надзорные органы.

    А так - есть отчет "Стоимостная оценка товаров на складе", который покажет нужную цену"
  8. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    Ладно, назовем Инвентаризацию по другому - Надо провести Ревизию, т.е. сверить наличие и цены товара с наличием и ценами на его в базе. При этом после ревизии надо чтобы присутствующие расписались на каждом листе и т.д. для этого идеально подходит форма Инвентаризации если в ней будут указанны цены розницы. Никто пока с людей не собирается взыскивать по продажной стоимости(пока :))...А отчет "Стоимостная оценка товаров на складе..." можно сказать совсем не подходит для ревизии...
  9. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    т.к. появились вопросы в личке по поводу этой темы выкладываю что я изменил в конфигурации:
    В Конфигураторе ищем Документ->ИнвенторизацияТоваровНаСкладе, открываем модуль объекта, ищем процедуру ЗаполнитьПоОстаткамНаСкладе, и весь ее код меняем на этот:
    Код:
    Если РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата).ВестиПартионныйУчетПоСкладам Тогда
    ВремСклад = Склад;
    Иначе
    ВремСклад = Справочники.Склады.ПустаяСсылка();
    КонецЕсли;
    
    ВалютаУпрУчета    = глЗначениеПеременной("ВалютаУправленческогоУчета");
    СтруктураКурса    = МодульВалютногоУчета.ПолучитьКурсВалюты(ВалютаУпрУчета, Дата);
    КурсУпрУчета      = СтруктураКурса.Курс;
    КратностьУпрУчета = СтруктураКурса.Кратность;
    
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
    
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |	ОстаткиТоваров.ЦенаВРознице,
    |	ВЫБОР
    |		КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |		  ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |			0 
    |		ИНАЧЕ
    |			СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |			/ СУММА(ОстаткиПартий.КоличествоОстаток)
    |	КОНЕЦ                                   КАК Сумма,
    |	СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество
    |ИЗ
    |	РегистрНакопления.ТоварыВНТТ.Остатки(&МоментДокумента,
    |	                                                   Склад = &Склад
    |//	                                                 И ЦенаВРознице > 0
    |) КАК ОстаткиТоваров
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |	РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |	                                                  Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |	ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |	И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |	И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |		ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.ЦенаВРознице";
    ИначеЕсли Склад.ВидСклада = Перечисления.ВидыСкладов.Розничный Тогда
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |     ОстаткиТоваров.Номенклатура,
    |     ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |     ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |     ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |     ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |     ОстаткиТоваров.Качество,
    |     СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    |     СУММА(ОстаткиТоваров.СуммаПродажнаяОстаток) КАК Сумма,
    |     ВЫБОР
    |          КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |            ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |               0 
    |          ИНАЧЕ
    |               СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |               / СУММА(ОстаткиПартий.КоличествоОстаток)
    |     КОНЕЦ                                  КАК СуммаУчет
    |ИЗ
    |     РегистрНакопления.ТоварыВРознице.Остатки(&МоментДокумента, Склад = &Склад)
    |КАК ОстаткиТоваров
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |     РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |                                                       Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |     ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |     И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |     И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |          ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |     И ОстаткиТоваров.Качество                   = ОстаткиПартий.Качество
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    |     ОстаткиТоваров.Номенклатура,
    |     ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |     ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |     ОстаткиТоваров.Качество";
    Иначе
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.Оптовый Тогда
    РегОстатки = "ТоварыНаСкладах";
    Иначе
    РегОстатки = "ТоварыВРознице";
    КонецЕсли;
    
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |	ОстаткиТоваров.Качество,
    |	СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    |	ВЫБОР
    |		КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |		  ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |			0 
    |		ИНАЧЕ
    |			СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |			/ СУММА(ОстаткиПартий.КоличествоОстаток)
    |	КОНЕЦ                                  КАК Сумма
    |ИЗ
    |	РегистрНакопления." + РегОстатки + ".Остатки(&МоментДокумента, Склад = &Склад)
    |КАК ОстаткиТоваров
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |	РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |	                                                  Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |	ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |	И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |	И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |		ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |	И ОстаткиТоваров.Качество                   = ОстаткиПартий.Качество
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Качество";
    
    КонецЕсли;
    
    Запрос = ПостроительОтчета.ПолучитьЗапрос();
    
    Запрос.УстановитьПараметр("Склад",           Склад);
    Запрос.УстановитьПараметр("ПартионныйСклад", ВремСклад);
    Если ЭтоНовый() Тогда
    Запрос.УстановитьПараметр("МоментДокумента", КонецДня(Дата));
    Иначе
    Запрос.УстановитьПараметр("МоментДокумента", МоментВремени());
    КонецЕсли;
    
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
    
    Если Выборка.Количество = 0 Тогда
    Продолжить;
    КонецЕсли;
    
    СтрокаТабличнойЧасти = Товары.Добавить();
    
    СтрокаТабличнойЧасти.Номенклатура     = Выборка.Номенклатура;
    СтрокаТабличнойЧасти.КоличествоУчет   = Выборка.Количество;
    СтрокаТабличнойЧасти.Количество       = ?(ТолькоУчетные, 0, СтрокаТабличнойЧасти.КоличествоУчет);
    СтрокаТабличнойЧасти.ЕдиницаИзмерения = Выборка.ЕдиницаХранения;
    СтрокаТабличнойЧасти.Коэффициент      = Выборка.КоэффициентЕдиницыХранения;
    СтрокаТабличнойЧасти.СуммаУчет        = Выборка.Сумма;
    СтрокаТабличнойЧасти.Сумма            = ?(ТолькоУчетные, 0, Выборка.Сумма);
    СтрокаТабличнойЧасти.Цена             = СтрокаТабличнойЧасти.Сумма / СтрокаТабличнойЧасти.КоличествоУчет;
    
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
    СтрокаТабличнойЧасти.ЦенаВРознице = Выборка.ЦенаВРознице;
    Иначе
    СтрокаТабличнойЧасти.Качество     = Выборка.Качество;
    КонецЕсли;
    
    СтрокаТабличнойЧасти.СуммаРегл        = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаТабличнойЧасти.Сумма, ВалютаУпрУчета,
    мВалютаРегламентированногоУчета, КурсУпрУчета, 1, КратностьУпрУчета, 1);
    
    СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
    Если УчитыватьСерии Тогда
    СтрокаТабличнойЧасти.СерияНоменклатуры = Выборка.СерияНоменклатуры;
    КонецЕсли;
    
    КонецЦикла;
    
    Удачи!
  10. igbes
    Offline

    igbes

    Регистрация:
    22 окт 2008
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    В розничной торговле учёт обычно ведётся в продажных ценах, так что Вы не совсем правы. Недостача тоже взыскивается в продажных ценах. На инфостарте есть внешний отчет, формирующий инвентаризационные документы с продажными ценами, так что не стоить делать изменения в типовой конфигурации.
  11. TopicStarter Overlay
    1C8
    Offline

    1C8 Опытный в 1С

    Регистрация:
    20 янв 2009
    Сообщения:
    216
    Симпатии:
    0
    Баллы:
    26
    спасибо, а ссылочку можешь дать?
  12. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Неговорите гоп, недостача может быть списана по себестоимости, на момент списания, по розничной цене недостачу не списывают, списывают на расходы фирмы недостаюшую сумму Розница - Списано. Каждый период закрывают счета по списанным товарам на общие "итоговые" счета организации 90 - 99.
    В противном случае ждите налоговой, они вам с удовольствием пени насчитают и закроют Вашу фирму, в лёгкую.

    Просто некоторые бухгалтеры делают иначе, не списывают товар по факту, а оставляют его торчать на счетах, а деньги относят к доходам фирмы, а налоговой реальную картину не показывают.
  13. Дмитрий83
    Offline

    Дмитрий83

    Регистрация:
    1 июл 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    У меня цены показывает розничные,но не на весь товар
  14. solvex
    Offline

    solvex

    Регистрация:
    6 июл 2010
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Потому что цены берутся не из того регистра.
    Обновленная версия.
    Код:
    Если РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата).ВестиПартионныйУчетПоСкладам Тогда
    ВремСклад = Склад;
    Иначе
    ВремСклад = Справочники.Склады.ПустаяСсылка();
    КонецЕсли;
    
    ВалютаУпрУчета    = глЗначениеПеременной("ВалютаУправленческогоУчета");
    СтруктураКурса    = ОбщегоНазначения.ПолучитьКурсВалюты(ВалютаУпрУчета, Дата);
    КурсУпрУчета      = СтруктураКурса.Курс;
    КратностьУпрУчета = СтруктураКурса.Кратность;
    
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
    
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |	ОстаткиТоваров.ЦенаВРознице,
    |	ВЫБОР
    |		КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |		  ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |			0 
    |		ИНАЧЕ
    |			СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |			/ СУММА(ОстаткиПартий.КоличествоОстаток)
    |	КОНЕЦ                                   КАК Сумма,
    |	СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество
    |ИЗ
    |	РегистрНакопления.ТоварыВНТТ.Остатки(&МоментДокумента,
    |	                                                   Склад = &Склад
    |//	                                                 И ЦенаВРознице > 0
    |) КАК ОстаткиТоваров
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |	РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |	                                                  Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |	ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |	И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |	И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |		ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.ЦенаВРознице";
    //Start  Инвентаризация в розничных ценах
    ИначеЕсли Склад.ВидСклада = Перечисления.ВидыСкладов.Розничный Тогда
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |     ОстаткиТоваров.Номенклатура,
    |     ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |     ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |     ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |     ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |     ОстаткиТоваров.Качество,
    |     СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    |		СУММА(ЦеныНоменклатурыСрезПоследних.Цена) Как Сумма,
    </span>
    |     ВЫБОР
    |          КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |            ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |               0 
    |          ИНАЧЕ
    |               СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |               / СУММА(ОстаткиПартий.КоличествоОстаток)
    |     КОНЕЦ                                  КАК СуммаУчет
    |ИЗ
    | 	РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&МоментДокумента, ТипЦен = &ТипЦен) КАК ЦеныНоменклатурыСрезПоследних,
    |		
    |     РегистрНакопления.ТоварыВРознице.Остатки(&МоментДокумента, Склад = &Склад)  КАК ОстаткиТоваров
    |		
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |     РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |                                                       Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |     ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |     И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |     И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |          ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |     И ОстаткиТоваров.Качество                   = ОстаткиПартий.Качество
    |
    |ГДЕ ЦеныНоменклатурыСрезПоследних.Номенклатура = ОстаткиТоваров.Номенклатура И ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры = ОстаткиТоваров.ХарактеристикаНоменклатуры
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |СГРУППИРОВАТЬ ПО
    |     ОстаткиТоваров.Номенклатура,
    |     ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |     ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |     ОстаткиТоваров.Качество";
    
    //End Инвентаризация в розничных ценах
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.Оптовый Тогда
    РегОстатки = "ТоварыНаСкладах";
    Иначе
    РегОстатки = "ТоварыВРознице";
    КонецЕсли;
    
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    |	ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    |	ОстаткиТоваров.Качество,
    |	СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    |	ВЫБОР
    |		КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    |		  ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    |			0 
    |		ИНАЧЕ
    |			СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    |			/ СУММА(ОстаткиПартий.КоличествоОстаток)
    |	КОНЕЦ                                  КАК Сумма
    |ИЗ
    |	РегистрНакопления." + РегОстатки + ".Остатки(&МоментДокумента, Склад = &Склад)
    |КАК ОстаткиТоваров
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |	РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента, 
    |	                                                  Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    |	ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    |	И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    |	И (ОстаткиТоваров.СерияНоменклатуры          = ОстаткиПартий.СерияНоменклатуры
    |		ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |	И ОстаткиТоваров.Качество                   = ОстаткиПартий.Качество
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура, 
    |     ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    |	ОстаткиТоваров.Номенклатура,
    |	ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    |	ОстаткиТоваров.СерияНоменклатуры,", "") + "
    |	ОстаткиТоваров.Качество";
    
    КонецЕсли;
    
    Запрос = ПостроительОтчета.ПолучитьЗапрос();
    
    Запрос.УстановитьПараметр("Склад",           Склад);
    Запрос.УстановитьПараметр("ТипЦен",           Склад.ТипЦенРозничнойТорговли);
    Запрос.УстановитьПараметр("ПартионныйСклад", ВремСклад);
    Если ЭтоНовый() Тогда
    Запрос.УстановитьПараметр("МоментДокумента", КонецДня(Дата));
    Иначе
    Запрос.УстановитьПараметр("МоментДокумента", МоментВремени());
    КонецЕсли;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
    
    Если Выборка.Количество = 0 Тогда
    Продолжить;
    КонецЕсли;
    
    СтрокаТабличнойЧасти = Товары.Добавить();
    
    СтрокаТабличнойЧасти.Номенклатура     = Выборка.Номенклатура;
    СтрокаТабличнойЧасти.КоличествоУчет   = Выборка.Количество;
    СтрокаТабличнойЧасти.Количество       = ?(ТолькоУчетные, 0, СтрокаТабличнойЧасти.КоличествоУчет);
    СтрокаТабличнойЧасти.ЕдиницаИзмерения = Выборка.ЕдиницаХранения;
    СтрокаТабличнойЧасти.Коэффициент      = Выборка.КоэффициентЕдиницыХранения;
    СтрокаТабличнойЧасти.СуммаУчет        = Выборка.Сумма;
    СтрокаТабличнойЧасти.Сумма            = ?(ТолькоУчетные, 0, Выборка.Сумма);
    СтрокаТабличнойЧасти.Цена             = СтрокаТабличнойЧасти.Сумма / СтрокаТабличнойЧасти.КоличествоУчет;
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
    СтрокаТабличнойЧасти.ЦенаВРознице = Выборка.ЦенаВРознице;
    Иначе
    СтрокаТабличнойЧасти.Качество     = Выборка.Качество;
    КонецЕсли;
    
    СтрокаТабличнойЧасти.СуммаРегл        = ОбщегоНазначения.ПересчитатьИзВалютыВВалюту(СтрокаТабличнойЧасти.Сумма, ВалютаУпрУчета,
    мВалютаРегламентированногоУчета, КурсУпрУчета, 1, КратностьУпрУчета, 1);
    
    СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
    Если УчитыватьСерии Тогда
    СтрокаТабличнойЧасти.СерияНоменклатуры = Выборка.СерияНоменклатуры;
    КонецЕсли;
    
    КонецЦикла;
    
    
  15. Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте,помогите, пожалуйста, в конфигурации поменять этот код.Как это сделать.он не копируется.... :angry:
  16. afl
    Offline

    afl

    Регистрация:
    27 авг 2010
    Сообщения:
    46
    Симпатии:
    0
    Баллы:
    1
    В конфигураторе Меню-Конфигурация-Поддержка-Настройка поддержки-Включить возможность изменения
  17. Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Возникла при копировании кода,следующая проблема, так как я новичок в программе,я не могу понять в чем проблема.В служебном сообщении: Метод обьекта не обнаружен(Пересчитать из Валюты в Валюту)Документ Инвентаризация Товаров на складе(739)Строка Табл.Части.Сумма Регл=общего назначения.

    Помогите, пожалуйста!!!
  18. Дмитрий83
    Offline

    Дмитрий83

    Регистрация:
    1 июл 2009
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Мы добавили дополнительную обработку,теперь в инвентаризации цены закупочные,а в печатной форме-розничные,если надо пишите-скину обработку
  19. milena384
    Offline

    milena384 Опытный в 1С

    Регистрация:
    4 ноя 2011
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    Добрый день. Если можно скиньте мне обработку.
  20. kofeman
    Offline

    kofeman Опытный в 1С

    Регистрация:
    26 июн 2011
    Сообщения:
    56
    Симпатии:
    0
    Баллы:
    26
    И мне если можно скиньте обработку.буду очень признателен

Поделиться этой страницей