Интерфейс Такси

Тема в разделе "Статьи", создана пользователем sphincks, 25 авг 2015.

  1. TopicStarter Overlay
    sphincks
    Offline

    sphincks

    Регистрация:
    25 авг 2015
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Обзорная статья посвященная интерфейсу "Такси" платформы 1С 8.3.

    Такси - это интерфейс 1С платформы, адаптированный под "привычки" современного пользователя привыкшего работать с веб-интерфейсом. Данный интерфейс поддерживает работу в мобильных устройствах.

    1. Включение
    При создании базы с нуля на платформе 1С 8.3 по умолчанию включается интерфейс "Такси".
    В режиме конфигуратора можно оставить возможность выбора пользователю переключать с каким интерфейсом он хочет работать.

    [​IMG]
    2. Работа пользователя
    Внешний вид интерфейса генерируется автоматически, меню функций повторяет меню функций интернет - браузера.

    [​IMG]

    Основные функции веб-браузера "перекачивавшие" в интерфейс "Такси":
    - начальная страница
    - копки навигации по открытым ранее окнам
    - возможность просмотреть историю - список последними объектов с которыми работали в ИС
    - возможность добавить часто используемые объекты в закладки
    - панель открытых напоминает вкладки, объекты которые открыты помещаются в панель открытых окон
    - есть возможность скопировать ссылку любого объекта системы передать его через e-mail пользователю этой же информационной системы.

    Для настройки интерфейса, в пользовательском режиме, существует такой инструмент как "Редактор панелей".
    [​IMG]
    С помощью "Редактора панелей" пользователь может под себя настроить интерфейс не прибегая к помощи программиста.

    3. Ограничения

    В интерфейсе "Такси" не рекомендуется использовать модальные окна, в частности не будут работать такие методы как: Вопрос, Предупреждение, ОткрытьЗначение.
    При вызове этих методов система сообщить об ошибке: "Использование модальных окон в данном режиме запрещено"

    Например при использовании метода глобального контекста "Вопрос" вызовет ошибку.


    Процедура ПередЗавершениемРаботыСистемы(Отказ)
    Если Не Вопрос("Уже уходите ?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да Тогда

    Отказ = Истина;
    КонецЕсли;
    КонецПроцедуры



    [​IMG]
    Ограничение - это связано с тем, что разработчики стандартизируют своё решение под мировые стандарты разработки программного обеспечение, интерфейс которых стремится быть похожим на веб-страница. "Приучают" пользователя работать в одном окне, а разработчика разрабатывать приложения которые будут работать в одном окне. Кроме того во многих веб-браузерах для обеспечения безопасности не поддерживаются модальные окна, в связи с чем интерфейса "Такси" может быть использован на различных устройствах, в том числе и мобильных.
    Но тем не менее в системе есть возможность снять ограничение на использование модальных окон.

    [​IMG]

    При этом правильным способом считается доработка конфигурации под новые требования. Встроенные операторы, которые вызывают модальные окна необходимо заменить на дублирующие функции:
    Предупреждение - ПоказатьПредупреждение
    Вопрос - ПоказатьВопрос
    ВвестиЧисло - ПоказатьВводЧисла
    Блокирующее окно отличается от модального тем, что открытие блокирующего окна не останавливает выполнение программного кода.
    • Модальное окно – окно, блокирующее весь интерфейс приложения, при этом исполнение кода останавливается до момента получения ответа пользователя.
    • Блокирующее окно – окно, блокирующее весь интерфейс или его часть, но при этом исполнение кода не останавливается.
    Пример решения вывода вопроса пользователю с помощью блокирующего окна при выходе из программы:

    // Модуль управляемого приложения
    Процедура ПередЗавершениемРаботыСистемы(Отказ)
    Отказ = Истина;
    Оповещение = Новый ОписаниеОповещения("ПриВыходеИзСистемы",ОбработкаОповещений);
    ПоказатьВопрос(Оповещение,"Вы уверены что хотите выйти ?",РежимДиалогаВопрос.ДаНет)
    КонецПроцедуры
    //Общий модуль Обработка Оповещений:Модуль
    Процедура ПриВыходеИзСистемы(Результат, Параметры) Экспорт
    Если Результат = КодВозвратаДиалога.Да Тогда
    // без условный выход из программы
    ЗавершитьРаботуСистемы(Ложь);
    Иначе
    Сообщить("Продолжаем трудиться!");
    КонецЕсли;
    КонецПроцедуры


    Для пользователя это будет выглядеть так:
    При выходе из системы выведется блокирующее окно:
    [​IMG]
    Это окно блокирует интерфейс в ожидание выбора от пользователя, при этом исполнение кода не останавливается
    При нажатии на кнопку "Да" программа завершает свою работу.
    При нажатии на кнопку "Нет" появляется сообщение с пользователь продолжает работать
    [​IMG]
    Отказ от модальности - вещь не проста не все сценарии использующие модальные окна на данный момент могут быть легко переведены на использование блокирующих окон.
    В целом удобный развивающийся механизм.

    Вложения:

    • 1.png
      1.png
      Размер файла:
      6,5 КБ
      Просмотров:
      112
    • 2.png
      2.png
      Размер файла:
      59,3 КБ
      Просмотров:
      114
    • 4.png
      4.png
      Размер файла:
      41,1 КБ
      Просмотров:
      112
    • 5.png
      5.png
      Размер файла:
      6,2 КБ
      Просмотров:
      112
    • 6.png
      6.png
      Размер файла:
      9 КБ
      Просмотров:
      111
    • 7.png
      7.png
      Размер файла:
      6,2 КБ
      Просмотров:
      110
    • 8.png
      8.png
      Размер файла:
      1,1 КБ
      Просмотров:
      111
    Последнее редактирование: 25 авг 2015
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Оформлено, вроде, не плохо. Статья не плохая :)
    Смысл размещения ?
  3. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    "панель истирии" это нечто :)))) надо в юмор запостить наверное это скрин
  4. Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    Ну как, у многих просто возникает вопрос: А зачем этот интерфейс нужен, если есть "Формы в закладках". По мне, так интерфейс "Такси" намного удобнее и приятнее, а те, кто работал в 1с 7.7 более приятен интерфейс "Формы в закладках" :)

Поделиться этой страницей