8.х ОБМЕН Импорт данных в 1С

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем lex_nv, 14 ноя 2011.

  1. TopicStarter Overlay
    lex_nv
    Offline

    lex_nv

    Регистрация:
    14 ноя 2011
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Нужен совет от гуру.
    Задача: импортировать данные по сотрудникам из Парус-Зарплата в 1Сv8.2 и ЗПП

    Из Паруса вытащить данные в принципе проблем нет, а вот как их правильно импортировать в 1С, пока представляю очень смутно.

    На сколько я понял в 1Сv8 это делается по средствам XML, либо была еще идея воспользоваться импортом из 1Сv7, сделав соответствующий файл с нужными данными (но как выглядит этот файл не представляю, т.к. 1Сv7 нет).
    В книгах которые идут с поставкой информация по импорту практически не описана.

    В общем я малость запутался и топчусь на одном месте, подскажите как вообще решаются в 1С подобные задачи? Или может литературу посоветуете? Куда копать?

    Заранее благодарю за любые советы.
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Вам надо программно писать полученные данные непосредственно в базу 1С. Либо, если dbf читаете не из 1С, то использовать СОМ - соединение.
  3. TopicStarter Overlay
    lex_nv
    Offline

    lex_nv

    Регистрация:
    14 ноя 2011
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    А не могли бы пример обращения к базе 1С с вызовом какого ни будь селекта показать? База файловая, что то не могу докумекать как к ней подключиться. Находил информацию что это делается только при наличии модуля web-сервера, чего у меня нет.

    И еще вопрос, скажите а конфигурация "Конвертация данных" может брать данные из файла? Или только из одной базы данных в другую?
  4. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Код:
     ТекстЗапроса = СформироатьСтрокуЗапроса();
    Команда.CommandText = ТекстЗапроса;
    
    
    Попытка
    НаборЗаписей = Новый COMОбъект("ADODB.RecordSet");
    НаборЗаписей.ActiveConnection = Акцесс;
    НаборЗаписей.CursorType = 1;
    НаборЗаписей.Open(ТекстЗапроса);
    Исключение
    
    Сообщить("Обломись:" + ОписаниеОшибки());
    КонецПопытки;
    
    Попытка
    НаборЗаписей.MoveFirst();
    Исключение
    НаборЗаписей.Close();
    Возврат;
    КонецПопытки;
    ТипЗначения = Тип("СправочникМенеджер." + ИмяСправочника);
    Объект = Новый(ТипЗначения, Неопределено);
    КолвоЗаписей = НаборЗаписей.RecordCount;
    ЭлементыФормы.Прогресс.МаксимальноеЗначение = КолвоЗаписей;
    ЭлементыФормы.Прогресс.МинимальноеЗначение = 0;
    ЭлементыФормы.Прогресс.Значение = 0;
    Пока НаборЗаписей.EOF() = 0 Цикл
    НовыйЭлемент = Объект.СоздатьЭлемент();
    Для N = 0 По ТаблицаСоответствияПолей.Количество() - 1 Цикл
    ИДПоля1С = СокрЛП(ТаблицаСоответствияПолей[N].ИДПоля1С);
    Если ИДПоля1С = "" Тогда
    Продолжить;
    КонецЕсли;
    ИмяПоляТаблицы = ТаблицаСоответствияПолей[N].ИдПоля;
    НовыйЭлемент[ИДПоля1С] = НаборЗаписей.Fields(ИмяПоляТаблицы).Value;
    КонецЦикла;
    НовыйЭлемент.Записать();
    НаборЗаписей.MoveNext();
    
    
    КонецЦикла;
    НаборЗаписей.Close();
    Предупреждение("Загрузка справочника завершена!");
    
    

    Ну вот Вам для примера загрузка из ДБФ файла через ком объект.
  5. TopicStarter Overlay
    lex_nv
    Offline

    lex_nv

    Регистрация:
    14 ноя 2011
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо, очень помогли. Направление движения выбрал теперь вроде правильно. Столкнулся только с другой проблемой.
    Импортирую в зарплату сотрудников. Сначала импортировал Справочник физические лица, все вроде нормально прошло. А как теперь программно установить при импорте в справочнике СотрудникиОрганизации ссылку на СотрудникОрганизации.Физлицо из справочника Физические лица?
  6. TopicStarter Overlay
    lex_nv
    Offline

    lex_nv

    Регистрация:
    14 ноя 2011
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Все, как устанавливать ссылки из других справочников тоже разобрался.
    [warn=Правила форума!]
    1 тема - 1 вопрос
    [/warn]

Поделиться этой страницей