8.х Импорт данных из Excel В 1С

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Jecka, 13 фев 2012.

  1. TopicStarter Overlay
    Jecka
    Offline

    Jecka

    Регистрация:
    1 апр 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Подскажите где взять простейшую инструкцию по импорту данных.
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    пройдитесь поиском.... тем, посвященных перекачке данных, много.
  3. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Обработка ЗагрузкаИзТабличногоДокумента вам в помощь.
  4. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    ObjExcel = Новый COMОбъект("Excel.Application");
    
    //чтобы эксель октрылся и стал выден юзеру. А то мало ли какие вопросы он попробует задать при открытии.
    ObjExcel.Visible = Истина;
    
    //путь к файлу XLS или XLSA
    РабочаяКнига = ObjExcel.WorkBooks.Open("D:\TEMP\123.xls");
    
    //можно передавать номер листа типа РабочийЛист = РабочаяКнига.Sheets(1);
    РабочийЛист = РабочаяКнига.Sheets("Лист1");
    
    //активация того листа, с которым работали. Нужна тут для дальнейших визуальных свестоперделок
    РабочийЛист.Activate();
    
    Для Сч = 1 По 1000 Цикл
    //визуальная свестоперделка показывающая какую строку сейчас обработаываем.
    //Применение этой свестоперделки замедляет работу с файлом (~10%) - зато моргает и мигает.
    РабочийЛист.Rows(Сч).Select();
    
    //получаем значения ячейки из колонки А (1).
    //Тут можем получить и текст, и число, и дату, и булево.
    КолонкаА = РабочийЛист.Cells(Сч, 1).Value;
    
    //получаем текстовое представление колонки А(1).
    //А то бывает что значение = 2, а текст отображается как 000000002.
    //Тут приходит только текст (СТРОКА)
    ТекстКолонкиА = РабочийЛист.Cells(Сч, 1).Text;
    
    #Если Клиент Тогда
    ОбработкаПрерыванияПользователя();
    #КонецЕсли
    КонецЦикла;
    
    //ObjExcel.Quit(); - вот так закрывается ЭКСЕЛЬ
    
    КонецПроцедуры
    Вот так например. Медленее чем запрос к SQL через ADO, зато визуально видно что происходит.
Похожие темы
  1. Vit@L
    Ответов:
    12
    Просмотров:
    2.780
  2. Dmitrii
    Ответов:
    8
    Просмотров:
    602
Загрузка...

Поделиться этой страницей