7.7 Группы без номенклатуры не попадают в запрос

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем cplusmax, 14 ноя 2012.

  1. TopicStarter Overlay
    cplusmax
    Offline

    cplusmax Опытный в 1С

    Регистрация:
    7 сен 2010
    Сообщения:
    154
    Симпатии:
    2
    Баллы:
    29
    Здравствуйте. Подскажите пожалуйста как лучше сделать...
    Требуется вывести в таблицу значений Группы ( с подгруппами) из справочника Номенклатура с использованием Множественного фильтра. Вот как я это пытаюсь сделать:

    Код:
    ТекстЗапроса=
    "//{{ЗАПРОС(Сформировать)
    |Без итогов;
    |Номенклатура = Справочник.Номенклатура.ТекущийЭлемент;
    |Родитель = Справочник.Номенклатура.Родитель;
    |Группировка Родитель Без групп;
    |"//}}ЗАПРОС
    ;
    НетОш = НетОш * глФильтрПоПеременнойЗапроса(ТаблицаМФ, "Номенклатура", ВыбТМЦ, "ВыбТМЦ", ТекстЗапроса, , "СвойстваНоменклатуры");
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса)=1 Тогда
    Пока Запрос.Группировка()=1 Цикл
    Если ПустоеЗначение(Запрос.Родитель)=0 Тогда
    Родитель=Запрос.Родитель;
    Стр="";  
    Если (ТзГруппы.НайтиЗначение(Родитель.Код, Стр, "ИД")=0) И (Родитель.Уровень()<3) Тогда
    ТзГруппы.НоваяСтрока();
    ТзГруппы.ИД=Родитель.Код;
    ТзГруппы.Название=Родитель.Наименование;
    КонецЕсли;  
    КонецЕсли;
    КонецЦикла;  
    КонецЕсли; 
    Но проблема в том, что в таблицу значений не попадают группы внутри которых нет номенклатурных позиций :unsure: а очень нужно чтобы попадали (потому как внутри этих групп есть еще подгруппы которые и содержат номенклатуру)... подскажите как этого можно добиться (чтобы в запрос попадали подгруппы не имеющие внутри себя номенклатурных позиций?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Для группировки Родитель убрать "без групп".
    А если еще нужны суммы по группам, тогда еще убрать "без итогов".

Поделиться этой страницей