7.7 Групповая печать

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем yan_komlev, 24 мар 2006.

  1. TopicStarter Overlay
    yan_komlev
    Offline

    yan_komlev

    Регистрация:
    24 мар 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Уважаемые госопода!

    Я знаю к 1C есть такая обработка, которая выводит напечать например за определенный период РКО или ПКО. Если у кого есть вышлите на адрес yan_komlev@mail.ru
    Буду очень благодарен.
  2. Оксана
    Offline

    Оксана

    Регистрация:
    16 апр 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Я бы тоже хотела иметь такую доработку, если у кого есть пришлите пожайлуста на elit_market@rambler.ru. Заранее благодарна.
  3. xan
    Offline

    xan

    Регистрация:
    25 апр 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    ВСЕ ПРОСТО!!! Сам недавно делал такую обработку для платежных документов.
    Создаете новый отчет или форму. Задаете период через, например Дата1 и Дата 2.
    Добавляете табличные формы из нужных документов. Также берете процедуры печати из самих документов. вставляете параметр процедуры в виде выбранного виды документа документа. Дальше дело техники. Если не совсем понятно пишите на sslnt@mail.ru/
  4. Nick
    Offline

    Nick

    Регистрация:
    21 сен 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    // Вызов процедуры на примере документа.
    // модуль формы документа
    Процедура ПриОткрытии()
    Если ТипЗначенияСтр(Форма.Параметр)="СписокЗначений" тогда
    СЗ=Форма.Параметр;
    Команда=СЗ.Получить("Команда");
    Если "Печать"=Команда тогда
    Печать();
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    // Сам вызов (из любого места конфигурации):
    СЗ=СоздатьОбъект("СписокЗначений");
    СЗ.ДобавитьЗначение("Печать","Команда");
    ОткрытьФормуМодально(Док.ТекущийДокумент(),СЗ);
  5. SKryl
    Offline

    SKryl

    Регистрация:
    13 янв 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Пришлите и мне пожалуйста эту обработку! syromyatnikova@maple.ru Заранее спасибо!!!

Поделиться этой страницей