7.7 Группировка Все ВошедшиеВЗапрос

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Black Cat, 27 окт 2011.

  1. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Товарищи, помогите понять смысл этих добавочных слов. Когда и зачем применяют Все, а когда Все ВошедшиеВЗапрос ?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Когда нужно получить все элементы (ну скажем справочника номенклатуры) даже если они не попали в функцию (к примеру не было движений если запрос по регистрам)
  3. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Ну а чем отличаются "Все" и "Все ВошедшиеВЗапрос" ?
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Все - в запросе будут все возможные значения данных.
    ВошедшиеВЗапрос - уточняет условие Все и будут включены данные, по которым есть значение хотя бы в одной строке запроса.
  5. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Вот такой запрос:

    Код:
    ТекстЗапроса="
    |Период с НачДата по КонДата;
    |РегПокупатель	= Регистр.Продажи.Покупатель;
    |РегПроект = Регистр.Продажи.Покупатель.Проект;
    |РегФирма  	= Регистр.Продажи.Фирма;
    |ПродСт		= Регистр.Продажи.ПродСтоимость;
    |ПродВ		= Регистр.Продажи.ПродСтоимостьВ;
    |Функция СуммаПродСт = Сумма(ПродСт);
    |Функция СуммаПродВ = Сумма(ПродВ);
    |Группировка Месяц;
    |Группировка РегПроект;
    |Группировка РегПокупатель Без Групп;
    |";
    
    Если Фирма.Выбран()=1 Тогда
    ТекстЗапроса=ТекстЗапроса+"
    |Условие (РегФирма = Фирма);";
    КонецЕсли;
    
    Если Контрагент.Выбран()=1 Тогда
    ТекстЗапроса=ТекстЗапроса+"
    |Условие (РегПокупатель В Контрагент);";
    КонецЕсли;
    
    Если Проект.Выбран()=1 Тогда
    ТекстЗапроса=ТекстЗапроса+"
    |Условие (РегПроект = Проект);";
    КонецЕсли;
    
    // Если ошибка в запросе, то выход из процедуры  
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    
    В какую группировку вставить "Все" или "Все ВошедшиеВЗапрос". чтоб вывести даже месяца, в которых не было движения (обе функции равнялись 0) ?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  7. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Нет, не прокатывает. Контрагенты, по которым не было движения, не выводятся.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Группировка РегПокупатель Без Групп Все;
  9. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Тоже не выводятся.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    все кто есть должны выводиться... Если вообще нет движений - тогда да. А если хоть в одном месяце есть - выведет
  11. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Дык мне и нужно чтоб выводились даже те, по которым не было движения ни в одном месяце.
    Смысл таков: выбираем проект (у нас он равен манагеру, работающему с клиентом). Выбираем период например с начала года. И запускаем отчет. Есть такие клиенты, которые в прошлом году работали, а в этом не разу. Вот их нужно тоже увидеть, чтоб манагеру надавать по шапке, потому что упустил клиента.
    Как тогда таких вывести ?
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    вам никто не мешает сделать так:
    Код:
    РегПокупатель	= Регистр.Продажи.Покупатель,Справочник.Контрагенты;
    
    
  13. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Спасибо. Более менее разобрался
  14. TopicStarter Overlay
    Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Не буду создавать новую тему спрошу здесь.
    Как получить через Запрос всю номенклатуру справочника Номенклатура, по которой не было движения за период и остаток за весь период равнялся 0 в регистре ОстаткиТМЦ ?
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Хм.... Теоретически можно. Отобрать товары по которым не было движений (по аналогии с контрагентами пост 12) + функция получения конечного остатка и на все это накладывайте условие = 0;

Поделиться этой страницей