8.х группировка в отчете через построитель

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем bannov, 26 окт 2009.

  1. TopicStarter Overlay
    bannov
    Offline

    bannov Опытный в 1С

    Регистрация:
    17 дек 2008
    Сообщения:
    185
    Симпатии:
    0
    Баллы:
    26
    1С 8.1 УПП
    Делаю отчет через построитель. Каким образом можно сделать чтобы на выходе информация была сразу на втором уровне группировок?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    ВЫ имеете виду сразу сгруппировать? Только кодом
  3. TopicStarter Overlay
    bannov
    Offline

    bannov Опытный в 1С

    Регистрация:
    17 дек 2008
    Сообщения:
    185
    Симпатии:
    0
    Баллы:
    26
    я понимаю что кодом, не знаю как
  4. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    если я правильно понял, то у табличного поля есть метод ПоказатьУровеньГруппировок(Уровень)...посмотрите его
  5. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Код:
     Процедура ГлавнаяКомманднаяПанельДействие1(Кнопка)
    
    // Очистим табличный документ - результат 
    ЭлементыФормы.Результат.Очистить();
    
    // Сгенерируем макет компоновки данных при помощи компоновщика макета 
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    
    // В качестве схемы компоновки будет выступать схема самого отчета 
    // В качестве настроек отчета - текущие настройки отчета 
    // Данные расшифровки будем помещать в свойство расширения формы - ДанныеРасшифровки 
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    
    // Создадим и инициализируем процессор компоновки 
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ,ДанныеРасшифровки);
    
    // Создадим и инициализируем процессор вывода результата 
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ЭлементыФормы.Результат);
    
    // Обозначим начало вывода 
    ПроцессорВывода.НачатьВывод();
    
    // Основной цикл вывода отчета 
    Пока Истина Цикл
    
    // Получим следующий элемент результата компоновки 
    ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    
    Если ЭлементРезультата = Неопределено Тогда
    // Следующий элемент не получен - заканчиваем цикл вывода 
    Прервать;
    
    Иначе
    // Элемент получен - выведем его при помощи процессора вывода 
    ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
    ********** вот это ********ЭлементыФормы.Результат.ПоказатьУровеньГруппировокСтрок(0) *******
    КонецЕсли;
    
    КонецЦикла;
    
    // Обозначем завершение вывода 
    ПроцессорВывода.ЗакончитьВывод();
    
    КонецПроцедуры
    
    
    

Поделиться этой страницей