7.7 Глупый вопрос

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем igorekkrav, 20 май 2011.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите пробегаю по всем документам Заявка . Как мне пробежать еще по табличной части реквезита ДатаОжидания и получить значения.


    Код:
    Процедура Сформировать()	
    // Перебор строк документов 
    Док = СоздатьОбъект("Документ.Заявка"); 
    Док.ВыбратьДокументы(ВыбНачПериода, ВыбКонПериода); 
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    
    Пока Док.ПолучитьСтроку() = 1 Цикл  
    //Ожидание = Док.ДатаОжидания;
    КонецЦикла; 
    Пока Док.ПолучитьДокумент() = 1 Цикл  
    Док.ВыбратьСтроки();
    Таб.ВывестиСекцию("Заголовок");	
    КонецЦикла;    
    
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    
    КонецПроцедуры
    
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.174
    Симпатии:
    13
    Баллы:
    29
    Получай документ и пробегай по нему....
  3. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Спасибо, понял!
  4. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    А как выташить в 7.7 строки в документе ?

    В цикле

    Код:
    Для Каждого СтрокаТабЧасти Из ЭтотОбъект.ТабЧастьПараметрыМашин Цикл
    Сообщить(СтрокаТабЧасти.Машина);
    Сообщить(СтрокаТабЧасти.Продукция);
    КонецЦикла;
    
    Это для 8 ки
  5. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Код:
    Документ.ВыбратьСтроки();
    Пока Документ.ПолучитьСтроку() = 1 Цикл
    ...
    КонецЦикла;
    
    
  6. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    спасибо!!

    Подскажите а расшифровку поля можно только из запроса получить?
  7. SirStefan
    Offline

    SirStefan Опытный в 1С

    Регистрация:
    20 апр 2010
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    А что есть расшифровка поля?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Наверное имелись ввиду реквизиты т.части документов....

    Код:
    Документ.ВыбратьСтроки();
    Пока Документ.ПолучитьСтроку() = 1 Цикл
    НашаПеременная=Документ.НужныйРеквизитТЧ;
    ...
    КонецЦикла;
    
    
  9. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Расшифровка поля в отчете. Ставлю расшифровка (Док) для поля Док. Не проваливается:(

    Код:
    Процедура Сформировать()	
    // Перебор строк документов 
    Док = СоздатьОбъект("Документ.Заявка"); 
    Док.ВыбратьДокументы(ВыбНачПериода, ВыбКонПериода); 
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Таб.ВывестиСекцию("Заголовок");
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку() = 1 Цикл   
    Ожидание = Док.ДатаОжидания;    
    Таб.ВывестиСекцию("Ожидание");
    КонецЦикла;  
    КонецЦикла;
    
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    
    КонецПроцедуры
    
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Для того чтобы "провалился" (я думаю что надо просто открыть) напишите:
    Код:
    Док.ТекущийДокумент()
    
    
    в поле расшифровки
  11. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Спасибо , работает.
  12. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите еще вопросик если можно. Как можно к ТекущаяДата() прибавить 2 дня ?
  13. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ТекущаяДата() +2
  14. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    спасибо!

Поделиться этой страницей