7.7 глПолучитьЦену() возвращает 0

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем dimi3o, 25 янв 2013.

  1. TopicStarter Overlay
    dimi3o
    Offline

    dimi3o

    Регистрация:
    25 янв 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Не получается вернуть цену. Что не так я делаю? Просто не находит. Хотя в реализации все работает и параметры полностью совпадают при просмотре. Вот код обработки Киоска:

    Код:
    Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
    Перем ВремТовар, ВремЕдиница, ВремКоличество;
    Перем ЦенаЦены;
    ТипЦен = СоздатьОбъект("Справочник.ТипыЦен");
    ТипЦен.НайтиПоНаименованию("Розничные");
    Валюта = СоздатьОбъект("Справочник.Валюты");
    Валюта.НайтиПоНаименованию("руб.");
    Курс = 1.000;
    Если Событие = "BarCodeValue" Тогда
    Если Форма.ТолькоПросмотр() = 0 Тогда
    Если глПолучитьТоварПоШтрихкоду(Данные, ВремТовар, ВремЕдиница, ВремКоличество) <> 0 Тогда
    Форма.Товар .Заголовок(" "+ВремТовар);
    Форма.Цена .Заголовок(глПолучитьЦену(ВремТовар, ТипЦен, РабочаяДата(), ВремЕдиница, Валюта, Курс));
    Сообщить(" "+ВремТовар+" "+ТипЦен+" "+РабочаяДата()+" "+ВремЕдиница+" "+Валюта+" "+Курс);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    // Обработка закончена. Готовы к получению нового штрихкода.
    глСканерПосылкаДанных(1);
    КонецПроцедуры

    Вот что возвращает Сообщить():
    Соус Стебель бамбука 300г дой пак барбекю Розничные 25.01.13 шт руб. 1

    Параметры полностью сходятся с теми, что вводятся в глПолучитьЦену() в реализации. Только там выводит цену 26.9, а у меня - 0!
    При этом наименование позиции полностью и корректно выводит!
    Подскажите мужики! Заранее спасибо!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    для начата проверьте... находит ли по наименованию.
    Код:
    Сообщить(Валюта.НайтиПоНаименованию("руб."));
    

Поделиться этой страницей