8.х Главная книга

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Rais, 11 ноя 2011.

  1. TopicStarter Overlay
    Rais
    Offline

    Rais

    Регистрация:
    16 май 2011
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Скачал внешний отчет Главная книга по субсчетам для 1С 8.2 Бухгалтерия 1.6 и пытаюсь переделать под свою бухгалтерию. И конечно в моей конфигурации Метод объекта не обнаружен (ПривестиКЧислу)
    Что это может быть за метод, как его задать?
    Код:
    // Получим конечное сальдо:
    Если Не СтруктураПараметров.РазвернутоеСальдо Тогда
    
    СуммаКонДт = СуммаНачДт + БухгалтерскиеОтчеты.ПривестиКЧислу(ОбщийИтог.СуммаОборотДт) - БухгалтерскиеОтчеты.ПривестиКЧислу(ОбщийИтог.СуммаОборотКт);
    
    СуммаКонКт = СуммаНачКт;
    
    Иначе
    
    ДеревоОстатков = СтруктураПараметров["ДеревоОстатков"];
    КолвоСтрок = ДеревоОстатков.Строки.Количество();
    
    Если КолвоСтрок<>0 Тогда
    
    СтрокаОстатков = ДеревоОстатков.Строки[0];
    
    СуммаКонДт = СтрокаОстатков.СуммаРазвернутоКонДт;
    СуммаКонКт = СтрокаОстатков.СуммаРазвернутоКонКт;
    
    Иначе
    СуммаКонДт = 0;
    СуммаКонКт = 0;
    КонецЕсли;
    КонецЕсли;
    
    Если Не СтруктураПараметров.РазвернутоеСальдо Тогда
    
    Если СуммаКонДт>СуммаКонКт Тогда
    СуммаКонДт=СуммаКонДт-СуммаКонКт;
    СуммаКонКт=0;
    Иначе
    СуммаКонКт=СуммаКонКт-СуммаКонДт;
    СуммаКонДт=0;
    КонецЕсли;
    
    КонецЕсли;
    
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Возьмите типовую и смотрите в ней нужные функции.
    Код:
    // функция приводит значение из выборки к числу
    Функция ПривестиКЧислу(Значение) Экспорт
    
    Если Значение = NULL Тогда
    Возврат 0;
    Иначе
    Возврат Значение;
    КонецЕсли;
    
    КонецФункции
    
    
  3. TopicStarter Overlay
    Rais
    Offline

    Rais

    Регистрация:
    16 май 2011
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Спасибо огроменное!

Поделиться этой страницей