7.7 Галочка выделения всех данных в списке

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 26 июл 2010.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Подскажите, пожалуйста, как в списке значений еще поставить галочку для выбора всех значений сразу?

    Это по теме перенос данных. (обработка изменить родителя)

    Вложения:

  2. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    Две кнопки. Обе используют одну и ту же процедуру, но каждая передает свой аргумент.
    Процедура перебирает все элементы списка и устанавливает/удаляет пометки согласно переданому аргументу.

    Вложения:

  3. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Спасибо!
    У меня тоже получилось по-своему. (приложение)

    А можно ли выделить всех, кроме тех, которые начинаются с буквы Д?

    Вложения:

  4. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    Очень хорошо! :) Вы молодец. :unsure:

    А насчет отметок... А стоит ли овчинка выделки? Действительно ли нужна такая функция или может стоить пнуть пользователей чтобы не роптали на и без того облегчившуюся жизнь? :smile:

    В общем я вижу это так:
    Код:
    Процедура ВыбратьБукву();
    
    Перем Буква;
    
    Если ВвестиСтроку(Буква,"Введите первую букву",1) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Для Индекс = 1 По Спис.РазмерСписка() Цикл
    Если ВРег(Буква) = ВРег(Лев(Строка(Спис.ПолучитьЗначение(Индекс)),1)) Тогда
    Спис.Пометка(Индекс,1);  //[i]помечаем[/i] эти пункты
    КонецЕсли;
    КонецЦикла;
    
    Установить("");  //инвертируем отметки (на основе вашей доработки)
    
    КонецПроцедуры
    

Поделиться этой страницей