7.7 Галочка в списке справочника. Как?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем antares, 29 май 2008.

  1. TopicStarter Overlay
    antares
    Offline

    antares Опытный в 1С

    Регистрация:
    30 ноя 2006
    Сообщения:
    340
    Симпатии:
    7
    Баллы:
    29
    1с 7.7.025 ЗИК 2.81
    Люди, подскажите кто если эту проблему осилил, как в поле списка справочника отразить галочку. В свойствах многострочной части вроде есть вкладка "картинка", но методов типа "ВыводитьПиктограмму()" как в ТЗ нет, и че делать незнаю пока. Цеплять 1с++ пока не хоца (это в крайнем случае) и переписывать список на ТЗ тоже. Заранее спасибо.
  2. Akulina
    Offline

    Akulina Опытный в 1С

    Регистрация:
    30 авг 2007
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    В свойствах списка на закладке "Дополнительно" надо установть флажок "список с пометками"
  3. TopicStarter Overlay
    antares
    Offline

    antares Опытный в 1С

    Регистрация:
    30 ноя 2006
    Сообщения:
    340
    Симпатии:
    7
    Баллы:
    29
    Боюсь, "Akulina" вы не правы. Или я вас не правильно понял. В свойствах многострочной части справочника вкладки "дополнительно" нет. Скорее вы говорите о справочнике 8-ой версии. Тут речь о 7-ой.
  4. Akulina
    Offline

    Akulina Опытный в 1С

    Регистрация:
    30 авг 2007
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Это я Вас неправильно поняла. Я думала, что речь идет об объекте формы типа "список". Но в Вашу проблему тоже можно решить. В свойствах табличной части на закладке "Картинка" нажмите кнопку "изменить картинку" и из библиотеки картинок выберите картинку с галочкой. У меня, например, выбрана картинка с красной галочкой. Добавьте колонку типа "текстовое поле". Далее для этого поля пропишите формулу вызова функции, например ОтобразитьГалочку().
    А в модуле формы саму функцию:
    Код:
    Функция ОтобразитьГалочку()
    Если <какое-то условие> Тогда
    НомПикт = 1;
    Иначе
    НомПикт = 2;
    КонецЕсли;
    
    Возврат НомПикт;
    КонецФункции
    
    
  5. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    antares, посмотри как это реализованно в документе "ЗаписиКнигиПокупок/Продаж" в бухгалтерии
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Можно обойтись и без картинок:
    найти символ "галки" в каком-нить "символьном" шрифте и использовать его.
  7. TopicStarter Overlay
    antares
    Offline

    antares Опытный в 1С

    Регистрация:
    30 ноя 2006
    Сообщения:
    340
    Симпатии:
    7
    Баллы:
    29
    Thank's всем! Идея с символьным шрифтом крайне оригинальна!

    p.s. Кстати, может силами "форум-сообщества" решим еще одну задачку.Там же. Есть обработка, в ней таблица вывода, в ячейках "расшифровка" и в модуле обработки предопределенная процедура "ОбработкаЯчейкиТаблицы()". Но при DBLCLK в ячейку полученного отчета иногда вхожу в локальную пред-ую процедуру, а иногда вываливаюсь в глобальную процедуру с выводом окошка со значением "расшифровки". Ни кто с таким парадоксом не сталкивался?
  8. Decokz
    Offline

    Decokz

    Регистрация:
    18 ноя 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    ПОСЛЕ установки картинки. можно ли при двойном нажатии пользователя на картинку, изменение значения элемента и соотвественно чтоб картинка менялась. какой функцией это можно сделать?
    Возможно:
    Процедура ПриНачалеРедактированияСтроки()
    КонецПроцедуры

    Но как узнать на каком столбце было двойное нажатие.
    т.к. у меня три столбца с картинками.

    Все. нашел =)

    Форма.АктивныйЭлемент();

    спасибо всем! )))

Поделиться этой страницей