7.7 Функция вывода остатков по заболансовым счетам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем НатахаБ, 30 янв 2008.

  1. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    второй день ведем дискуссию а ты еще так и не решила чего ты хочешь! сотрудник не меняется, и не должен меняться, я понял так, что ты выбираешь конкретного сотрудника и хочешь узнать че на нем весит... это раз...
    а два это то, что зачем тебе счета помимо выше перечисленных? если хочешь всетаки - то добавляй в СЗ их... только с обязательным условиям что на этих счетах должно быть субконто сотрудники...
    вообщем примерно так...
  2. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Другие счета мне не нужны. Надо если материал не числится (нулевое количество на счете у сотрудника) чтобы это было показано, если есть то какое количество. Т.е чтобы весь справочник материалов выходил. Надо чтобы было на подобие как в Справочник.Материалы.ФормеСписка.ДляПодбора. На этой форме выводятся остатки по Местам Хранения, а надо чтобы выводились остатки по Сотруднику с забалансового счета :unsure:
  3. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    :unsure: ты наконец-то рассказала чего ты хочешь!!!
    Код:
    Процедура Заполнить(РасчетИзКолонки=1)
    
    Остаток = 0;
    ИспользоватьСчета = СоздатьОбъект("СписокЗначений");
    ИспользоватьСчета.ДобавитьЗначение(СчетПоКоду("МЦ.04"));
    ИспользоватьСчета.ДобавитьЗначение(СчетПоКоду("МЦ.03"));
    ИспользоватьСчета.ДобавитьЗначение(СчетПоКоду("МЦ.02"));
    
    Если (РасчетИзКолонки = 0) или (РасчетИзКолонки = 1)  Тогда
    Если (КонМесяца(КонтекстФормыДокумента.ДатаДок) <= КонецРассчитанногоПериодаБИ())
    и (ТекущийЭлемент().Выбран() = 1) Тогда
    Если МОЛКто.Выбран() = 1  Тогда
    Остаток = БИ.СКД(ИспользоватьСчета, "К",, ТекущийЭлемент(), МОЛКто);    
    Иначе
    Остаток = БИ.СКД(ИспользоватьСчета, "К",, ТекущийЭлемент());
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;                
    
    Возврат СокрЛ(Формат(Остаток, "Ч15.3."));
    КонецПроцедуры
    
    
    
  4. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Большое Спасибо :unsure:

Поделиться этой страницей