7.7 Фотография товара в справочнике ТОВАРЫ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем BOBS, 26 окт 2010.

  1. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Посмотрите форум тут уже обсуждалось как к номенклатурное строке присвоить фото, найдите почитайте если что не получаться будет напишите тут.
    Вот смотрите
    http://www.1c-pro.ru/topic21516.html/page__hl__%2B%D0%BA%D0%B0%D1%80%D1%82%D0%B8%D0%BD%D0%BA%D0%B0+%2B%D0%BD%D0%BE%D0%BC%D0%B5%D0%BD%D0%BA%D0%BB%D0%B0%D1%82%D1%83%D1%80%D0%B5__fromsearch__1
  2. goshanek
    Offline

    goshanek

    Регистрация:
    17 окт 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    окно в номенклатуре и кнопку сделал, а как прописать чтобы при нажатии кнопки открылась папка с картинками и в окне отображалась выбраная картинка?
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Смотрите "КомандаСистемы" и "ЗапуститьПриложение"
  4. goshanek
    Offline

    goshanek

    Регистрация:
    17 окт 2012
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    все сделал но теперь проблема, выбираешь фото, устанавливаешь на товар, показывает картинку, но эта картинка устанавливается на все товары, на отдельный товар не ставится отдельная картинка. как сделать чтобы на каждый товар своя картинка была. и при выходе из программы картинки не сохраняются (т.е. их потом нет на товаре)

    вот что прописано в конфигураторе:
    Код:
    Процедура УстановитьКартинку()
    перем ИмяФайла;
    перем ИмяКат;
    если ФС.ВыбратьФайлКартинки(0,ИмяФайла,ИмяКат,"Выберите файл с картинкой",)=0 тогда
    Возврат;
    конецесли;
    ИмяФайла=СокрЛП(ИмяФайла);
    ИмяКат=СокрЛП(ИмяКат);
    Поз=Найти(ИмяФайла,".");
    Расширение=Сред(ИмяФайла,Поз);
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.НайтиЭлемент(ТекущийЭлемент());
    Стр=СокрЛП(Спр.Код);
    ПутьКуда=СокрЛП(Константа.ПутьКФото)+Стр+Расширение;
    если ФС.СуществуетФайл(ПутьКуда)=1 тогда
    Если Вопрос("Файл уже есть. Перезаписать?","Да+Нет")<>"Да" Тогда
    Возврат;
    КонецЕсли;
    Ф=СоздатьОбъект("Картинка");
    Фото.УстановитьКартинку(Ф);
    ФС.УдалитьФайл(ПутьКуда) ;
    если ФС.СуществуетФайл(ПутьКуда)=1 тогда
    Сообщить("Не удалился");
    КонецЕсли;
    конецесли; 
    ФС.КопироватьФайл(ИмяКат+ИмяФайла,ПутьКуда,0);
    Фото.Загрузить(ПутьКуда);
    КонецПроцедуры // УстановитьКартинку()
    Процедура ПоказатьКартинку()																		 
    Если ПустоеЗначение(ТекущийЭлемент()) = 1 Тогда
    Возврат;
    конецесли;
    Имя=СокрЛП(Константа.ПутьКФото)+СокрЛП(ТекущийЭлемент().Код)+".jpg";
    Если ФС.СуществуетФайл(Имя)=1 Тогда
    Фото.Загрузить(Имя);
    Фото.РежимРисования(3);
    иначе
    Ф=СоздатьОбъект("Картинка");
    Фото.УстановитьКартинку(Ф);
    Фото.РежимРисования(3);
    КонецЕсли;
    КонецПроцедуры
    процедура БольшаяКартинка()
    Имя=СокрЛП(Константа.ПутьКФото)+СокрЛП(ТекущийЭлемент().Код)+".jpg";
    Если ФС.СуществуетФайл(Имя)=1 Тогда
    ОткрытьФорму("Обработка.БольшаяКартинка",Фото);
    конецесли;
    конецпроцедуры

Поделиться этой страницей