8.х ФормированиеПечатныхФорм.ПредставлениеСерий

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Кирилл_15, 2 ноя 2009.

  1. TopicStarter Overlay
    Кирилл_15
    Offline

    Кирилл_15 Опытный в 1С

    Регистрация:
    2 ноя 2009
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Добрый День.Кто встречался с коллекции "ФормированиеПечатныхФорм.ПредставлениеСерий" В УПП 8.1?
    Мне нужно в поле включить в скобках ХарактеристикуНомеклатуры вот так не работает:
    Область.Параметры.Материал =Обход.Материал+" "+ФормированиеПечатныхФорм.ПредставлениеСерий(Обход);Выдает ошибку "Поле объекта не обнаружено (Серия)"

    А Так работает,только не красиво и без скобок.Параметры.Материал =Обход.Материал+" "+Обход.Характеристика;

    Материал Храктрестика
    Грунт-эмаль желтый
    Проволока сварочн., 1,2
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Мда... А в запросе серию вытаскиваете? Что вы туда передаете вообще :)
  3. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    У Вас в выборке нет поля "Серия", вот и ошибку выдает.
  4. TopicStarter Overlay
    Кирилл_15
    Offline

    Кирилл_15 Опытный в 1С

    Регистрация:
    2 ноя 2009
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26




    Про этот Выбор Обход = РезультатЗапроса.Выбрать();
    Пока Обход.Следующий() Цикл

    Область.Параметры.ПечМатериал =Обход.ПечМатериал+" "+ФормированиеПечатныхФорм.ПредставлениеСерий(Обход);
    Область.Параметры.Материал = Обход.Материал;

    Область.Параметры.ПечЕдИзм = Обход.ПечЕдИзм;
    Область.Параметры.ЕдИзм = Обход.ЕдИзм;

    Область.Параметры.КолРезерв = Обход.КолРезерв;
    Область.Параметры.КолРазмещено = Обход.КолРазмещено;

    Если ВидимостьНЗП Тогда
    Область.Параметры.КолНЗП = Обход.КолНЗП;
    РасшифровкаНЗП .Вставить("Номенклатура", Обход.Материал);
    Область.Параметры.РасшифровкаНЗП = РасшифровкаНЗП;
    КонецЕсли;



    Если вы помните вы на днях мне помогали по ХарактеристиНомеклатуры.Все этот же Запрос я мучаю :unsure: :


    ТекстЗапроса =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    | РегЗаказы.Материал КАК Материал,
    | РегЗаказы.Характеристика КАК Характеристика,
    | РегЗаказы.ЕдИзм КАК ЕдИзм,
    | ПРЕДСТАВЛЕНИЕ(РегЗаказы.Материал) КАК ПечМатериал,
    | ПРЕДСТАВЛЕНИЕ(РегЗаказы.ЕдИзм) КАК ПечЕдИзм,
    | РегЗаказы.Материал.Артикул КАК Артикул,
    | СУММА(РегЗаказы.КолПотребность) КАК КолПотребность,
    | СУММА(РегЗаказы.КолРезерв) КАК КолРезерв,
    | СУММА(РегЗаказы.КолРазмещено) КАК КолРазмещено,
    | СУММА(РегЗаказы.КолНЗП) КАК КолНЗП,
    | СУММА(РегЗаказы.КолПотребность - РегЗаказы.КолРезерв - РегЗаказы.КолРазмещено - РегЗаказы.КолНЗП) КАК Необеспечено
    |ИЗ
    | (ВЫБРАТЬ
    | РегПотребности.Номенклатура КАК Материал,
    | РегПотребности.ХарактеристикаНоменклатуры КАК Характеристика,
    | РегПотребности.ЕдиницаИзмерения КАК ЕдИзм,
    | РегПотребности.КоличествоОстаток КАК КолПотребность,
    | 0 КАК КолРезерв,
    | 0 КАК КолРазмещено,
    | 0 КАК КолНЗП
    | ИЗ
    | РегистрНакопления.ПотребностиЗаказовНаПроизводство.Остатки(&ДатаКон, ЗаказНаПроизводство = &Заказ) КАК РегПотребности
    |
    | ОБЪЕДИНИТЬ ВСЕ
    |
    | ВЫБРАТЬ
    | РегРезерв.ХарактеристикаНоменклатуры КАК Характеристика,
    | РегРезерв.Номенклатура,
    | РегРезерв.Номенклатура.ЕдиницаХраненияОстатков,
    | 0,
    | РегРезерв.КоличествоОстаток,
    | 0,
    | 0
    | ИЗ
    | РегистрНакопления.ТоварыВРезервеНаСкладах.Остатки(&ДатаКон, ДокументРезерва = &Заказ) КАК РегРезерв
    |
    | ОБЪЕДИНИТЬ ВСЕ
    |
    | ВЫБРАТЬ
    | РегРазмещение.ХарактеристикаНоменклатуры КАК Характеристика,
    | РегРазмещение.Номенклатура,
    | РегРазмещение.Номенклатура.ЕдиницаХраненияОстатков,
    | 0,
    | 0,
    | РегРазмещение.КоличествоОстаток,
    | 0
    | ИЗ
    | РегистрНакопления.РазмещениеЗаказовПокупателей.Остатки(&ДатаКон, ЗаказПокупателя = &Заказ) КАК РегРазмещение
    |"+?(ВидимостьНЗП, "
    | ОБЪЕДИНИТЬ ВСЕ
    |
    | ВЫБРАТЬ
    | РегНЗП.ХарактеристикаЗатраты КАК Характеристика,
    | РегНЗП.Затрата,
    | РегНЗП.Затрата.ЕдиницаХраненияОстатков,
    | 0,
    | 0,
    | 0,
    | РегНЗП.КоличествоОстаток
    | ИЗ
    | РегистрНакопления.МатериалыВПроизводстве.Остатки(&ДатаКон, Заказ = &Заказ) КАК РегНЗП","")+") КАК РегЗаказы
    |
    |СГРУППИРОВАТЬ ПО
    | РегЗаказы.Материал,
    | РегЗаказы.Характеристика,
    | РегЗаказы.ЕдИзм
    |
    |УПОРЯДОЧИТЬ ПО
    | Характеристика.Наименование,
    | ЕдИзм.Наименование";

    Запрос = Новый Запрос;
    Запрос.Текст = ТекстЗапроса;

    //Запрос.УстановитьПараметр( "МассивНоменклатуры", Заказ.Материалы.ВыгрузитьКолонку("Номенклатура"));
    Запрос.УстановитьПараметр( "Заказ", Заказ);
    Если КонДата = '00010101000000' Тогда
    Запрос.УстановитьПараметр( "ДатаКон", КонДата);
    Иначе
    Запрос.УстановитьПараметр( "ДатаКон", Новый Граница( КонецДня(КонДата), ВидГраницы.Включая));
    КонецЕсли;

    РезультатЗапроса = Запрос.Выполнить();

    // Формирование печатной формы
    Макет = ПолучитьМакет("АнализЗаказа");

    Область = Макет.ПолучитьОбласть("ШапкаМатериалы"+?(ВидимостьНЗП, "","БезНЗП"));
    ТабДокумент.Вывести(Область);

    Область = Макет.ПолучитьОбласть("СтрокаМатериалы"+?(ВидимостьНЗП, "","БезНЗП"));

    РасшифровкаРезерв = Новый Структура("ВидОтчета", "ТоварыВРезервеНаСкладах");
    РасшифровкаРазмещено = Новый Структура("ВидОтчета", "РазмещенияВЗаказах");
    РасшифровкаНЗП = Новый Структура("ВидОтчета", "ВедомостьПроизводственныеЗатраты");

    Обход = РезультатЗапроса.Выбрать();
    Пока Обход.Следующий() Цикл

    Область.Параметры.ПечМатериал =Обход.ПечМатериал+" "+ФормированиеПечатныхФорм.ПредставлениеСерий(Обход);
    Область.Параметры.Материал = Обход.Материал;

    Область.Параметры.ПечЕдИзм = Обход.ПечЕдИзм;
    Область.Параметры.ЕдИзм = Обход.ЕдИзм;

    Область.Параметры.КолРезерв = Обход.КолРезерв;
    Область.Параметры.КолРазмещено = Обход.КолРазмещено;
  5. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Ну так не выбирается в этом запросе серия. У Вас только "характеристика" там есть. Если хотите ее в скобках вывести, то нужно Свою процедуру вставить в модуль. Примерно такую:
    Код:
    //Обрезанная функция ПредставлениеСерий
    Функция ПредставлениеХарактеристик(Выборка) Экспорт
    
    Результат = "(";
    
    Если ЗначениеЗаполнено(Выборка.Характеристика) Тогда
    Результат = Результат + Выборка.Характеристика;
    Результат = СтрЗаменить(Результат, "", "");
    КонецЕсли;
    
    Результат = Результат + ")";
    
    Возврат ?(Результат = "()", "", " " + Результат);
    
    КонецФункции // ПредставлениеХарактеристик()
    
    
    
    и вызывать ее у себя - заменить
    Код:
    Область.Параметры.ПечМатериал =Обход.ПечМатериал+" "+ФормированиеПечатныхФорм.ПредставлениеСерий(Обход);
    
    
    на
    Код:
    Область.Параметры.ПечМатериал =Обход.ПечМатериал+ПредставлениеХарактеристик(Обход);
    
    
  6. TopicStarter Overlay
    Кирилл_15
    Offline

    Кирилл_15 Опытный в 1С

    Регистрация:
    2 ноя 2009
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    СпасибоОгромное тебе спасибо,все работает.
    Я уже сам дошел до в Спр.Номенклатуры и нашел эту Функция.И еще спасибо что не банишь новечков и хватает на нас терпения и времени .............
  7. TopicStarter Overlay
    Кирилл_15
    Offline

    Кирилл_15 Опытный в 1С

    Регистрация:
    2 ноя 2009
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    А сейчас что не то?
    НЗП двоится и в скопках:



    Артикул Материалы Потребность Обеспечение Осталось обеспечить
    Зарезерви- ровано Размещено НЗП Зарезерви- ровано Размещено НЗП
    0169-1х Круг 30 кг 5,16 - - - 5,16
    0061-1х Круг 50 кг 22,60 - - - 22,60
    0099-1 Уголок 50*5 кг 1,66 - - - 1,66
    0007-1х Лист 6 кг 229,30 - - - 229,30
    0068-1х Лист 8 кг 309,55 - - - 309,55
    0069-1х Лист 10 кг 846,54 - - - 846,54
    0082-1х Лист 12 кг 90,37 - - - 90,37
    0071-1х Лист 16 кг 25,01 - - - 25,01
    0072-1х Лист 20 кг 30,69 - - - 30,69
    0115-1 Швеллер 10 кг 68,80 - - - 68,80
    0011-1 Швеллер 16 кг 292,55 - - - 292,55
    (Круг 30; Круг 30) кг - - - -5,16 5,16
    (Круг 50; Круг 50) кг - - - -22,60 22,60
    (Лист 10; Лист 10) кг - - - 846,54 -846,54
    (Лист 12; Лист 12) кг - - - -90,37 90,37
    (Лист 16; Лист 16) кг - - - -25,01 25,01
    (Лист 20; Лист 20) кг - - - -30,69 30,69
    (Лист 6; Лист 6) кг - - - -229,30 229,30
    (Лист 8; Лист 8) кг - - - 309,55 -309,55
    (Уголок 50*5; Уголок 50*5) кг - - - 1,66 -1,66
    (Швеллер 10; Швеллер 10) кг - - - -68,80 68,80
    (Швеллер 16; Швеллер 16) кг - - - -292,55 292,55
  8. TopicStarter Overlay
    Кирилл_15
    Offline

    Кирилл_15 Опытный в 1С

    Регистрация:
    2 ноя 2009
    Сообщения:
    57
    Симпатии:
    0
    Баллы:
    26
    Все разобрался.................

Поделиться этой страницей