[РЕШЕНО] Формирование книги покупок и книги продаж Ошибка

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем evgenn1, 10 апр 2015.

  1. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Срочно нужна помощь!
    При формировании книги покупок и книги продаж в 1С Бухгалтерия 7.70.594 ошибка по расположению номера и даты
    Книги покупок и продаж по постановлению №1137
    В графе3 написано Номер и дата, а формирует Дату и номер (как в предедущей версии книг)


    [​IMG]
    Последнее редактирование: 10 апр 2015
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Вы хотите сами поменять или задание за баксы кому-то предлагаете?
  3. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Сделать надо в течении часа, если кода немного переписывать могу сам, если много то и заплачу (сколько?)
    Сам могу внешние печатные отредактировать, обновить и установить (подключить оборудование) 1с и т.п. вообщем немного в курсе как и что..
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.438
    Симпатии:
    373
    Баллы:
    104
    ну поменяли там порядок вывода значений, там дел на несколько минут всего
    сами легко найдёте, раз подправить немного кода для вас не проблема
  5. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    проблема найти это место :)
    в печатной форме есть такая переменная СокрП(ТабОтчета.ДатаНомер) #С а ДатаНомер где то в ГМ
    --- Объединение сообщений, 10 апр 2015 ---
    Уважаемые подскажите пожалуйста где и что дописать !
    Денег на телефон сброшу 500 р. у меня есть на карточке, гл.бух очень хорошая женщина и заставлять её вручную перебивать так не охота... а директор жмот, штатный программист бухает и трубку не берет ))

    Вложения:

    Последнее редактирование: 10 апр 2015
  6. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.438
    Симпатии:
    373
    Баллы:
    104
    что-то не так
    вот из 7.70.590
    Код:
    //*****************************************************************************
    Функция ДатаНомер(Док)
       
        Если Док.Вид() = "ЗаписьКнигиПродаж" Тогда
            Возврат Док.ДатаНомерСчетаФактуры;
       
        ИначеЕсли Док.Вид() = "ЗаписьКнигиПродажТорг" Тогда
            Возврат Док.НомерДата;
           
        Иначе
            Если ДатаКонца >= '30.05.2006' Тогда
                Возврат Формат(Док.ДатаДок, "Д") + " №" + Док.НомерДок;
            Иначе
                Возврат Формат(Док.ДатаДок, "Д") + " №" +
                СокрЛП(глПреобразоватьНомерДок(Док.НомерДок, 0, 0));
            КонецЕсли;
        КонецЕсли;
    
    КонецФункции
    
    это задействуется прописанным в ячейке формы
    Код:
    ДатаНомер(Запрос.Док)
    
    какой же у вас был релиз до этого?
  7. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Честно говоря не помню какой релиз был до этого, не обратил внимания на это.
    Вопрос поднялся след. образом:
    Есть СБИС-отчетность, в нее нужно загрузить в формате Exсel книги покупок и продаж на скрине показано как должно формироваться.
    Наш программист бухает уже 3-ю неделю. Я позвонил в сбис мне сказали нужно до 594 обновить и все будет тип топ ), я обновил и такой лаг вылез..
  8. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.438
    Симпатии:
    373
    Баллы:
    104
    а в чём собственно ошибка то?
    номер есть, дата есть
    может у вас там было исправлено как раз в коде ранее
    а при обновлении вернулось к исходному
  9. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    После обновления добавились необходимые отчеты
    Необходимо вывести номер; Дата
    [​IMG]
    Последнее редактирование: 10 апр 2015
  10. man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    В приведенном выше коде поправьте Возврат Формата как Вам надо, если я все правильно понял.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Там значение берется из реквизита ДатаНомерСчетаФактуры документа... Копайте в этом направлении
  12. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Если ТабОтчета.Док.Вид()="ЗаписьКнигиПокупок" Тогда
    ТабОтчета.Аванс = ТабОтчета.Док.Аванс;
    ТабОтчета.ДатаНомер = СокрЛП(ТабОтчета.Док.ДатаНомерСчетаФактуры);

    Если ТабОтчета.Док.Исправление = 1 Тогда
    ТабОтчета.НомерДатаИсправления = СокрЛП(ТабОтчета.Док.НомерДатаИсправленияСчетаФактуры);
    КонецЕсли;
    Как исправить (ТабОтчета.Док.ДатаНомерСчетаФактуры) на (ТабОтчета.Док.НомерДатаСчетаФактуры) ??
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Написать обработку, которая бы поменяла местами значения в реквизите ДатаНомерСчетаФактуры
    ИЛИ
    функцию, которая бы преобразовывала бы непосредственно в отчете
  14. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    не умею писать обработки и функции... может напишет кто?
    Есть желающие?
    Последнее редактирование: 13 апр 2015
  15. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Если ТабОтчета.Док.Вид()="ЗаписьКнигиПокупок" Тогда
    ТабОтчета.Аванс = ТабОтчета.Док.Аванс;
    ТабОтчета.ДатаНомер = СокрЛП(ТабОтчета.Док.ДатаНомерСчетаФактуры);

    поз=Найти(ТабОтчета.ДатаНомер,"№");
    Если поз>1 Тогда
    стр1=СокрЛП(Лев(ТабОтчета.ДатаНомер,поз-1));
    стр2=СокрЛП(Сред(ТабОтчета.ДатаНомер,поз+1));
    ТабОтчета.ДатаНомер=стр2+";"+стр1;
    КонецЕсли;
  16. TopicStarter Overlay
    evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Хряку и всем принимавшим участие Большое спасибо!
    Проблема решена.
    P.S. Хряк пиши телефон, закину деньги, как обещал..
    еще раз благодарю

Поделиться этой страницей