7.7 Формирование цен из Поступления ТМЦ

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Romikus, 4 апр 2007.

  1. TopicStarter Overlay
    Romikus
    Offline

    Romikus

    Регистрация:
    4 апр 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Подскажите, если можно, как осуществить формирование розничных цен из закупочных взятых из приходной накладной на товар?
    1С Предприятие 7,7 торговля+склад 9,2
  2. †omynoker
    Offline

    †omynoker

    Регистрация:
    17 авг 2006
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Если розничная цена получается расчетным путем, то в форме документа "Поступление ТМЦ" нажать кнопку "Действия" -> "Обновление цен в справочнике", далее интуитивно.
    Более детально описано в сопроводительной документации.
  3. user314159
    Offline

    user314159

    Регистрация:
    23 апр 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Если надо автоматически

    В модуле документа

    в Процедура ПроведениеПоРегистрам()

    Код:
    СпрЦены = СоздатьОбъект("Справочник.Цены");
    Цена1 = Нужный тип цен;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если глВернутьЦену(Номенклатура, Цена1, ДатаДок, ЦенаЦены, ЕдЦены, ВалЦены, НаценкаЦены, НайденнаяЦена)=1 Тогда
    Если ЦенаЦены <> (Цена/Коэффициент)	Тогда    
    СпрЦены.НайтиЭлемент(НайденнаяЦена);
    ПривязыватьСтроку(НомерСтроки);
    УстановитьРеквизитСправочника(СпрЦены.ТекущийЭлемент(),"Цена",ПолученнаяЦена(Цена),ДатаДок);
    УстановитьРеквизитСправочника(СпрЦены.ТекущийЭлемент(),"Единица",Номенклатура.БазоваяЕдиница,ДатаДок);
    Иначе
    Продолжить;
    КонецЕсли;
    Иначе               
    СпрЦены.ИспользоватьВладельца(Номенклатура);
    СпрЦены.Новый();
    СпрЦены.Валюта = Валюта;
    СпрЦены.ТипЦен = Цена1;
    СпрЦены.Записать();
    ПривязыватьСтроку(НомерСтроки);
    УстановитьРеквизитСправочника(СпрЦены.ТекущийЭлемент(),"Цена",ПолученнаяЦена(Цена),ДатаДок); 
    УстановитьРеквизитСправочника(СпрЦены.ТекущийЭлемент(),"Единица",Номенклатура.БазоваяЕдиница,ДатаДок);
    КонецЕсли;
    КонецЦикла;
    

Поделиться этой страницей