7.7 Форма справочника только для выбора

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Asttoxa, 18 май 2012.

  1. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста как сделать форму справочника ТОЛЬКО для выбора.
    То есть создаем отдельную форму. В теле формы я указал:

    Код:
    Процедура ПриПереносеЭлементаВДругуюГруппу(Элем,Групп)
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры	
    
    Процедура ПриВводеСтроки()
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    Процедура ПриУстановкеОтбора(Тип,Значение)
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    Процедура ПриРедактированииНовойСтроки()
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    Процедура ПриНачалеРедактированияСтроки()
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    Этого все равно мало. Можно редактировать элемент правой кнопкой.
    Регулировать Набором прав не предлагать, потому что один и тот же пользователь в этой форме может ТОЛЬКО выбирать а в другой форме может редактировать и создавать. Задумка такой :)

    Спасибо.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура ПриОткрытии()
    Форма.ТолькоПросмотр(1);
    КонецПроцедуры

Поделиться этой страницей