8.х Форма редактирования выражения в обработке по загрузке из табличного документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем palax, 12 ноя 2009.

  1. TopicStarter Overlay
    palax
    Offline

    palax

    Регистрация:
    12 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    ....Не могу понять как вызвать процедуру заполнения Фамилия,Имя Отчество в справочнике Физические лица в ЗУП при заполнении реквизита Наименование при помощи обработки по загрузке данных из табличного документа.Вот сама процедура.

    Код:
    Процедура НаименованиеПриИзменении(Элемент)
    
    ФИО = Наименование;
    
    Если ПустаяСтрока(Фамилия) Или ЭтоНовый() Тогда
    Фамилия		= ОбщегоНазначения.ВыделитьСлово(ФИО);
    Имя			= ОбщегоНазначения.ВыделитьСлово(ФИО);
    Отчество	= ОбщегоНазначения.ВыделитьСлово(ФИО);
    
    Если ЗначениеЗаполнено(Отчество) И Не ЗначениеЗаполнено(Пол) Тогда
    Пол = ПроцедурыУправленияПерсоналом.ПолучитьПол(Отчество);
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры;
    
    В форме редактирования выражения не получается.
    Чувствую что вопрос тупой, но ничего поделать не могу-опыта маловато!Извините...
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    ЕЕ не вызовишь. Эта обработка, тупо записывает данные в реквизиты. А поля Фамилия Имя Отчество - это просто элементы на форме. и данные после этой процедуры записываются в регистр сведений Фамилии Имя отчества работников. т.е если хочешь что бы в справочнике Физ лиц были заполнены эти поля то тебе надо заолнять этой же обработкой регистр сведений, который был упомянут выше.
  3. TopicStarter Overlay
    palax
    Offline

    palax

    Регистрация:
    12 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо БОЛЬШОЕ! Только я не понял какой процедурой заносятся эти данные в регистр сведений!
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    Код:
    // Процедура - обработчик события "ПередЗаписью" формы
    //
    Процедура ПередЗаписью(Отказ)
    
    // запись в регистр ФИО
    Если мНаборЗаписейФИО.Количество() = 0 Тогда
    ЗаписьНабора = мНаборЗаписейФИО.Добавить();
    ЗаписьНабора.Период		= ?(ЗначениеЗаполнено(ДатаРождения),ДатаРождения,'19000101');
    ЗаписьНабора.Фамилия	= Фамилия;
    ЗаписьНабора.Имя		= Имя;
    ЗаписьНабора.Отчество	= Отчество;
    КонецЕсли;
    
    КонецПроцедуры
    
  5. TopicStarter Overlay
    palax
    Offline

    palax

    Регистрация:
    12 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Draco-БОЛЬШОЕ СПАСИБО!

Поделиться этой страницей